Jump to content

Dan

Direction
  • Content Count

    29821
  • Joined

  • Last visited

Everything posted by Dan

  1. Je te signalais que le mot "recursive" est maintenant un mot réservé, depuis la version 10.2.0 de MariaDB. Il faut éditer le script d'installation et mettre des back quotes autour du terme recursive https://github.com/plegall/Piwigo-community/issues/36 SELECT id, type, category_id, user_album, `recursive`, create_subcategories, nb_photos, storage FROM piwigo_community_permissions WHERE (type = 'any_visitor')
  2. Bonjour et bienvenue à bord ! RECURSIVE est un mot réservé depuis MariaDB 10.2.0 ! Dan
  3. En Javascript je n'en sais rien, mais en php ceci fonctionne bien pour autant que tu n'aies pas de "<" dans le texte à conserver : <?php $subject='La Sivolière, Rue des Chenus, Saint-Bon-Tarentaise, France →︎ Genève aéroport (GVA)<a href="javascript:void(0);" class="new_check tooltip" title="Lieu dropp off : Adresse trouvée par google<br>04/04/2019 à 15:59 Système" rel="lieu_drop"><img src="https://www.monsite.limo/images/check_orange.png" rel="3_3539"></a><a href="javascript:void(0);" class="new_check tooltip" title="Lieu pick up : Adresse trouvée par google<br>04/04/2019 à 15:59 Système" rel="lieu_pickup"><img src="https://www.monsite.limo/images/check_orange.png" rel="3_3539"></a>'; $pattern='/([^<]*)<a.*<\/a>/'; $replacement='${1}'; $resultat = preg_replace($pattern, $replacement, $subject); print $resultat; ?> et affiche ceci : La Sivolière, Rue des Chenus, Saint-Bon-Tarentaise, France →︎ Genève aéroport (GVA)
  4. Peut-être que l'encryptage ne fonctionne pas chez Free. Je n'en ai aucune idée. Essaye des encryptage différents, par exemple sur cette page : https://httpd.apache.org/docs/2.4/fr/misc/password_encryptions.html
  5. Dans le fichier .env ... Est-ce que 192.168.64.1 est l'IP de ton serveur ? Dans ce cas il faut la remplacer par 127.0.0.1 parce que mysql ne permet des connexions que de 127.0.0.1 par défaut ! Uniquement dans le cas contraire .... Il faut commenter la ligne bind-adress = 127.0.0.1 dans le fichier de config de mysql, relancer ce dernier, et créer des utilisateurs distants (par exemple root@192.168.64.1 en plus de root@localhost) pour qu'ils puissent se connecter.
  6. Les erreurs de type SQLSTATE[HY000] [2002] Connection refused viennent le plus souvent d'une mauvaise configuration. Vérifie les paramètres suivants dans ton fichier .env DB_CONNECTION=mysql DB_HOST=127.0.0.1 DB_PORT=3306 DB_USERNAME=... (un compte sous mysql avec les permissions adéquates, souvent root !) DB_PASSWORD= ...
  7. Bonjour Alex, et bienvenue à bord de Webmaster-Hub !
  8. Assure-toi de ne pas copier de caractères supplémentaires lorsque tu copies cela dans le fichier .htpasswd. Assure-toi aussi que le chemin vers ce fichier est correctement renseigné dans le fichier .htaccess.
  9. Hello, Aenoa a raison. Tu ne pourras faire cela qu'en t'identifiant sous smtp sur le serveur au départ duquel tu veux envoyer les mails. Si cela passait sans authentification, cela voudrait dire que ce serveur est en "open relay" ... donc pas cool. Dan
  10. Bonjour zaebas59, et bienvenue à bord de Webmaster Hub !
  11. Un mot de passe devrait toujours être encrypté. Pour ce faite, il faut utiliser un générateur de mot de passe (un outil qui permet de les encrypter) Par exemple à cette page : http://www.htaccesstools.com/htpasswd-generator/ En choisissant toto comme identifiant et comme mot de passe, cela génère une ligne comme ceci : toto:$apr1$CLrqBkZh$wbjba74ksfO6qTuwbjrMO0 qu'on peut inclure dans le fichier .htpasswd J'avais il y a bien longtemps rédigé un article sur le fichier .htaccess, mais il reste d'actualité : https://www.webmaster-hub.com/publications/le-fichier-htaccess/
  12. Merci pour cette info, elle pourra éventuellement servir à d'autres qui ont le même souci que toi !
  13. Vu que cette erreur apparaît après une intervention d'Asus, il serait peut-être mieux de contacter leur service client et leur poser la question, non ?
  14. Php 7.0 est déjà obsolète lui aussi ! https://www.php.net/supported-versions.php Mais bon, il te permettrait tout de même d'être moins "hors des clous" que ta version actuelle et offre de meilleures performances. En ce qui concerne apache et mysql, no comment !
  15. Essaye en te connectant avec un compte local ! Si l'erreur est du côté de Microsoft, cela devrait mieux se passer.
  16. Il y a tellement de possibilités pour donner cette erreur générique, qu'il est quasiment impossible de les lister toutes. Une recherche google "erreur 0x80090016" donne de nombreuses pages de résultats pour des causes diverses. Par exemple ceci :
  17. Alors un sfc /scannow devrait résoudre tes problèmes
  18. Je te suggère tout de même de lire cette page concernant le malware des ordis Asus dû à des hackers : https://www.clubic.com/antivirus-securite-informatique/virus-hacker-piratage/virus-informatique/actualite-852767-malware-detecte-logiciel-ordinateurs-asus.html La page du site d'Asus (en anglais) : https://www.asus.com/News/hqfgVUyZ6uyAyJe1 Je te conseille de télécharger l'outil d'Asus, histoire d'être certain que ton ordi n'est pas impacté ! https://dlcdnets.asus.com/pub/ASUS/nb/Apps_for_Win10/ASUSDiagnosticTool/ASDT_v1.0.1.0.zip
  19. Quelle version de Windows 10 tournes-tu ? 1803 ? 1809 ? autre ? Lance "winver" dans une fenêtre de commande pour savoir. Tu peux toujours démarrer une fenêtre de commande en tant qu'administrateur, et lancer ceci : sfc /scannow cela réparera automatiquement les fichiers abimés de te version de windows.
  20. Je dirais: commence par le plus évident ! Tu tournes un php obsolète sur un Debian obsolète. Comment peut-on laisser aller un serveur ainsi ? J'imagine aisément que tout le reste doit l'être aussi, par exemple apache et mysql ! Tout ce que tu peux faire en ajoutant des plugins revient à ajouter un emplâtre sur une jambe de bois. Donc, Debian à jour (version 9) et php 7.x (7.3 est le top, et BEAUCOUP plus rapide si ta version de Prestashop le permet) Php7.x est plus de 2 fois plus rapide que php 5.4 !!! Si 7.3 est trop récent, 7.1 est déjà beaucoup mieux que 5.4 ! Si tu ne sais pas comment t'y prendre, envoie-moi un MP, qu'on en discute. Dan PS: un peu de lecture : https://kinsta.com/fr/blog/comparaison-php-7-hhvm/ ou encore, pour php 7.3 https://servebolt.com/wordpress-5-0-php-7-2-vs-php-7-3-performance-and-speed-benchmark/ Ils ne comparent qu'à partir de php 5.6, vu qu'ils n'ont pas voulu réveiller les dinosaures
  21. Bonsoir, En ce qui concerne la page la plus visitée, je remarque qu'elle pèse tout de même 3MB ... Il est clair que pour ceux qui ont un ADSL "en carton", comme moi, elle met tout de même plusieurs secondes à s'afficher. Pas de souci pour ceux qui ont un accès à 20Mbits/s ou plus. Difficile de répondre concernant ton serveur, sans en savoir un peu plus. Tu tournes quoi comme O/S, quel type de serveur, combien de coeurs (éventuellement la référence chez OVH) ? Il est clair que des disques SSD amélioreraient la vitesse d'accès, surtout pour des disques NVMe qu'OVH propose sur quantité de serveurs . Un disque SSD est typiquement 4 à 5 fois plus rapide qu'un disque SATA classique, et un disque SSD NVMe 3 à 5 fois plus rapide qu'un SSD classique. Donc oui, avec une certitude absolue, des disques SSD amélioreraient la vitesse. Dans les serveur OVH que je gère, un certain nombre tournent des disques SSD NVMe, et la différence est flagrante. Un de mes infogérés s'était trompé en commandant son serveur l'année dernière et avait pris des disques SATA classiques (2TB) alors que je lui conseillais des SSD NVMe. Au bout de quelques mois, il a changé vu que ses clients râlaient parce que leurs sites étaient bien trop lents et il a pris exactement le même modèle, même CPU, même RAM , mais avec SSD NVMe. Il a remarqué tout de suite la différence, et maintenant son serveur ronronne tranquillement et ses clients ne lui cassent plus les pieds !
  22. Bonjour Nicolas, et bienvenue à bord de Webmaster Hub. Pour quelqu'un qui n'aime pas parler de lui, tu nous as fait une bien belle présentation
  23. Et oui, TLD est l’abréviation de Top Level Domain ... c'est à remplacer comme tu devais remplacer site1 ou site2 Les forums et pages web ne changeront de toute manière pas leurs liens de manière automatique. Il faudra que tu les contactes... Donc à ta place, je ne me casserais pas trop la tête pour ça car cette page intermédiaire ne servirait à rien. L'important est de laisser cette règle en place, comme ça tes visiteurs seront redirigés sur le nouveau domaine. Et s'ils veulent mettre l'URL en favori, ce sera la nouvelle. De plus, les moteurs de recherche changeront leur base de données du fait de la redirection 301 ... donc la vie est belle, non ?
  24. Au temps pour moi ! Il y a des espaces en trop dans les flags ! Il faut mettre [R=301,QSA,L] au lieu de [R=301, QSA, L] Ce sont ces espaces qui causent l'erreur 500.... c'est vraiment trop bête ! Désolé ! C'est ce qui peut arriver lorsqu'on formate un texte pour le rendre plus lisible
  25. Avec le contenu de ton fichier .htaccess, on verrait plus clair Il est bien sauvegardé au format texte... pas un format word ou autre ? Et avec tes noms de domaines au lieu de site1 et site2 , ce serait plus évident aussi !
×
×
  • Create New...