Aller au contenu

ebouilleur

Webmaster Régulier
  • Compteur de contenus

    73
  • Inscrit(e) le

  • Dernière visite

Réputation sur la communauté

0 Neutre

Pour me contacter

  • Mon Site
    https://www.pelotes-compagnie.fr

Information du profil

  • Genre
    Homme

Visiteurs récents du profil

2 137 visualisations du profil
  1. http et https sur un même serveur

    Par défaut oui, mais je pense que je peux en acheter d'autres si il n'y a aucune autre solution. Edit, après vérif, on peut ajouter une interface réseau pour 3,53 € / mois
  2. http et https sur un même serveur

    C'est vraiment moche quand même...
  3. http et https sur un même serveur

    Manuellement, c'est une vm de gandi
  4. http et https sur un même serveur

    Syntax OK
  5. http et https sur un même serveur

    Ca ne change rien Et d'après ce que j'ai lu c'est normal, ca permet juste de bloqué l'accès au site quand le client n'est pas compatible
  6. http et https sur un même serveur

    On parle bien des vhost qui sont dans le répertoire sites-enabled? Si oui, j'en ai que 1, celui de p&c
  7. http et https sur un même serveur

    Je l'ai mis dans le httpd.conf (qui était vide) Mais ca ne change rien : https://www.boite2jeux.fr affiche toujours P&C Dans mon fichier ports.conf je n'avais pas NameVirtualHost *:443 alors que j'avais NameVirtualHost *: Je l'ai rajouté a tout hasard, mais ca n'a rien changé (même si je pensais bien que ca changerai rien). J'ai chercher sur plusieurs tuto/forum je ne vois pas ce qu'il peut manquer
  8. http et https sur un même serveur

    Bon je veux bien encore un peu d'aide. Mon serveur est la version 12.04 d'Ubuntu. A priori pas besoin de recompiler pour avoir le SNI, il est par défaut. Quand je regarder dans mods-enabled/ssl.conf, j'ai la directive SSLStrictSNIVHostCheck on qui est commenté. J'ai pas bien compris si je dois mettre SSLStrictSNIVHostCheck off quelque part ou non. J'ai essayé de le mettre dans le vhost de pelotes&compagnie mais ca ne change rien. Du coup je saisi pas trop ce que je dois faire :(
  9. http et https sur un même serveur

    Oui j'ai biensur relancé apache. je vais regardé en détail ton lien demain (pas envie de réfléchir sur de l'anglais maintenant ^^) Ok pour le duplicate, par contre, si google index des page de pelotes&compagnie sur d'autres domaine. Exemple, recherches juste "pelotes-compagnie.fr" sur google. et on a en 2ème résultat : Mentions légales | Pelotes & Compagnie https://city-bar.fr/index--mention.html‎ Le site pelotes-compagnie se réserve le droit de modifier à tout moment les ... L' ensemble du site internet www.pelotes-compagnie.fr est soumis au droit français ...
  10. http et https sur un même serveur

    j'ai essayé de mettre ça sur un de mes domaines qui n'est pas en https (en plus que la directive avec le *:80 bien entendu), mais ca ne fait pas la redirection, y a t il une erreur : <VirtualHost *:443> ServerName www.city-bar.fr Redirect permanent / http://www.city-bar.fr/ </VirtualHost>
  11. http et https sur un même serveur

    Pour info, dans mon fichier ports.conf j'ai : NameVirtualHost *:80 Listen 80 <IfModule mod_ssl.c> # If you add NameVirtualHost *:443 here, you will also have to change # the VirtualHost statement in /etc/apache2/sites-available/default-ssl # to <VirtualHost *:443> # Server Name Indication for SSL named virtual hosts is currently not # supported by MSIE on Windows XP. Listen 443 </IfModule> <IfModule mod_gnutls.c> Listen 443 </IfModule>
  12. http et https sur un même serveur

    et bien si je remet comme avant (c'est à dire *:80) et que je met pareil pour le https, soit *:443 c'est ce que j'avais fait initialement (avant de poster sur le forum). Le résultat est que chaque site en http fonctionne, mais si on met https devant n'importe lequel de mes site ca renvoie vers le site pelotes & compagnie
  13. http et https sur un même serveur

    Bon, c'est pire tous mes sites en http sont redirigés vers le 1er site que j'ai configuré sur ma machine (c'est à dire boite2jeux.fr), exemple http://www.ebouilleursurf.com Et si on attaque boite2jeux.fr en https ça affiche le site de peloites & compagnie
  14. http et https sur un même serveur

    En effet j'ai 1 ip pour tout le serveur. Voici ce que j'ai donc mon fichier de config pour le vhost de pelotes et compagnie : <VirtualHost *:80> Servername pelotes-compagnie.fr ServerAlias www.pelotes-compagnie.fr Redirect permanent / https://www.pelotes-compagnie.fr/ </VirtualHost> <VirtualHost www.pelotes-compagnie.fr:443> ServerName www.pelotes-compagnie.fr ServerAlias www.pelotes-compagnie.fr pelotes-compagnie.fr ServerAdmin support@ebouilleursurf.com DocumentRoot "/srv/d_Osiris/www/www.pelotes-compagnie.fr/htdocs" <Directory "/srv/d_Osiris/www/www.pelotes-compagnie.fr/htdocs"> Options -Indexes FollowSymLinks MultiViews AllowOverride All Order allow,deny Allow from all </Directory> ErrorLog /srv/d_Osiris/www/www.pelotes-compagnie.fr/logs/www.pelotes-compagnie.fr-error.log LogLevel error SetEnvIf Remote_Addr "127\.0\.0\.1" loopback CustomLog /srv/d_Osiris/www/www.pelotes-compagnie.fr/logs/www.pelotes-compagnie.fr-access.log combined env=!loopback ServerSignature On SSLEngine on SSLCertificateFile /etc/letsencrypt/live/www.pelotes-compagnie.fr/cert.pem SSLCertificateKeyFile /etc/letsencrypt/live/www.pelotes-compagnie.fr/privkey.pem SSLCertificateChainFile /etc/letsencrypt/live/www.pelotes-compagnie.fr/chain.pem # Intermediate configuration, tweak to your needs SSLProtocol all -SSLv2 -SSLv3 SSLCipherSuite ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:EC3-SHA:!KRB5-DES-CBC3-SHA SSLHonorCipherOrder on SSLCompression off </VirtualHost> Et pour l'autre vhost, j'ai : <VirtualHost *:80> ServerName www.boite2jeux.fr ServerAlias www.boite2jeux.fr boite2jeux.fr ServerAdmin postmaster@ebouilleursurf.com DocumentRoot "/srv/d_Osiris/www/www.boite2jeux.fr/htdocs" <Directory "/srv/d_Osiris/www/www.boite2jeux.fr/htdocs"> Options Indexes FollowSymLinks MultiViews AllowOverride All Order allow,deny Allow from all </Directory> ScriptAlias /cgi-bin/ /srv/d_Osiris/www/www.boite2jeux.fr/cgi-bin/ <Directory "/srv/d_Osiris/www/www.boite2jeux.fr/cgi-bin/"> AllowOverride None Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch Order allow,deny Allow from all </Directory> ErrorLog /srv/d_Osiris/www/www.boite2jeux.fr/logs/www.boite2jeux.fr-error.log LogLevel error SetEnvIf Remote_Addr "127\.0\.0\.1" loopback CustomLog /srv/d_Osiris/www/www.boite2jeux.fr/logs/www.boite2jeux.fr-access.log combined env=!loopback ServerSignature On Ca me parait bon en paramétrage, non? enfin je suppose que non, mais bon ^^
  15. http et https sur un même serveur

    Bonjour, Pour mon dernier site réalisé, j'ai voulu activé https pour faire plaisir à notre ami google. J'ai obtenu un certificat avec LE (let's encrypt). L'installation c'est bien déroulé et j'ai maintenant accès a mon site en https => https://www.pelotes-compagnie.fr Par contre, les autres sites de ma VM, qui ne sont pas en https pointe maintenant vers le contenu de ce nouveau site. Exemple, si je vais sur https://www.boite2jeux.fr ca m'affiche le site de pelotes et compagnie Je ne comprend pas trop pourquoi, et dans tous les cas, ce n'est pas top, que ce soit pour l visiteur ou pour le duplicate content Une idée? Merci
×