Jump to content

ebouilleur

Webmaster Régulier
  • Content Count

    74
  • Joined

  • Last visited

Everything posted by ebouilleur

  1. Bonjour, Pour une raison que j'ignore sur mon site www.nantesweb.net quand je veux partager une page sur facebook, il ne m'affiche pas d'image. Et si je teste l'outil il m'affiche bien l'url de la l'image og, mais en aperçu il ne m'affiche en effet rien : https://developers.facebook.com/tools/debug/sharing/ Pour l'avoir déjà fait avec un autre site https://www.pelotes-compagnie.fr/index--codes-promo.html , ca marche bien. Du coup je n'ai pas d'idée sur l'origine du problème. Et vous? Merci Yves
  2. Par défaut oui, mais je pense que je peux en acheter d'autres si il n'y a aucune autre solution. Edit, après vérif, on peut ajouter une interface réseau pour 3,53 € / mois
  3. C'est vraiment moche quand même...
  4. Manuellement, c'est une vm de gandi
  5. Ca ne change rien Et d'après ce que j'ai lu c'est normal, ca permet juste de bloqué l'accès au site quand le client n'est pas compatible
  6. On parle bien des vhost qui sont dans le répertoire sites-enabled? Si oui, j'en ai que 1, celui de p&c
  7. Je l'ai mis dans le httpd.conf (qui était vide) Mais ca ne change rien : https://www.boite2jeux.fr affiche toujours P&C Dans mon fichier ports.conf je n'avais pas NameVirtualHost *:443 alors que j'avais NameVirtualHost *: Je l'ai rajouté a tout hasard, mais ca n'a rien changé (même si je pensais bien que ca changerai rien). J'ai chercher sur plusieurs tuto/forum je ne vois pas ce qu'il peut manquer
  8. Bon je veux bien encore un peu d'aide. Mon serveur est la version 12.04 d'Ubuntu. A priori pas besoin de recompiler pour avoir le SNI, il est par défaut. Quand je regarder dans mods-enabled/ssl.conf, j'ai la directive SSLStrictSNIVHostCheck on qui est commenté. J'ai pas bien compris si je dois mettre SSLStrictSNIVHostCheck off quelque part ou non. J'ai essayé de le mettre dans le vhost de pelotes&compagnie mais ca ne change rien. Du coup je saisi pas trop ce que je dois faire :(
  9. Oui j'ai biensur relancé apache. je vais regardé en détail ton lien demain (pas envie de réfléchir sur de l'anglais maintenant ^^) Ok pour le duplicate, par contre, si google index des page de pelotes&compagnie sur d'autres domaine. Exemple, recherches juste "pelotes-compagnie.fr" sur google. et on a en 2ème résultat : Mentions légales | Pelotes & Compagnie https://city-bar.fr/index--mention.html‎ Le site pelotes-compagnie se réserve le droit de modifier à tout moment les ... L' ensemble du site internet www.pelotes-compagnie.fr est soumis au droit français ...
  10. j'ai essayé de mettre ça sur un de mes domaines qui n'est pas en https (en plus que la directive avec le *:80 bien entendu), mais ca ne fait pas la redirection, y a t il une erreur : <VirtualHost *:443> ServerName www.city-bar.fr Redirect permanent / http://www.city-bar.fr/ </VirtualHost>
  11. Pour info, dans mon fichier ports.conf j'ai : NameVirtualHost *:80 Listen 80 <IfModule mod_ssl.c> # If you add NameVirtualHost *:443 here, you will also have to change # the VirtualHost statement in /etc/apache2/sites-available/default-ssl # to <VirtualHost *:443> # Server Name Indication for SSL named virtual hosts is currently not # supported by MSIE on Windows XP. Listen 443 </IfModule> <IfModule mod_gnutls.c> Listen 443 </IfModule>
  12. et bien si je remet comme avant (c'est à dire *:80) et que je met pareil pour le https, soit *:443 c'est ce que j'avais fait initialement (avant de poster sur le forum). Le résultat est que chaque site en http fonctionne, mais si on met https devant n'importe lequel de mes site ca renvoie vers le site pelotes & compagnie
  13. Bon, c'est pire tous mes sites en http sont redirigés vers le 1er site que j'ai configuré sur ma machine (c'est à dire boite2jeux.fr), exemple http://www.ebouilleursurf.com Et si on attaque boite2jeux.fr en https ça affiche le site de peloites & compagnie
  14. En effet j'ai 1 ip pour tout le serveur. Voici ce que j'ai donc mon fichier de config pour le vhost de pelotes et compagnie : <VirtualHost *:80> Servername pelotes-compagnie.fr ServerAlias www.pelotes-compagnie.fr Redirect permanent / https://www.pelotes-compagnie.fr/ </VirtualHost> <VirtualHost www.pelotes-compagnie.fr:443> ServerName www.pelotes-compagnie.fr ServerAlias www.pelotes-compagnie.fr pelotes-compagnie.fr ServerAdmin support@ebouilleursurf.com DocumentRoot "/srv/d_Osiris/www/www.pelotes-compagnie.fr/htdocs" <Directory "/srv/d_Osiris/www/www.pelotes-compagnie.fr/htdocs"> Options -Indexes FollowSymLinks MultiViews AllowOverride All Order allow,deny Allow from all </Directory> ErrorLog /srv/d_Osiris/www/www.pelotes-compagnie.fr/logs/www.pelotes-compagnie.fr-error.log LogLevel error SetEnvIf Remote_Addr "127\.0\.0\.1" loopback CustomLog /srv/d_Osiris/www/www.pelotes-compagnie.fr/logs/www.pelotes-compagnie.fr-access.log combined env=!loopback ServerSignature On SSLEngine on SSLCertificateFile /etc/letsencrypt/live/www.pelotes-compagnie.fr/cert.pem SSLCertificateKeyFile /etc/letsencrypt/live/www.pelotes-compagnie.fr/privkey.pem SSLCertificateChainFile /etc/letsencrypt/live/www.pelotes-compagnie.fr/chain.pem # Intermediate configuration, tweak to your needs SSLProtocol all -SSLv2 -SSLv3 SSLCipherSuite ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:EC3-SHA:!KRB5-DES-CBC3-SHA SSLHonorCipherOrder on SSLCompression off </VirtualHost> Et pour l'autre vhost, j'ai : <VirtualHost *:80> ServerName www.boite2jeux.fr ServerAlias www.boite2jeux.fr boite2jeux.fr ServerAdmin postmaster@ebouilleursurf.com DocumentRoot "/srv/d_Osiris/www/www.boite2jeux.fr/htdocs" <Directory "/srv/d_Osiris/www/www.boite2jeux.fr/htdocs"> Options Indexes FollowSymLinks MultiViews AllowOverride All Order allow,deny Allow from all </Directory> ScriptAlias /cgi-bin/ /srv/d_Osiris/www/www.boite2jeux.fr/cgi-bin/ <Directory "/srv/d_Osiris/www/www.boite2jeux.fr/cgi-bin/"> AllowOverride None Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch Order allow,deny Allow from all </Directory> ErrorLog /srv/d_Osiris/www/www.boite2jeux.fr/logs/www.boite2jeux.fr-error.log LogLevel error SetEnvIf Remote_Addr "127\.0\.0\.1" loopback CustomLog /srv/d_Osiris/www/www.boite2jeux.fr/logs/www.boite2jeux.fr-access.log combined env=!loopback ServerSignature On Ca me parait bon en paramétrage, non? enfin je suppose que non, mais bon ^^
  15. Bonjour, Pour mon dernier site réalisé, j'ai voulu activé https pour faire plaisir à notre ami google. J'ai obtenu un certificat avec LE (let's encrypt). L'installation c'est bien déroulé et j'ai maintenant accès a mon site en https => https://www.pelotes-compagnie.fr Par contre, les autres sites de ma VM, qui ne sont pas en https pointe maintenant vers le contenu de ce nouveau site. Exemple, si je vais sur https://www.boite2jeux.fr ca m'affiche le site de pelotes et compagnie Je ne comprend pas trop pourquoi, et dans tous les cas, ce n'est pas top, que ce soit pour l visiteur ou pour le duplicate content Une idée? Merci
  16. Bonsoir, Je ne pense jamais avoir réouvert de post si vieux... mais as tu trouver un script faisant ton bonheur? pour ma part je ne trouve pas
  17. Bon au final ca donne ca : SELECT f.id_facture, p.id_prestation, f.numero_facture, f.date_facture, c.nom, c.ville, sum( ( p.prix_htva + ( ( p.prix_htva * p.tva ) /100 ) ) * p.quantite ) AS prixFacture FROM facture f LEFT OUTER JOIN client c ON ( f.id_client = c.id_client ) LEFT OUTER JOIN prestation p ON ( f.id_facture = p.id_facture ) WHERE f.id_membre =1 GROUP BY f.id_facture LIMIT 0 , 30 Merci
  18. Bonsoir Jacques, OK merci je vois l'idée et en effet ca fonctionne mieux Après c'est sur que je vais pas faire un somme de tva, mais le principe est ok Merci
  19. Bonjour, J'ai 3 tables : client, facture, prestation. Je souhaite afficher un tableau récapitulatif qui doit m'afficher le prix de la facture, cad la somme de toutes les prestations d'un facture (qui pour ne pas simplifier n'ont pas le meme montant de tva et/ou de quantité) Pour le moment, j'essaye deja d'avoir la somme juste des montant htva et deja je coince. Voila ce que ca donne : SELECT f.id_facture, f.numero_facture, f.date_facture, c.nom, c.ville, p.quantite, p.prix_htva, p.tva FROM facture as f LEFT JOIN client AS c ON (f.id_client=c.id_client) LEFT JOIN (SELECT SUM(prix_htva) FROM prestation GROUP BY f.id_facture) AS p ON (f.id_facture=p.id_facture) WHERE f.id_membre=$sess_id_pseudo order by $choix_order_by desc limit $limite,$nombre Phpmyadmin me sort que les colonnes p.quantite, p.prix_htva, p.tva n'existe pas Une idée? Merci
  20. J'avais vu qu'il s'agisait de frame, mais si tu clic sur le lien google et que tu fais F5, tu arrive sur le marcher du travail, alors que tu as juste rafraichi la page, donc l'url n'est pas modifier, alors comment ca fonctionne?
  21. Tu vois quel site ? Essayes en passant par google alors, avec le recherche "argent facile". en général c'est le 1er site sponsorisé
  22. Bonjour, J'aimerais vous exposer un truc curieux. Si vous aller pour la toute 1ere fois sur le site : http://www.gagner-bcp-argent.com/ vous verrez un site d'astuce d'argent ET si vous y revenez, il y a un autre site sur le travail du marché. Je me demande lintérêt de faire ca. Je me demande aussi comment c'est géré (car a priori c'est pas un cookie) IL y a plusieurs site de ce genre. Recherche sur google "argent facile" et il y en a dans les liens sponsorisés. PS : je n'ai pas trouvé de meilleur catégorie pour mon post. Merci
  23. Merci, je vais regarder le log dont tu parles Mais dans mon css, non, tout est bon
  24. Bonjour, Suite a des soucis sur mon serveur (des plantages toujours incompris), j'ai activé les log de chacun de mes sites. ET j'ai des lignes incompréhensible, et j'ai besoin de vos lumières. Dans mon fichier de log je peux lire : [Fri Nov 12 15:14:03 2010] [error] [client 79.83.211.5] File does not exist: /home/ebouilleur/pet-racing/beta/home, referer: http://beta.pet-racing.fr/css/style.css [Fri Nov 12 16:43:21 2010] [error] [client 79.83.211.5] File does not exist: /home/ebouilleur/pet-racing/www/home, referer: http://beta.pet-racing.fr/quartziam.php 1. Je comprend pas le File does not exist: /home/ebouilleur/pet-racing/beta/home vu que dans mon fichier style.css il n'y a rien qui s'appelle home 2. Idem que le 1 sauf que la c'est encore plus bizarre car : />http://beta.pet-racing.fr pointe sur /home/ebouilleur/pet-racing/beta et />http://www.pet-racing.fr pointe sur /home/ebouilleur/pet-racing/www Et la il me dit que ma page qui est sur mon sous-domaine n'arrive pas a trouvé le répertoire home du sous domaine www Une idée svp? Merci
×
×
  • Create New...