Jump to content

philippe69

Hubmaster
  • Posts

    496
  • Joined

  • Last visited

Everything posted by philippe69

  1. Bonjour, Quelqu'un a-t-il déjà testé litespeedtech en remplacement de Apache ou Nginx. J'ai entendu dire que c'est vraiment beaucoup plus rapide. L'avez vous testé sur PrestaShop ? Le tuning est-il compliqué ? Merci de vos retours Cordialement Philippe69
  2. Bonjour à tous, J'ai plusieurs serveurs sur lesquels tournent des Prestashop. Je voudrais avoir le Prestashop sur 1 serveur et les images du répertoire /img hébergées sur une 2ième machine. J'ai monté avec sshfs le répertoire ~/img distant des images sur le point de montage local ~/img. Quand je fait ls ~/img sur le serveur du Prestashop je vois bien le répertoire ~/img de l'autre machine : OK Quand je tape l'url directe : http://149.202.xxx.xxx/~user/img/logo-1486549260.jpg : ça s'affiche dans le navigateur : OK Mon problème est que quand je tape l'url http://monsite.com/img/uneimage.jpg j'ai un message FORBIDEN Forbidden You don't have permission to access /img/logo-1486549260.jpg on this server. Auriez-vous une idée pourquoi je n'ai pas les droits ? Merci de votre aide Philippe69
  3. Je viens de faire le test et ... ça ne change rien. En fait, j'ai l'impression que la RewriteCond ne match pas.
  4. Bonjour à tous, je cherche à rediriger des url d'un ancien site vers des URL Prestashop L'ancienne forme est : http://www.culturevap.fr/PBSCProduct.asp?ItmID=12256839 La nouveau site devient : http://www.culturevap.fr/home/213-orion-v3.html J'ai donc mis ça dans mon .htaccess RewriteCond %{QUERY_STRING} ItmID=12256839 RewriteRule ^.*$ home/213-orion-v3.html? [L,R=301,NC] Mais la redirection n'est pas prise en compte Auriez-vous une idée ? Merci d'avance Philippe
  5. En fait on n'en sait rien. Il y a 65000 mail en attente de départ.
  6. Non pas tous. Certains sont du spam. Mais les spam n'arrivent pas mais doivent quand même partir. Or, notre problème, c'est les mails qui ne partent pas
  7. Bonjour, Je travaille avec sanjb sur ce sujet (ce serveur est infogéré par Dan 393918). Ce que je ne comprends pas c'est pourquoi ces mails ne partent pas ? En effet, je vois bien la liste des mail en attente de départ, mails il devraient quand même partir ? Philippe
  8. Merci de ta réponse. Mias comme je ne m'en sort pas, j'ai écrit ma propre mini couche soap...
  9. Bonjour, J'ai testé un serveur soap avec un client windows (SoapUI). Il me génère une trame un échange répondant ce que j'attends. J'ai écrit un client SOAP en php pour faire la même chose mais qui lui ne fonctionne pas. Entre les 2 tests, les entêtes sont identiques. Voici la trame que je génère ; elle est refusée : <?xml version="1.0" encoding="UTF-8"?> <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlso.../soap/envelope/" xmlns:ns1="urn:productinfo"> <SOAP-ENV:Body> <ns1:read> <product>article</product> <quantity>10</quantity> </ns1:read> </SOAP-ENV:Body> </SOAP-ENV:Envelope>'; Voici la trame générée par soapUI. Elle est acceptée : <?xml version="1.0" encoding="UTF-8"?> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlso.../soap/envelope/" xmlns:urn="urn:productinfo"> <soapenv:Header/> <soapenv:Body> <urn:read> <product>article1</product> <quantity>1</quantity> </urn:read> </soapenv:Body> </soapenv:Envelope> Pour que ma trame soit acceptée, il suffit que je remplace "ns1" par "urn". Or je ne sait pas comment modifier ça en php. Voici mon code try { $strheader = "Content-Type: text/xml;charset=UTF-8\r\n" . 'SOAPAction: ""' . "\r\n" . "Accept: text/plain\r\n" . "Host: xxxxxxxxxx\r\n" . "Connection: Keep-Alive\r\n" . "User-Agent: Apache-HttpClient/4.1.1 (java 1.5)\r\n"; $context = stream_context_create( array("http"=>array( 'method' => 'POST', "header"=> $strheader), ) ); $options = array( 'login' => "xxxx", 'password' => 'xxx', 'location' => 'xxxxxxxxxxx/wssproductinfo.cgi', "soap_version" => SOAP_1_1, 'trace' => 1, 'cache_wsdl' => 'WSDL_CACHE_NONE', 'stream_context' => $context ); $client = new SoapClient( "http://www.xxxxxxx/productinfo.wsdl", $options ); echo '<pre>' . print_r( $client->read( array('product'=>"article",'quantity'=>'10') ),true ); } catch (Exception $e) { echo "Trace= <pre>".print_r($e->getTrace(),true) . '<br>'; } 1/ Auriez vous une idée pour modifier mon "ns1" en "urn" ? Merci de votre aide Cordialement Philippe
  10. Merci de vos chaleureux soutiens. Je me suis simplement trompé de thread dans ma réponse
  11. Merci Dan. Je vais essayer
  12. Je n'ai rien rebooté ni eu aucune action sur le serveur. C'est bien ce qui m'inquiète.
  13. Bonjour, Ce matin, à la connexion sur mon site web, j'ai le message : Table xxx is marked as crashed and should be repaired. J'ai réussi à la réparer. Mais à votre avis, comment ce type d'erreur peut-il se produire ? Que dois-je faire pour l'éviter ? Merci d'avance Cordialement Philippe69
  14. Merci à tous. C'est bien ce que je craignais. Il n'y a pas vraiment de solution hors celle que vous citez et que j'avais envisagé. Cordialement Philippe
  15. Bonjour, et merci de ta réponse. Mais ce n'est pas ça. En fait, je voudrais éviter de faire apparaître du code js dans mais page mais plutôt utiliser des fichiers externes js. Ceci afin d'éviter le code directement à l'intérieur des pages html. Quand tu fais ça : <script type="text/javascript">code js</script> les moteurs de recherche lisent le code et doivent d'abord faire le ménage pour passer ensuite au référencement. alors que quand tu fais: <script language="text/javascript" type="text/javascript" src="monjs.js"></script>' les moteurs ne cherchent pas à lire l'inclusion de fichier js. C'est pour cela que je souhaite un mix des 2 : - je souhaite conserver la notation src="xxxx" - mais mon xxx n'est pas un fichier mais mon code js généré dynamiquement ...hummmm, pas facile à expliquer
  16. Bonjour à tous, Mon code PHP génère dynamiquement du code javascript. actuellement pour inclure ce code je fais un classique : <script language="text/javaScript" type="text/javascript">Mon code js</script>' Le problème c'est que ça fait des pages trop chargées en js et peu optimisées pour le référencement. Est-il possible, sans passer par la création d'un fichier dans lequel je mets mon js, d'envoyer le code comme si c'était un fichier séparé. exemple: en php le code js est créé dans $fichierjs puis l'appel se ferai avec un truc du genre <script language="text/javaScript" type="text/javascript" src=<"'.$fichierJS.'"></script>' J'ai volontairement mis "<" derrière "src=" pour faire comme une redirection de flux Merci de votre aide Cordialement
  17. Tu te rends bien compte que ce que tu demandes c'est loin d'être simple !!! Je tente une ébauche de code. tu mets un "onchange" sur ton id "type" qui va vers le javascript suivant : function OnMySelectChange(el) { if( $$('#type').value == 'Montagne' ) { $A($$('#sous-rubrique' +' input'))[0].value = 'Alpes'; $A($$('#sous-rubrique' +' input'))[1].value = 'Jura'; $A($$('#sous-rubrique' +' input'))[2].value = 'Vosges'; } if( $$('#type').value == 'Mer' ) { ... } } Tu inclus le framework prototype.js pour éviter les getelementbyid..style.name trop pénibles à utilise. Il te servira pour plein de chose si tu développes en js http://www.prototypejs.org/ Quand tu maîtriseras prototype tu pourras facilement remplacer $A($$('#sous-rubrique' +' input'))[0].value = 'Alpes'; par de l'Ajax $A($$('#sous-rubrique' +' input'))[0].value = new Ajax.Request('/ton/url', {...
  18. Bonjour à tous, J'ai besoin d'écrire un programme sur windows qui va accéder à une base de données via ODBC. Je connais bien le C mais ça fait un éternité que je n'ai pas écrit de code. Ce programme n'a pas d'interface fenêtre. J'aurais donc besoin de plusieurs conseils : - quel compilateur choisir avec une prise en main pas trop prise de tête, incluant si possible un débogueur - un exemple de code C pour accéder à un base via ODBC : ouverture, ordre sql, gestion d'erreur, fermeture. En option, je vais aussi écrire un web service basé sur soap avec un contrat WSDL. Ce serait génial si vous aviez une exemple de code. Merci à vous Cordialement Philippe
  19. Bonjour, je viens de changer de PC et mon MySQL local (easyphp) me crée des soucis. J'essaye de créer des tables avec des champs not null mais cet attribut n'est pas pris en compte. exemple CREATE TABLE IF NOT EXISTS `address_format` ( `address_format_id` int(11) NOT NULL auto_increment, `address_format` varchar(128) NOT NULL default '', `address_summary` varchar(48) NOT NULL default '', PRIMARY KEY (`address_format_id`) ) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=6 ; et je récupère : Champ Type Interclassement Attributs Null Défaut Extra Action address_format_id int(11) Oui NULL auto_increment address_format varchar(128) latin1_swedish_ci Oui address_summary varchar(48) latin1_swedish_ci Oui Impossible de positionne le champ not null. Aurriez vous une idée ? Merci Cordialement
  20. Bonjour, J'utilise un logiciel (Talend) qui enchaine des commandes dans une console SSH. Ce logiciel chaine les commandes et les sépare avec des ";" sur une ligne du bash Pour me connecter sur ma base de données j'ai besoin d'enchainer l'ordre de connexion MYSQL et des commandes sql Par exemple mysql -t --host=localhost --user=xxxx --password=xxxx vanille_db; select * from categories; quit; exit; sur une seule ligne : mysql -t --host=localhost --user=xxxx --password=xxxx vanille_db;select * from categories;quit;exit; Mais il faut forcer la validation entre la connexion et le select. Comment forcer la validation de la connexion ? Merci à tous Cordialement
  21. Devant la difficulté à régler mon problème, j'ai passé mon appli sur un de mes serveurs infogérés. Donc maintenant ça fonctionne. Dan, je te solliciterai dans qq temps pour mettre en place une sauvegarde automatique. Merci de votre aide Cordialement
  22. Mon NAT est configuré (enfin je crois) Afin de travailler par étape, je voudrais d'abord essayer de fonctionner correctement sur mon réseau local, à savoir d'un pc du réseaulocal vers mon serveur sur le même réseau. Si ça fonctionne, je passerai dans un 2ième temps par l'extérieur. Comment tester d'un PC local vers mon serveur local, quoi vérifier ? merci
  23. Bonjour, J'ai une freebox derrière laquelle il y a un routeur smc. Sur le réseau local un serveur Fedora9 hébergeant un site web. 1/ En local (du serveur vers lui même) sur 127.0.0.1 mon serveur répond. sur 192.168.2.192 mon serveur répond. 2/ depuis une autre machine du réseau local sur 192.168.2.192 mon serveur NE répond PAS. Pouvez-vous m'aider svp ? Merci Cordialement
  24. Bonjour, Je ne peux pas te donner l'adresse parce que j'ai rapidement mis en place une solution de contournement. Donc actuellement il n'y a rien à voir. Regarde celui là http://www.mara-materiaux.com/ . Il est beaucoup plus simple mais c'est le même type de page. Voici une description plus précise de ce qui se passe : Ce site inclut un menu en css qui permet grâce au survol de la souris sur les catégories et sous catégories d'afficher les menus. Les pages changeant à chaque rafraîchissement, le menu est chargé à chaque fois. Le site dont je parle génère automatiquement 2500 lignes de menus pour plus de 400Ko. Par contre toute la boîte constituant le menu est mise en cache sur le serveur pour ne pas être recalculée à chaque appel. Le problème de lenteur de chargement n'est que sur ie. Je pensais que si il y avait une solution pour mettre en cache cette boîte de menu, cela améliorerait bien la vitesse de chargement. Je ne vois pas comment faire.
×
×
  • Create New...