Jump to content

jaguar2007

Membre
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutre
  1. Bon j'ai fini par trouver une alternative pour ce probleme rencontré. J'ai enlevé la commande Wmode (qui au passage, ralentit fortement l'animation sur mon mac). J'ai agrandi ma zone d'animation flash, et intégré sur un calque le fond de la page. Ca fonctionne nickel. Je déconseille vivement cette fonction wmode avec des formulaires qui peut jouer des tours sur certains browser. Encore merci à 5ive et Norseb pour leur aide :-)
  2. Bon, j'ai enlevé le wmode transparent, mais cela ne me satisfait guère. 5ive : ton alternative à forcer les caractères "@" et "." pourrait etre pas mal, seulement, imaginons que l'internaute s'appelle jeancharles.linternaute_AT_free.fr ca va poser le meme probleme pour le "." dans jeancharles.linternaute. Car, la majorité des utilisateurs à 90% vont effacer les caractères avant de taper leurs coordonnées, ce qui sera de nouveau un probleme. N'y aurait-il pas une troisième autre alternative ?
  3. 5five >Par contre ce qui à l'air différent avec ton problème par rapport au mien, sauf mauvaise lecture de ma part, c'est que toi ça fonctionne avec firefox sous mac et pas sur PC ? et pas sur IE7 sur PC, par contre sur IE6 pas de soucis ? C'est tout a fait exact 5ive, sous mac, avec safari et firefox, la saisie des caractères marche très bien. Sous PC, c'est le chaos : IE6 : la saisie des caractères "@" et "." marche IE7 : Ces memes caractères ne marchent pas Firefox 1.5.0.4 PC : Ces memes caractères ne marchent pas Effectivement, comme tu le dis dans un post plus bas, mon site utilise la fonction wmode:transparent Il me reste donc à tester tes deux solutions alternatives. Je vois cà cet après midi, et vous tiens informé 5ive, je confirme ce que tu disais, je viens de tester mon swf seul dans firefox PC (via Virtual PC sous mac), et il n'y a plus de problemes de caractères. Au passage, ton site est très réussi, bravo Jag'
  4. Pour ceux ou celles qui voudraient m'aider dans ces problèmes d'affichage de caractères, je peux tout a fait mon transmettre le lien du site en privé. Merci d'avance pour votre aide Amitiés Jaguar2007
  5. Bonjour à tous, Je cherche sur les forums depuis plusieurs jours la réponse à mon problème, mais en vain. Le voici : J'ai réalisé un site internet tout en flash. Dans la rubrique "Contact" de ce site, j'y ai mis plusieurs champs (nom, adresse mail, message) qui forment donc un formulaire et qui permet de laisser un message. Ce message est ensuite recu dans la boite mail du site. Pour que cela fonctionne, j'ai utilisé bien évidemment un fichier php (fourni sur internet) que j'ai nommé email.php, voici le code entier du fichier (toutes les lignes y figurent) : <?php /***************************************************\ * PHP 4.1.0+ version of email script. For more * information on the mail() function for PHP, see * [url="http://www.php.net/manual/en/function.mail.php"]http://www.php.net/manual/en/function.mail.php[/url] \***************************************************/ // First, set up some variables to serve you in // getting an email. This includes the email this is // sent to (yours) and what the subject of this email // should be. It's a good idea to choose your own // subject instead of allowing the user to. This will // help prevent spam filters from snatching this email // out from under your nose when something unusual is put. $sendTo = "balabala_AT_balabala.fr"; $subject = "My Flash site reply"; // variables are sent to this PHP page through // the POST method. $_POST is a global associative array // of variables passed through this method. From that, we // can get the values sent to this page from Flash and // assign them to appropriate variables which can be used // in the PHP mail() function. // header information not including sendTo and Subject // these all go in one variable. First, include From: $headers = "From: " . $_POST["name"] ." ". $_POST["lastname"] . "<" . $_POST["email"] .">\r\n"; // next include a replyto $headers .= "Reply-To: " . $_POST["email"] . "\r\n"; // often email servers won't allow emails to be sent to // domains other than their own. The return path here will // often lift that restriction so, for instance, you could send // email to a hotmail account. (hosting provider settings may vary) // technically bounced email is supposed to go to the return-path email $headers .= "Return-path: " . $_POST["email"]; // now we can add the content of the message to a body variable $message = $_POST["message"]; // once the variables have been defined, they can be included // in the mail function call which will send you an email mail($sendTo, $subject, $message, $headers); ?> Tout fonctionne à merveille sous mac, Safari comme Firefox, mais sur PC, il y a un problème : l'utilisateur ne peut pas taper son caractère "arobase" et le "point ." se transforme en ":" dans les champs du formulaire si il est sous Firefox ou IE 7. En revanche, sous IE 6 PC, la saisie des caractères dans le formulaire fonctionne correctement. Avez vous une idée du probleme ? Merci d'avance Amitiés Jag'
×
×
  • Create New...