Jump to content

sparh

Hubmaster
  • Content Count

    522
  • Joined

  • Last visited

Everything posted by sparh

  1. sparh

    Question sur RAM

    Merci d'avoir regardé. Mais dans l'onglet Processus j'ai la même valeur, entre 20 et 30% d'utilisation de la RAM, soit dans mon cas 6000 à 9000Mo de mes 31,9Go disponible. Or si j’additionne les chiffres de l'onglet Processus colonne Mémoire je tombe 3-4000Mo utilisés. C'est pas très grave mais je me demandais si quelqu'un savait d'où vient cette différence ?!
  2. sparh

    Question sur RAM

    Bonjour, Mon PC est équipé de 32Go de RAM mais je trouve qu'il ralentit assez rapidement (après 4-5 heures d'utilisation) Quand je vais dans le gestionnaire des taches il m'indique 20% de RAM utilisé ce qui fait environ 6000Mo. Mais ce même gestionnaire des taches m'indique qu'il n'y a que 2400Mo de RAM utilisé. Auriez-vous une idée d'où peux venir cette différence ?
  3. Bonjour, Faute de frappe j'utilise bien usr/bin/ffmpeg pour lancer https://arlo.netgear.com/hmsweb/users/devices/startStream il faut d'abord se connecter puis obtenir les infos sur les caméras (ce que j'arrive à faire) (instructions). Une fois les infos récupérées on peux lancer https://arlo.netgear.com/hmsweb/users/devices/startStream et si tout est bon obtient une réponse du type {"data":{"url":"rtmps://vzwow97-z1-prod.ar.arlo.com:80/vzmodulelive?egressToken=47028611_eef4_4eb9_b36c_ec2f20376f6a&userAgent=web&cameraId=52M1847EB5000_1557902583880"},"success":true} ou {"data":{"url":"rtsp://vzwow32-z1-prod.ar.arlo.com:443/vzmodulelive/52M1847EB5000_1557902909000?egressToken=8240472d_0adc_48bd_b602_edd9b04bbd5b&userAgent=iOS&cameraId=52M1847EB5000_1557902909000"},"success":true} suivant le user agent utilisé. Ca fonctionne avec FFMPEG 4.1.3 (merci Dan), j'enregistre bien mon flux vidéo. Actuellement je doit stopper l'enregistrement pour pouvoir lire ma vidéo enregistré, mais j''aimerai l'afficher en temps réel, avez vous une idée
  4. Bonjour, j'essai d'afficher le stream de mes caméras Arlo (https://arlo.netgear.com) sur mon site. En utilisant https://github.com/jeffreydwalter/arlo/issues/7#issuecomment-349160421 et http://robertogallea.com/blog/netgear-arlo-api j'arrive à me connecter et afficher la dernière image prises par caméra. Maintenant j'aimerai afficher la vidéo en live. En lançant https://arlo.netgear.com/hmsweb/users/devices/startStream j'obtien une url du type rtsp://vzwow147-z1-prod.ar.arlo.com:443/arlomotionrecord/MyCameraID?egressToken=c08b401a_95e8_4fc6_8eee_05d7529d1853&userAgent=iOS&cameraId=MyCameraID Bien sur MyCameraId correspond à l'id de caméra Ensuite j'essai de sauvegarder ce flux via ffmpeg shell_exec('/usr/share/ffmpeg -re -i "rtsp://vzwow32-z1-prod.ar.arlo.com:443/arlomotionrecord/MyCameraId?egressToken=df9376e3_351d_436d_b1f9_451daa3bd571&userAgent=iOS&cameraId=MyCameraId" -acodec copy -vcodec copy "/home//Video/files/test.mp4" 2> /home/Video/files/out.txt') Et la ça marche pas!! Voici ce que j'ai dans mon fichier out.txt ffmpeg version 3.2.12-1~deb9u1 Copyright (c) 2000-2018 the FFmpeg developers built with gcc 6.3.0 (Debian 6.3.0-18+deb9u1) 20170516 configuration: --prefix=/usr --extra-version='1~deb9u1' --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libebur128 --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared libavutil 55. 34.101 / 55. 34.101 libavcodec 57. 64.101 / 57. 64.101 libavformat 57. 56.101 / 57. 56.101 libavdevice 57. 1.100 / 57. 1.100 libavfilter 6. 65.100 / 6. 65.100 libavresample 3. 1. 0 / 3. 1. 0 libswscale 4. 2.100 / 4. 2.100 libswresample 2. 3.100 / 2. 3.100 libpostproc 54. 1.100 / 54. 1.100 rtsp://vzwow32-z1-prod.ar.arlo.com:443/arlomotionrecord/MyCamearId?egressToken=df9376e3_351d_436d_b1f9_451daa3bd571&userAgent=iOS&cameraId=MyCamearId: Invalid data found when processing input Une idée de ce qui ne vas pas ?
  5. Bonjour, je galère pour trouver la bonne expression régulière pour transformer (en javascript) La Sivolière, Rue des Chenus, Saint-Bon-Tarentaise, France →︎ Genève aéroport (GVA)<a href="javascript:void(0);" class="new_check tooltip" title="Lieu dropp off : Adresse trouvée par google<br>04/04/2019 à 15:59 Système" rel="lieu_drop"><img src="https://www.monsite.limo/images/check_orange.png" rel="3_3539"></a><a href="javascript:void(0);" class="new_check tooltip" title="Lieu pick up : Adresse trouvée par google<br>04/04/2019 à 15:59 Système" rel="lieu_pickup"><img src="https://www.monsite.limo/images/check_orange.png" rel="3_3539"></a> En La Sivolière, Rue des Chenus, Saint-Bon-Tarentaise, France →︎ Genève aéroport (GVA) Si vous avez une idée ça m'aiderai beaucoup!!
  6. Hello c'est fait sur le site live gmc-limousines.ch Merci en tous cas
  7. J'ai finalement trouvé en mettant line-height: 8px; au div contenant l'image
  8. Bonjour, justement il n'y a pas de padding pour le div parent et la taille de l'image est fixée en amont (width:100%) J'ai essayé de mettre height:100% du coup l'image se déforme et j'ai toujours mon espace en bas
  9. Bonjour, voilà plusieurs heures que je galère sans trouver d'où vient le petit espace sous les photos ? Voilà la page : https://www.gmc-limo.eu/Services/ Si quelqu'un aurait un peu de temps pour regarder et m'aider ce serait super cool Merci d'avance
  10. Bonjour, j'ai crée un dossier /Marketing à la racine de mon site et je vais y mettre des fichiers html. J'aimera faire en sorte de pouvoir appeler les documents via monsite.fr/ledocument.html au lieu de monsite.fr/Marketing/ledocument.html Est ce possible ? Merci d'avance
  11. J'avais oublié de préciser que j'utilise PHPMailer et j'ai trouvé la solution ici http://stackoverflow.com/questions/3708153/send-email-with-phpmailer-embed-image-in-body $mail->AddEmbeddedImage('img/2u_cs_mini.jpg', 'logo_2u'); <img src="cid:logo_2u" alt="" />
  12. Bonjour, j'envoie des emails de confirmation d'inscription a mes utilisateurs avec une signature contenant une image. L'email est en html et jusqu’à aujourd'hui mon image était sur mon serveur. Maintenant j’aimerai que l'image soit en pièce jointe. Pas de souci pour mettre la pièce jointe mais impossible de l'afficher au bon endroit dans mon email, savez vous comment faire ? Avant ce qui marche très bien <div> <img src="http://monsite.com/monImage.jpg /><br> M société etc.. </div> Maintenant mais ça ne marche pas (l'image est bien en pièce jointe de l'email) <div> <img src="monImage.jpg /><br> Ma société etc.. </div> Auriez vous une idée ? Merci d'avance
  13. Hello je devais être très fatigué hier car ce matin ça fonctionne! Merci pour votre aide
  14. Merci de m'aider mais dans les 2 cas j'obtient null (j'avais déja testé pour voir si $values['location'] retournait un tableau). $retour = json_decode($values,true); var_dump($retour); $retour = json_decode($values); var_dump($retour); Voici un exemple de ma variable $values si jamais et la manière dont je la récupère $values = file_get_contents('php://input'); //si je fait un echo $values j'obtient ça {"location":[{"coords":{"speed":13.78999996185303,"longitude":6.106461001741759,"latitude":46.20269310378117,"accuracy":10,"heading":239.3082580566406,"altitude":424.451416015625,"altitudeAccuracy":6},"is_heartbeat":false,"extras":{"action":""},"is_moving":true,"odometer":1763.193420100596,"uuid":"4C420566-1F55-4A89-83DA-F03D5C9E2423","activity":{"type":"unknown","confidence":100},"battery":{"level":0.28,"is_charging":false},"timestamp":"2016-10-19T09:13:12.000Z"},{"coords":{"speed":12.67000007629395,"longitude":6.105477869875073,"latitude":46.20219555439851,"accuracy":10,"heading":217.1203918457031,"altitude":424.525390625,"altitudeAccuracy":6},"is_heartbeat":false,"extras":{"action":""},"is_moving":true,"odometer":1857.093282904583,"uuid":"603BD74E-7324-4C17-B21A-E16C7430BC3D","activity":{"type":"unknown","confidence":100},"battery":{"level":0.28,"is_charging":false},"timestamp":"2016-10-19T09:13:19.000Z"}]}
  15. Bonjour, oui j'aimerai pouvoir récupérer toutes les données. Je convertit en array car après avoir bien galéré c'est le seul moyen que j'ai trouvé pour y arriver Quand je fais un count($retour) dans tous les cas j'obtient 1. Dans le cas ou location est un tableau rien ne fonctionne la fonction json_decode me renvoi null.
  16. Bonjour, j'ai un plugin de géolocalisation qui envoi des données au serveur les données sont envoyés sous cette forme: $values = '{ "location": { "coords": { "latitude": [Float], "longitude": [Float] "accuracy": [Float] "speed": [Float|-1], "heading": [Float/0-360|-1], "altitude": [Float] }, "extras": { // <-- optional extras. @see #getCurrentPosition for details "foo": "bar" }, "activity": { "type": [still|on_foot|walking|running|in_vehicle|on_bicycle|unknown], "confidence": [Int/0-100%] }, "geofence": { // <-- Present only if a geofence was triggered at this location "identifier": [String], "action": [String ENTER|EXIT] }, "battery": { "level": [Float/0-1], "is_charging": [Boolean] }, "timestamp": [ISO-8601 UTC], // eg: "2015-05-05T04:31:54.123Z" "uuid": [String], // <-- Universally unique identifier "event" [String], // <-- motionchange|geofence|heartbeat "is_moving": [Boolean], // <-- The motion-state when location was recorded (@deprecated; use #event) "is_heartbeat: [Boolean], // <-- If this location was recorded during heartbeat mode. "odometer": [Float/meters] } }'; Pour le traitement j'utilise : $retour = json_decode($values,true); $speed = $retour['location']['coords']['speed']; $longitude = $retour['location']['coords']['longitude']; etc... Mais dans certains cas "location" est un tableau, ce qui donne $values = '{ "location": [{ "coords": { "latitude": [Float], "longitude": [Float] "accuracy": [Float] "speed": [Float|-1], "heading": [Float/0-360|-1], "altitude": [Float] }, "extras": { // <-- optional extras. @see #getCurrentPosition for details "foo": "bar" }, "activity": { "type": [still|on_foot|walking|running|in_vehicle|on_bicycle|unknown], "confidence": [Int/0-100%] }, "geofence": { // <-- Present only if a geofence was triggered at this location "identifier": [String], "action": [String ENTER|EXIT] }, "battery": { "level": [Float/0-1], "is_charging": [Boolean] }, "timestamp": [ISO-8601 UTC], // eg: "2015-05-05T04:31:54.123Z" "uuid": [String], // <-- Universally unique identifier "event" [String], // <-- motionchange|geofence|heartbeat "is_moving": [Boolean], // <-- The motion-state when location was recorded (@deprecated; use #event) "is_heartbeat: [Boolean], // <-- If this location was recorded during heartbeat mode. "odometer": [Float/meters] }, { "coords": { "latitude": [Float], "longitude": [Float] "accuracy": [Float] "speed": [Float|-1], "heading": [Float/0-360|-1], "altitude": [Float] }, "extras": { // <-- optional extras. @see #getCurrentPosition for details "foo": "bar" }, "activity": { "type": [still|on_foot|walking|running|in_vehicle|on_bicycle|unknown], "confidence": [Int/0-100%] }, "geofence": { // <-- Present only if a geofence was triggered at this location "identifier": [String], "action": [String ENTER|EXIT] }, "battery": { "level": [Float/0-1], "is_charging": [Boolean] }, "timestamp": [ISO-8601 UTC], // eg: "2015-05-05T04:31:54.123Z" "uuid": [String], // <-- Universally unique identifier "event" [String], // <-- motionchange|geofence|heartbeat "is_moving": [Boolean], // <-- The motion-state when location was recorded (@deprecated; use #event) "is_heartbeat: [Boolean], // <-- If this location was recorded during heartbeat mode. "odometer": [Float/meters] } etc...] }'; Auriez vous une idée de comment récupérer les données ? Merci d'avance
  17. Salut figure { width:490px; height:320px; border:1px solid #000; } .img-licence { font-size:0.7em; text-align:right; font-style:italic; -moz-transform-origin: 100% 0%; -moz-transform: rotate(90deg); -o-transform-origin: 100% 0%; -o-transform: rotate(90deg); -webkit-transform-origin: 100% 0%; -webkit-transform: rotate(90deg); transform-origin: 100% 0%; transform: rotate(90deg); float:right; padding-right:10px; } Je sais pas si c'est parfait mais c'est déjà mieux
  18. Juste pour info j'avais ouvert un ticket chez Infomaniak et voilà leur réponse : D'après quelques billets de blog technique (https://www.bram.us/2014/10/26/php-5-6-automatically-populating-http_raw_post_data-is-deprecated-and-will-be-removed-in-a-future-version/), il semblerait que ceci apparaissent même lorsque l'on ne fait pas de requêtes POST.Vous pouvez soit ignorer ces entrées, soit tenter une migration sous PHP7, ou essayer de mettre l'instruction qui va bien dans un .htaccess étant donné que c'est modifiable par dossier comme décrit içi (http://php.net/manual/en/ini.core.php#ini.always-populate-raw-post-data ).
  19. Bonjour, dans mes logs je trouve systématiquement cette erreur : stderr: PHP message: PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0, J'ai longtemps cherché et ce que je ne comprends pas c'est que je n'utilise nulle part la variable $HTTP_RAW_POST_DATA. J'ai fini par découvrir que c'est la fonction suivante qui crée l'erreur. Auriez vous une idée d'ou peux venir le problème ? Merci d'avance function api($url,$email,$pass,$id_api,$method,$data=''){ $http_auth_ident = $email.':'.$pass ; $url_curl = $url.'/api/?method='.$method.'&id='.$id_api; // connexion $timeout = '15'; $ch = curl_init($url_curl); curl_setopt($ch, CURLOPT_USERAGENT, "CURL"); curl_setopt($ch, CURLOPT_FRESH_CONNECT, true); curl_setopt($ch, CURLOPT_TIMEOUT, $timeout); curl_setopt($ch, CURLOPT_CONNECTTIMEOUT, $timeout); if (preg_match('`^https://`i', $url_curl)) { curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false); curl_setopt($ch, CURLOPT_SSL_VERIFYHOST, 0); } curl_setopt($ch, CURLOPT_FOLLOWLOCATION, false); curl_setopt($ch, CURLOPT_RETURNTRANSFER, true); // Définition de la méthode d'authentification du serveur curl_setopt($ch, CURLOPT_HTTPAUTH, CURLAUTH_ANY); // Définition des identifiants curl_setopt($ch, CURLOPT_USERPWD, $http_auth_ident); if($data != '') { curl_setopt($ch, CURLOPT_POST, true); curl_setopt($ch, CURLOPT_POSTFIELDS, http_build_query($data)); } curl_setopt($ch, CURLOPT_HTTPHEADER, array('Content-Type: text/plain')); $response = curl_exec($ch); $info = curl_getinfo($ch); curl_close($ch); return $response ; }
  20. Merci je me suis tourné vers Dell avec une docking station http://accessories.euro.dell.com/sna/productdetail.aspx?c=ch&l=fr&s=dhs&cs=chdhs1&sku=452-BCCJ
  21. Merci pour vos réponses. J'ai cherché un PC tout fait avec 3 hdmi ou 1 VGA + 2 HDMI mais je n'ai pas trouvé.
  22. Bonjour, je cherche un bon PC de bureau qui pourrait supporter 3 écrans Full HD. N'y connaissant pas grand chose en hardware je fait appelle a vous. Merci d'avance
  23. Bonjour peux être une idée avec l’événement scroll de jquery (mais je ne suis pas un spécialiste en js non plus!). var is_scrolled = 'no'; $(document).ready(function() { // désactive le scroll automatique car l'utilisateur à bougé lui même le scroll $(document).on("scroll",'#message_box', function() { is_scrolled = 'yes'; }); $('.toggle_chat').hide(); // load messages every 3000 milliseconds from server. load_data = {'fetch':1}; window.setInterval(function(){ $.post('chatbox/shout.php', load_data, function(data) { $('.message_box').html(data); if(is_scrolled == 'no') $("#message_box").animate({scrollTop: $("#message_box")[0].scrollHeight},2000);//Autoscroll to bottom of div }); }, 3000); }); Après il faudra trouver une solution pour réactiver le scroll automatique en remettant is_scrolled = 'no'; (peux être au bout d'un certain temps ou si l'utilisateur scroll de lui même en bas de #message_box) Bonne journée
×
×
  • Create New...