Jump to content

Chamz

Hubmaster
  • Content Count

    141
  • Joined

  • Last visited

Community Reputation

0 Neutre

About Chamz

  • Birthday 04/09/1969

Profile Information

  • Genre
    Homme
  • Localisation
    France
  1. Bonjour, Mon forum IPB et des modules à la dernière version ont été mis à jour récemment. Maintenant, lorsque j'envoie des fichiers contenant des caractères accentués dans IP Downloads, le nom du fichier est modifié ("caractères accentués" devient, par exemple, "caractères accentués") et le lien est brisé... Par contre, aucun problème pour envoyer ce genre de fichiers sur le forum. Selon IPS, la seule solution pour régler ce problème est de passer en UTF-8 (au lieu de l'actuel iso-8859-1). Quelle serait la meilleure façon de procéder, sachant que ma base de données fait 8 giga ?
  2. Pour %wa, j'ai des valeurs entre 0 et 9.8, parfois plus. Les autres (%hi, %si, %st) sont la plupart du temps entre 0 et 0.2. J'ai mis une petite vidéo ici : />http://www.andrejorge.info/divers/2503/pwh.mp4 Une autre ici : />http://www.andrejorge.info/divers/2203/top-22-03-10-a.mp4 Merci !
  3. Bonjour ! Je me suis aperçu que my.cnf et httpd.conf n'avaient pas été optimisés... Je m'en suis occupé (en demandant de l'aide pour httpd.conf) et depuis le serveur tourne sans problème, avec deux ou trois surcharges par moments le soir (la charge monte à 4 puis redescend à 1.50 à peu près). Par contre, la valeur %ni reste constamment élevée (entre 2 et 9 et monte parfois à 17, alors que %us est entre 0 et 0.4 et %sy entre 0.2 et 2). Un ps aux >liste.txt me donne des résultats tels que celui-ci : root 19601 0.0 0.1 127812 25104 ? Ss 00:00 0:17 lfd - sleeping nobody 21546 0.7
  4. Il y a eu des discussions sur le forum d'IPS à propos d'un bug d'IPB que certains rencontreraient en fonction de l'environnement dans lequel IPB tourne. J'ai contacté ceux qui ont eu des problèmes apparemment identiques aux miens, mais pas de réponse pour l'instant. En ce qui concerne mon serveur : CentOS release 5.4 Kernel : 2.6.27.10-grsec-xxxx-grs-ipv4-64 Apache 2.0.63 PHP 5.2.9 MySQL 5.0.89 eAccelerator 0.9.6-rc1 Je vais voir donc si je peux mettre à jour eAccelerator et sinon installer xCache à la place. Et demander à ce qu'Apache soit mis à jour.
  5. Bonjour ! La charge du serveur a augmenté brusquement hier et je l'ai enregistrée : http://www.andrejorge.info/divers/18-03/ J'y ai mis également deux fichiers vidéo qui montrent le top quand j'ai 450 et 590 utilisateurs en ligne.
  6. Je vais m'occuper de superviser l'utilisation CPU ce soir. Les techniciens de Platinum Server Management pensent eux que ma base de données faisant 8 GB, ce sont les opérations effectuées sur cette base de données qui consomment le plus de ressources et sont la cause du problème... MySQL utilise entre 10 et 30% du CPU et il est arrivé, rarement, que cela monte à 80% et même 100%. J'ai enregistré quelques TOP (d'avant les changements effectués sur MaxRequestsPerChild ) et je les ai publiés ici : />http://www.andrejorge.info/divers/16-03/ Ce sont 3 courtes vidéos qui correspondent
  7. Voici le fichier .htaccess corrigé : J'ajouterai plus tard ce qu'il faut écrire pour les blogs, les annonces, etc.
  8. Hello ! Mon problème est en fait un problème de configuration du serveur... Pour ce qui est d'Apache, j'ai mis MaxRequestsPerChild à 15000 (au lieu de 10000) et du coup le nombre de processus reste autour de 350 (au lieu de monter jusqu'à plus de 500, suivi d'un plantage). Je vais encore tenter d'améliorer les choses de ce côté là. Pour régler le problème de la charge du serveur, j'ai remplacé le fichier .htaccess de IPB par un autre fourni par un client d'IPS, voir ici : http://www.webmaster-hub.com/topic/48955-mod-rewrite-et-ipb-3/
  9. Bonjour ! Pour réduire la charge du serveur, il serait possible de modifier le fichier .htaccess d'IPB (avec mod_rewrite activé). Ceci : <IfModule Mod_rewrite.c> Options-MultiViews RewriteEngine On RewriteBase / RewriteCond% (REQUEST_FILENAME)!-F RewriteCond% (REQUEST_FILENAME)!-D RewriteRule. / index.php [L] </IfModule> devient : <IfModule mod_rewrite.c> Options -MultiViews RewriteEngine On RewriteBase / RewriteRule ^forum/(.*) /index.php?/forum/$1 [L] RewriteRule ^topic/(.*) /index.php?/topic/$1 [L] RewriteRule ^user/(.*) /index.php?/user/$1 [L]
  10. 5 fois, depuis 2003. Oui, c'est sûr. Les sociétés françaises que j'ai contacté ont refusé : trop de clients. Tu peux m'envoyer une adresse par MP s'il te plaît ?
  11. Non, je n'ai pas bbclone. J'ai eu un autre problème hier, alors que je n'avais que 400 membres en ligne et que je ne m'y attendais pas. j'ai pu enregistrer quelques tops : />http://www.andrejorge.info/divers/12-03/ Il y a toute une série de httpd utilisant 25% du CPU... Dans mysql-slow.log il n'y a rien qui corresponde à ce problème. Le script donné ci-dessus pour tracer ce qui utilise toute la CPU peut-il être utilisé tel quel ? Ou dois-je le modifier ? (ce dont je ne suis pas capable en fait, pour le moment). Merci.
  12. Non, je n'ai pas de graphes de l'utilisation CPU avant le changement de version... C'est en soirée que j'ai le plus de visiteurs : en moyenne 200 la journée et 600 le soir (sauf le mercredi ou j'ai 500/600 utilisateurs toute la journée). Pour aujourd'hui, j'ai 56 940 pages vues pour le moment (contre 151 299 hier, et 93 078 mardi). La solution est donc de prendre un serveur plus puissant ?...
  13. Bonjour ! J'ai publié les informations que j'ai pu obtenir à cette adresse : />http://www.andrejorge.info/divers/11-03/ Qu'en pensez-vous ? Merci pour votre aide,
  14. Je tente de bannir (momentanément) les Google bots et les autres moteurs de recherche pour voir ce que ça donne : je n'ai eu qu'un redémarrage de httpd, mais je n'ai pas réussi a obtenir des informations à ce moment là... Avec environ 450 utilisateurs en ligne en ce moment, la charge du serveur tourne autour de 0.80 et pas de surcharge du serveur pour le moment... Je vais devoir attendre demain soir pour essayer d'avoir d'autres informations. Y a-t-il un moyen de savoir si les Google bots sont la cause de mes problèmes ? Merci !
×
×
  • Create New...