Jump to content

Chamz

Hubmaster
  • Content Count

    141
  • Joined

  • Last visited

Community Reputation

0 Neutre

About Chamz

  • Birthday 04/09/1969

Profile Information

  • Genre
    Homme
  • Localisation
    France
  1. Bonjour, Mon forum IPB et des modules à la dernière version ont été mis à jour récemment. Maintenant, lorsque j'envoie des fichiers contenant des caractères accentués dans IP Downloads, le nom du fichier est modifié ("caractères accentués" devient, par exemple, "caractères accentués") et le lien est brisé... Par contre, aucun problème pour envoyer ce genre de fichiers sur le forum. Selon IPS, la seule solution pour régler ce problème est de passer en UTF-8 (au lieu de l'actuel iso-8859-1). Quelle serait la meilleure façon de procéder, sachant que ma base de données fait 8 giga ? Merci pour votre aide.
  2. Pour %wa, j'ai des valeurs entre 0 et 9.8, parfois plus. Les autres (%hi, %si, %st) sont la plupart du temps entre 0 et 0.2. J'ai mis une petite vidéo ici : />http://www.andrejorge.info/divers/2503/pwh.mp4 Une autre ici : />http://www.andrejorge.info/divers/2203/top-22-03-10-a.mp4 Merci !
  3. Bonjour ! Je me suis aperçu que my.cnf et httpd.conf n'avaient pas été optimisés... Je m'en suis occupé (en demandant de l'aide pour httpd.conf) et depuis le serveur tourne sans problème, avec deux ou trois surcharges par moments le soir (la charge monte à 4 puis redescend à 1.50 à peu près). Par contre, la valeur %ni reste constamment élevée (entre 2 et 9 et monte parfois à 17, alors que %us est entre 0 et 0.4 et %sy entre 0.2 et 2). Un ps aux >liste.txt me donne des résultats tels que celui-ci : root 19601 0.0 0.1 127812 25104 ? Ss 00:00 0:17 lfd - sleeping nobody 21546 0.7 0.1 241512 28000 ? SN 18:32 0:06 /usr/local/apache/bin/httpd -k start -DSSL root 21974 0.0 0.0 90176 3368 ? Ss 18:34 0:00 sshd: root_AT_pts/0 root 21997 0.0 0.0 68116 1580 pts/0 Ss 18:34 0:00 -bash nobody 22239 0.8 0.1 236056 24960 ? SN 18:35 0:05 /usr/local/apache/bin/httpd -k start -DSSL nobody 22294 0.5 0.1 241592 26432 ? SN 18:35 0:03 /usr/local/apache/bin/httpd -k start -DSSL root 23106 0.0 0.0 177024 10100 ? SNs Mar23 0:23 /usr/local/apache/bin/httpd -k start -DSSL root 24759 0.0 0.0 74804 1180 ? Ss Jan22 0:58 crond root 26317 0.0 0.0 0 0 ? S 13:05 0:02 [pdflush] root 29157 0.0 0.0 62624 1212 ? Ss Mar12 0:00 /usr/sbin/sshd root 29604 0.0 0.0 43384 7156 ? SN 18:01 0:00 /usr/local/cpanel/bin/leechprotect root 29610 0.0 0.0 109336 3964 ? SN 18:01 0:00 /usr/local/apache/bin/httpd -k start -DSSL root 30442 0.0 0.0 64324 2040 ? S 18:23 0:00 /usr/sbin/exim -q root 30535 0.0 0.0 28724 4060 ? S Mar09 0:00 /etc/authlib/authProg root 30651 0.0 0.0 0 0 ? S 05:14 0:00 [pdflush] root 31698 0.9 0.0 12880 1312 pts/0 S+ 18:36 0:05 top -d 1 nobody 31776 0.7 0.1 240656 26172 ? SN 18:37 0:03 /usr/local/apache/bin/httpd -k start -DSSL nobody 31777 0.5 0.1 241776 29628 ? SN 18:37 0:02 /usr/local/apache/bin/httpd -k start -DSSL nobody 31790 0.4 0.1 240756 27008 ? SN 18:37 0:02 /usr/local/apache/bin/httpd -k start -DSSL nobody 31808 0.6 0.1 241756 30844 ? SN 18:37 0:03 /usr/local/apache/bin/httpd -k start -DSSL nobody 31881 1.0 0.1 240996 29656 ? SN 18:38 0:04 /usr/local/apache/bin/httpd -k start -DSSL nobody 31900 0.3 0.1 241516 27840 ? SN 18:38 0:01 /usr/local/apache/bin/httpd -k start -DSSL nobody 31903 0.6 0.1 235660 21244 ? SN 18:38 0:02 /usr/local/apache/bin/httpd -k start -DSSL nobody 31904 0.5 0.1 234304 20948 ? SN 18:38 0:02 /usr/local/apache/bin/httpd -k start -DSSL nobody 31927 0.6 0.1 241080 28464 ? SN 18:38 0:02 /usr/local/apache/bin/httpd -k start -DSSL nobody 31943 0.6 0.1 237376 23136 ? SN 18:38 0:02 /usr/local/apache/bin/httpd -k start -DSSL nobody 31947 0.5 0.1 234864 20644 ? SN 18:38 0:02 /usr/local/apache/bin/httpd -k start -DSSL nobody 32163 0.6 0.1 234912 23964 ? SN 18:39 0:02 /usr/local/apache/bin/httpd -k start -DSSL nobody 32176 0.4 0.1 235660 21732 ? SN 18:39 0:01 /usr/local/apache/bin/httpd -k start -DSSL nobody 32187 0.7 0.1 234608 19344 ? SN 18:39 0:02 /usr/local/apache/bin/httpd -k start -DSSL nobody 32190 0.8 0.1 240484 26836 ? SN 18:39 0:03 /usr/local/apache/bin/httpd -k start -DSSL nobody 32198 0.5 0.1 240644 25940 ? SN 18:39 0:01 /usr/local/apache/bin/httpd -k start -DSSL nobody 32207 0.8 0.1 234296 21680 ? SN 18:39 0:02 /usr/local/apache/bin/httpd -k start -DSSL nobody 32210 0.6 0.1 239492 27936 ? SN 18:39 0:02 /usr/local/apache/bin/httpd -k start -DSSL root 32491 0.0 0.0 28724 4060 ? S Mar09 0:00 /etc/authlib/authProg Il y a beaucoup de lignes nobody 31776 0.7 0.1 240656 26172 ? SN 18:37 0:03 /usr/local/apache/bin/httpd -k start -DSSL Que peut-on en conclure ? Merci !
  4. Il y a eu des discussions sur le forum d'IPS à propos d'un bug d'IPB que certains rencontreraient en fonction de l'environnement dans lequel IPB tourne. J'ai contacté ceux qui ont eu des problèmes apparemment identiques aux miens, mais pas de réponse pour l'instant. En ce qui concerne mon serveur : CentOS release 5.4 Kernel : 2.6.27.10-grsec-xxxx-grs-ipv4-64 Apache 2.0.63 PHP 5.2.9 MySQL 5.0.89 eAccelerator 0.9.6-rc1 Je vais voir donc si je peux mettre à jour eAccelerator et sinon installer xCache à la place. Et demander à ce qu'Apache soit mis à jour.
  5. Bonjour ! La charge du serveur a augmenté brusquement hier et je l'ai enregistrée : http://www.andrejorge.info/divers/18-03/ J'y ai mis également deux fichiers vidéo qui montrent le top quand j'ai 450 et 590 utilisateurs en ligne.
  6. Je vais m'occuper de superviser l'utilisation CPU ce soir. Les techniciens de Platinum Server Management pensent eux que ma base de données faisant 8 GB, ce sont les opérations effectuées sur cette base de données qui consomment le plus de ressources et sont la cause du problème... MySQL utilise entre 10 et 30% du CPU et il est arrivé, rarement, que cela monte à 80% et même 100%. J'ai enregistré quelques TOP (d'avant les changements effectués sur MaxRequestsPerChild ) et je les ai publiés ici : />http://www.andrejorge.info/divers/16-03/ Ce sont 3 courtes vidéos qui correspondent aux moment ou j'avais environ 500 utilisateurs en ligne et qui montrent que la charge du server est autour de 1,5%, puis il y a une augmentation subite (et à peine visible car l'affichage ne dure pas longtemps) de %sy, et imédiatement après, PRM arrête Apache. Le fait d'avoir fait passer MaxRequestsPerChild à 15000 à fait que je n'ai plus cette augmentation subite de %sy. Par contre, maintenant,c'est la valeur %ni qui est plus élevée qu'avant.
  7. Voici le fichier .htaccess corrigé : J'ajouterai plus tard ce qu'il faut écrire pour les blogs, les annonces, etc.
  8. Hello ! Mon problème est en fait un problème de configuration du serveur... Pour ce qui est d'Apache, j'ai mis MaxRequestsPerChild à 15000 (au lieu de 10000) et du coup le nombre de processus reste autour de 350 (au lieu de monter jusqu'à plus de 500, suivi d'un plantage). Je vais encore tenter d'améliorer les choses de ce côté là. Pour régler le problème de la charge du serveur, j'ai remplacé le fichier .htaccess de IPB par un autre fourni par un client d'IPS, voir ici : http://www.webmaster-hub.com/topic/48955-mod-rewrite-et-ipb-3/
  9. Bonjour ! Pour réduire la charge du serveur, il serait possible de modifier le fichier .htaccess d'IPB (avec mod_rewrite activé). Ceci : <IfModule Mod_rewrite.c> Options-MultiViews RewriteEngine On RewriteBase / RewriteCond% (REQUEST_FILENAME)!-F RewriteCond% (REQUEST_FILENAME)!-D RewriteRule. / index.php [L] </IfModule> devient : <IfModule mod_rewrite.c> Options -MultiViews RewriteEngine On RewriteBase / RewriteRule ^forum/(.*) /index.php?/forum/$1 [L] RewriteRule ^topic/(.*) /index.php?/topic/$1 [L] RewriteRule ^user/(.*) /index.php?/user/$1 [L] RewriteRule ^forum-(.*)/(.*) /index.php?/forum-$1/$2 [L] </IfModule> Sauf que les liens dont l'url est &quot;http://www.monsite.com/index" ne fonctionnent plus (celui de l'onglet "Forums" par exemple). On m'a suggéré d'ajouter au fichier .htaccess : RewriteRule ^index /index.php?/index [L] mais j'obtiens un page blanche lorsque je clique sur l'onglet "Forums". Quelqu'un aurait-il une solution, ou des pistes ? Merci.
  10. 5 fois, depuis 2003. Oui, c'est sûr. Les sociétés françaises que j'ai contacté ont refusé : trop de clients. Tu peux m'envoyer une adresse par MP s'il te plaît ?
  11. Non, je n'ai pas bbclone. J'ai eu un autre problème hier, alors que je n'avais que 400 membres en ligne et que je ne m'y attendais pas. j'ai pu enregistrer quelques tops : />http://www.andrejorge.info/divers/12-03/ Il y a toute une série de httpd utilisant 25% du CPU... Dans mysql-slow.log il n'y a rien qui corresponde à ce problème. Le script donné ci-dessus pour tracer ce qui utilise toute la CPU peut-il être utilisé tel quel ? Ou dois-je le modifier ? (ce dont je ne suis pas capable en fait, pour le moment). Merci.
  12. Non, je n'ai pas de graphes de l'utilisation CPU avant le changement de version... C'est en soirée que j'ai le plus de visiteurs : en moyenne 200 la journée et 600 le soir (sauf le mercredi ou j'ai 500/600 utilisateurs toute la journée). Pour aujourd'hui, j'ai 56 940 pages vues pour le moment (contre 151 299 hier, et 93 078 mardi). La solution est donc de prendre un serveur plus puissant ?...
  13. Bonjour ! J'ai publié les informations que j'ai pu obtenir à cette adresse : />http://www.andrejorge.info/divers/11-03/ Qu'en pensez-vous ? Merci pour votre aide,
  14. Je tente de bannir (momentanément) les Google bots et les autres moteurs de recherche pour voir ce que ça donne : je n'ai eu qu'un redémarrage de httpd, mais je n'ai pas réussi a obtenir des informations à ce moment là... Avec environ 450 utilisateurs en ligne en ce moment, la charge du serveur tourne autour de 0.80 et pas de surcharge du serveur pour le moment... Je vais devoir attendre demain soir pour essayer d'avoir d'autres informations. Y a-t-il un moyen de savoir si les Google bots sont la cause de mes problèmes ? Merci !
×
×
  • Create New...