Aller au contenu

shkyo

Membre
  • Compteur de contenus

    5
  • Inscrit(e) le

  • Dernière visite

Réputation sur la communauté

0 Neutre

Information du profil

  • Genre
    Homme
  • Localisation
    Bretagne
  1. C'est bien noté! Quand à Notepad++ je regarderais ma config à l'occasion, je ne l'utilise que pour ouvrir des fichier texte ou assimilés... Pour la programmation du site web, j'utilise Sublime Text 3, il a des fonctions super pratiques pour accélérer le code HTML!
  2. YES!!!! ça fonctionne enfin! Merci à vous deux pour votre aide précieuse! Donc je résume, voici la version qui fonctionne: RewriteEngine On RewriteCond %{HTTPS} off RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R,L] Mais écris et sauvé avec le Notepad "de base", avant j'utilisais Notepad++ je ne pensais pas qu'il ne respectait pas le mode texte pur... Ouf, une bonne chose de faite, je galérais la-dessus depuis hier matin! Merci encore!
  3. Il n'y a absolument rien d'autre dans le fichier que les quelques lignes de redirection... Je viens d'essayer vos 2 propositions: pas mieux... J'ai aussi essayé avec juste la ligne "RewriteEngine On", même résultat! Là ça devient bizarre à ce que je comprends...
  4. Tout d'abord merci pour cette réponse rapide! J'avais oublié de préciser, le site est intégralement en HTML5/CSS3, aucun script n'est utilisé. J'ai testé les 2 propositions et j'ai toujours mon erreur 500... Je commence à me demander si OVH gère bien ce fameux fichier .htaccess! D'ailleurs, il y a à la racine un fichier .ovhconfig qui contient ceci (ce n'est pas moi qui l'ai écrit): app.engine=phpcgi app.engine.version=7.0 http.firewall=none environment=production container.image=default_image Perso j'ai essayé ça: RewriteEngine On RewriteCond %{SERVER_PORT} 80 RewriteRule ^(.*)$ https://www.xyz.fr/$1 [R,L] ou encore ça: RewriteEngine On RewriteCond %{HTTP_HOST} ^xyz\.fr [NC] RewriteCond %{HTTPS} off RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} Et toujours le même résultat... Erreur 500...
  5. Bonjour à tous, Je plante le décor en vitesse: le site web de ma boite est hébergé en mutualisé chez OVH, et on a pris l'option certificat SSL Quand on tape directement https://www.xyz.fr/ ça fonctionne bien, mais quand on tape www.xyz.fr ou xyz.fr la consultation du site reste en http... Et toutes les tentatives que j'ai faites de fichier .htaccess à la racine du site se termine TOUJOURS en erreur 500!! Quelqu'un a-t-il déjà eu (et résolu!) ce problème?? Merci d'avance...
×