Aller au contenu

lorik

Hubmaster
  • Compteur de contenus

    435
  • Inscrit(e) le

  • Dernière visite

Tout ce qui a été posté par lorik

  1. Hello, je cherche une astuce pour réaliser ça : J'ai un domaine, avec X sous domaines. Je veux bloquer l'accès au domaine (pas de problème avec ça), mais laisser passer l'accès à certains sous domaines précis. Et là, je sèche Merci de vos tuyaux, si vous en avez
  2. Oui, interdire les sous domaine un par un, ça c'est bon. C'est le process inverse que je cherche, avoir un login/pass pour TOUT SAUF xxx/yyy qui auraient un accès libre.
  3. lorik

    Rechercher dans toutes les bases d'un serveur

    Salut Dan, ok, je vais tester ça, effectivement. Merci
  4. Bonjour à tous, Une question : J'ai besoin de trouver une chaine qui se trouve quelque part dans une base mysql... simple à la base... sauf que j'ai 330 bases sur le serveur, et... je ne sais pas dans quelle base la chaine se trouve ! Est-ce qu'il existe une instruction qui permette de lancer une recherche dans toutes les bases d'un serveur ?? Merci de votre aide, j'ai rien trouvé pour le moment de mon coté
  5. Merci Dan, je vais ajouter un message pour ça sur le site...
  6. Hello Dan, je ne sais jamais si on peut publier des trucs comme ça, sur le forum... C'est le *****, domaine evenup, là par exemple, le site vient d'envoyer un mail de recup de mot de pass sur une adresse ****@hotmail.fr, et rien n'arrive. Le problème semble se poser spécifiquement sur les adresses hotmail.FR, en .com, pas de souci particulier, semble t il...
  7. Bonjour, Je deterre le sujet, pas sur qu'il soit résolu, et j'ai exactement le même souci avec Hotmail et Aol. Pour le lien ci-dessus de Aenoa, hélas, ça ne solutionne pas : Je n'ai pas de problème avec les adresses Live.fr, alors que Live et Hormail, c'est plus ou moins la même chose, et par ailleurs, j'ai testé sur l'outil, mon ip est clean. Dans exim, c'es tindiqué que les mail sont en 'queue' chez Hotmal, mais ça sort jamais de la queue, du coup... Nota : J'utilise phpmailer....
  8. lorik

    problème d'encodage...

    Hello, merci de la réponse. après moult tests, en fait, c'était juste un utf8_encode qu'il fallait faire... mais je garde de coté tous tes trucs, j'ai pas de doute que je vais encore ramer, j'ai effectivement d'autres sources....
  9. lorik

    problème d'encodage...

    Hello, Je m'arrache ce qui me reste de cheveux sur un truc pourtant sans doute basique sur le papier... J'ai 2 tables, en latin1_swedish_ci . La première (cible) est alimentée par des formulaires web. La 2eme (source) par des sources externes de données. Je cherche à alimenter la première avec les données de la 2eme. Pas de problème de script, ça marche. Par contre, les données importées à partir de 'source' ressortent très mal dans la page une fois publiées. Bon, un problème d'encodage, ok, mais je ne m'en sors pas pour trouver quoi faire avec les données importées pour qu'elles soient correctes. j'ai testé avec mb_detect_encoding, les données de ma (source) sont en utf-8, et les données de ma (cible) sont en ASCII. mais impossible de trouver la solution pour transformer mes données source en ASCII avant de les importer... utf8-decode ne donne pas de résultat... Bref, je seche grave... Merci de votre aide.
  10. Bonjour à tous, Ya pas un type de champ ou une astuce quelconque pour renseigner automatiquement dans un champ Mysql une date de mise à jour de l'enregistrement, sans passer par une procédure stockée ou du code en amont ? ça existe pour la création de l'enregistrement, mais pour la maj, je sèche complètement.. Une idée ? par avance merci.
  11. lorik

    Performance requete...

    Merci de la réponse, Oui, je suis d'accord pour le *, mais le propos était surtout de comparer, l'optimisation ne réduit pas le gap entre les 2 méthodes. Pour le transtypage, non, rien de particulier, on a des listes de codes postaux bien formatés et homogènes... A la place de la sous requete, je pourrais aussi faire un INNER JOIN avec une autre table, mais elle fait 5 000 000 d'enregistrements, j'ai pensé que ça serait plus rapide comme ça...
  12. lorik

    Performance requete...

    Bonjour à tous, Je suis assez surpris par les perfomances comparées de requetes assez simples : SELECT * FROM table1 WHERE cp IN (select toto from villes where code_postal=38000) => la requete tourne pendant presque 4 secondes. Pourtant : select toto from villes where code_postal=38000 ne met que 1 milisecondes. Et que si on met 'en dur, les valeurs à tester (le resultat du select toto from ville...) , on est aussi de l'ordre de la miliseconde.... SELECT * FROM table1 WHERE cp IN (38000,38950,38170,38100,38400,38180,38113,38220,38760,38340,38660,38450,38112,38134,38430,38960,38144,38119,38520,38770,73360,73670,73160,38620,38750,38830,38480,73520,73610,38840,38940,73800,73330,73110,73190,73530,73000,73240,73470,73130,73300,73490,73290,73230,73170,73660,73420,73390,73250,73370,73220,38890,73870,73340,73100,73450,73140,73630,73460,73310,73410,73440,73260,38070,74540,73600,73200,73550,73500,38138,74320,73730,74150,38118,73570,73350,74410,73540,69780,74210,69124,69720,69560,69125,38370,69970,74600,69420,73210,42520,73790,69330,73400,42410,74650) Bref, on passe de 2 milisecondes à ... 2000 fois plus !! Ya un truc qui m'échappe, là. Ca méchappe mais ça me pose un vrai souci, du coup, vos lumières sont les bienvenues
  13. lorik

    mysqli_real_escape_string fonctionnement bizarre...

    Merci de la réponse. Effectivement, il y avait une double utilisation de mysql_real_escape_string c'est ça qui mettait le B... Une fois nettoyé, ça marche mieux. Je retiens l'idée de mettre ça juste à l'insert, c'est vrai qu'on est tranquille, du coup ;)
  14. Bonjour à tous, un tit truc assez inexplicable pour moi... J'ai un script, qui extrait des données de plusieurs sources, les traites, et insere dans une table. Pour chaque donnée, avant de l'inserer, j'ai un $var=mysqli_real_escape_string ($link, $var); alors d'un coté, ça marche bien, mes données sont correctement insérées, même quand j'ai des caractères à échapper. Par contre, 2 trucs : - Dans ma table, même si les données sont insérée, j'ai certains caractères correctement echappés dans un champ (ex, Organisé par l\'Olympique d\'Huez- Alpes d\'Huez), et pas échappés dans d'autres champs (Alpes d'Huez) alors que la chaine a bien été soumise à mysqli_escape_string(..) Et aussi, dans l'autre sens, j'avais oublié d'echapper certaines données, et... elle sont correctement insérées, alors qu'il traine dedans les caractères qui devraient faire planter la requete, comme '... Vous allez me dire, 'bon, mais si c'est bien inséré, il est ou le problème ?' Bal le problème, c'est qu'après, j'ai un autre traitement qui lit la table, et insère certaines données dans une autre table. Et là, les chaines non echappées (pourtant bien insérées dans la première table) font planter la 2eme insertion... Bref, y un truc que je pige pas, là... Merci de votre aide.
  15. lorik

    Responsive, pdf, android

    Bonjour à tous, J'ai un petit souci sur un site : Le site propose de télécharger des documentations pdf . Pas de problème, ça marche bien? Sauf que... le site est responsive, et avec mon smartphone android, le téléchargement du pdf ne fonctionne pas. J'ai pas d'erreur, le téléchargement semble se lancer, et s'arreter tout de suite, sans plus.. J'ai bien chargé une appli de lecteur pdf, ça devrait marcher, mais... non Des idées ? Par avance merci...
  16. lorik

    Problème avec trim()

    Bonjour Dan J'ai pas tout compris le problème, je creuserai ça, mais dans tous les cas, oui, ça a solutionné Merci à vous 2 !
  17. lorik

    Problème avec trim()

    Hello, Un souci que je ne ocmprends pas, c'est du basique, pourtant... J'ai une serie de données dans un champ texte en base (renseigné à partir d'excel en copier coller, ça a peut être un interet...). J'extrais mon texte, je l'explode (\n), pas de souci. Dans les données du tableau resultant, j'en ai pas mal qui ont 1 ou 2 'blancs' en début de chaine (ex, ' tototata'). Qu'à cela ne tienne, je dégaine mon trim($chaine) de derrière les fagots. Resultat : que pouic, impossible d'enlever ces 'blancs'. Pas d'erreur, rien, juste... marche pas. J'ai checké les données avec Notepad pour voir si yavait pas des trucs pourris qui trainent, mais non, ya rien. La je ne comprends pas.... $value=trim($value); Snif please help...
  18. lorik

    Problème avec trim()

    Alors, j'ai bien compris l'idée, mais ya vraiment un truc qui déconne... là, ça m'a remplacé le premier 'blanc' (194) par un � (160). Pas supprimé, remplacé....
  19. lorik

    Problème avec trim()

    Merci de la réponse; Je ne connais pas cette commande. ca renvoie 194 pour toutes les valeurs de $value...
  20. lorik

    Responsive, pdf, android

    Hello, merci de la réponse. Vu que moi il se passe rien, le 'target blank', je n'ai aucune idée de ce que ça génère sur le mobile. Chez toi ça marche avec quoi ? android ?
  21. lorik

    $row['table.field']- Undefined index:

    Merci les gars, la vie est plus belle désormais
  22. lorik

    $row['table.field']- Undefined index:

    Hello les génies Bon, problème de CE2 : J'ai une requete basique avec jointure sur 2 tables. Pas de Pb. Par contre, sur les 83 champs des 2 tables, j'en ai 3 qui ont le même nom. Pour par me taper les 83 champs dans le select, avec 6 alias, je fais un basic 'select * blabla'. Je recupere là aussi basiquement (j'ai un niveau très très basique ) avec un mysql_fetch_array. Et là je coince, pour récuperer les données de mes 6 champs : $row['table.field'] me renvoi une erreur Undefined index... Bref, ma quesiton : ya une methode pour arriver à ne pas devoir se taper la saisie des 83 champs dans la requete ?? Pitié, dites moi que 'oui, t'es une quiche, ya une soluce !' pitié
  23. lorik

    Responsive, pdf, android

    Merci de la réponse. Je voyais plus un problème de techno global, mais voila une url test : https://www.coffrefortpro.com/poignee-etoile-test.html
  24. Merci dela réponse, c'est bon, c'est réglé
  25. Bonjour, Je cherche à faire une ré-ecriture d'url sur un nom de dossier (en plus du nom de fichier), mais je coince, là... Principe : J'ai un dossier 'physique', un vrai, sur le serveur, qui se nomme 'seo'. Chemin : mondomaine.com/seo. Dedans, j'ai un script index.php. Ce que je souhaite, c'est que TOUTES les urls du type mondomaine.com/theme1/keyword_x, ou mondomaine.com/theme2/keyword_y soient au final traitées par mon script mondomaine.com/seo/index.php?kw=keyword_blabla. Pour la partie 'keyword_', pas de problème, c'est pour les dossiers (theme1, theme2, etc...) que je coince.... Une idée, les champions ? Par avance merci
×