Jump to content

zoon53

Actif
  • Content Count

    18
  • Joined

  • Last visited

Community Reputation

0 Neutre
  1. Bonjour, A chaque fois que jenvoie un mailing à mes membres, je me fais blacklister par hotmail. ks36076 envois # telnet mx1.hotmail.com 25 Trying 65.54.244.136... Le DNS Report : http://www.dnsreport.com/tools/dnsreport.c...in=equinomy.com Faut il également installer un spf sur l'ip : http://www.dnsstuff.com/tools/spf.ch?ip=87.98.216.102 ? Ce dédié est uniquement consacré à l'envoi des emails, et il n'y a que le domaine equinomy.com dessus. J'ai installé le spf record qui semble correct. Je précise que jai bien un lien de désinscription, et des entêtes correctes : //ENTETES dans Outlook Return-Path: <monforum_AT_equinomy.com> Delivered-To: online.fr-charles.ruelle_AT_free.fr Received: (qmail 10763 invoked from network); 8 Mar 2007 22:08:00 -0000 Received: from 87.98.216.102 (HELO ks36076.kimsufi.com) (87.98.216.102) by mrelay4-2.free.fr with SMTP; 8 Mar 2007 22:08:00 -0000 Received: (qmail 15786 invoked by uid 1000); 8 Mar 2007 22:09:14 -0000 Date: 8 Mar 2007 22:09:14 -0000 To: charles.ruelle_AT_free.fr Subject: Invitation personnelle a nos prochaines ventes MIME-Version: 1.0 Content-type: text/html; charset=iso-8859-1 From: MonForum / Testagogo <monforum_AT_equinomy.com> X-Mailer: PHP v5.1.4 Message-ID: <200703082214.5afc2f719097_AT_www.equinomy.com> X-ProXaD-SC: Score=1 Lorsque j'envoie que quelques emails, tout passe sans problème, le problème intervient quand j'envoie la mailing liste sur 100 000 mails. Faut il étaler les envois sur 12h ? 24 h ? J'ai remarqué que je suis déblacklisté automatiquement après quelques heures. Merci, Charles
  2. Je vines de faire la modificaiton... toujours rien :/ J'utilise su php, sur apache 2, est ce que cela ne peut pas venir de là ?
  3. Bonjour, J'ai installé apc, tout semble ok Voici le phpInfo : http://ns36956.ovh.net/serveur/phpinfo/test.php VOici l'admin apc : http://ns36956.ovh.net/apc.php Il ne met en cache que le script apc.php, je ne comprends pas... Avez vous une idée ? Merci
  4. Merci pour ta réponse. Le problème est que c'est un forum, donc difficile de mettre en place un système de cache optimisé.
  5. Bonjour, Je suis actuellement face à de gros problèmes de perfs sur mon dédié (Start 310G) et jaimerai faire appel à quelquun pour optimiser ensemble MySQL. Je suis actuellement à une centaine de requêtes par seconde et jai fréquemment des requêtes qui bloquent des tables et font saturer la machine. Jaurai donc besoin de : Analyse de mes besoins, et éventuellement de quelques requêtes qui posent problème Optimisation des paramètres de Mysql Suivi dans la durée Le serveur : P4 dual 3ghz, 1Go de ram Mon fichier my.cnf : [mysqld] #tmp_table_size = 1M #query_cache_size = 32M #query_cache_type = 1 connect_timeout=10 max_connections=150 #skip-networking long_query_time=50 log-slow-queries = /var/log/mysql/slow-query.log innodb_file_per_table default-character-set=latin1 J'ai des problèmes de montée en charge, les requêtes sont très rapide et à chaque fois que je fais un explain, les index sont utilisés, il n'y a que peu de lignes traitées etc... J'ai pas mal de requêtes qui sont en statut : Copying to tmp table ou Sending data pendant plusieurs secondes. Lorsque le load monte un peu elles peuvent nécessiter plus de 40 secondes J'ai essayé d'activer le cache, sans grand succès car les requêtes sont toujours très diférentes. Ayant des problèmes de lock sur des tables entières, j'ai migré toutes les tables en InnoDb mais ca n'est pas vraiment mieux. Je suis déjà sous MySQL 5. Merci pour votre aide
  6. merci beaucoup. Tu penses que c'est bien l'optimisation de mysql le problème ? le dédié n'est pas trop juste ?
  7. Bonjour, J'ai de gros problèmes avec MySQL sur un serveur dédié. La config du serveur : Celeron 2.6, 512 MO Exemple de processlist : J'ai des "grosses" tables, au total près de 7 000 000 d'enregistrements pour 500 Mo. Il y a de grosses requetes, qui ne prennent quasi pas de temps quand il y a personne sur le site, mais dès qu'il y a un peu de load elles durent longtemps et s'ajoutent dans le processlist mysql et viennent saturer l'ensemble. Voici ma config mysql : port = 3306 socket = /var/lib/mysql/mysql.sock query_cache_size = 41984 #skip-external-locking #skip-innodb #key_buffer_size = 256M #max_allowed_packet = 1M #table_cache = 2048 #sort_buffer_size = 16M #read_buffer_size = 16M #thread_cache_size = 8 #thread_concurrency = 8 #myisam_sort_buffer_size = 64M #connect_timeout = 10 max_connections = 200 connect_timeout = 5 #long_query_time = 30 wait_timeout=5 #interactive_timeout=60 #thread_stack = 128k long_query_time = 3 log-slow-queries = /var/log/mysql/slow_queries.log log-error = /var/log/mysql/error.loglog-error = /var/log/mysql/error.log #max_allowed_packet = 500M J'avoue ne pas trop savoir comment parramétrer MySQL... Avez vous des conseils à me donner ? Quel peut être mon problème ? Merci bcp
  8. Bonjour, Je rencontre un problème (aléatoire ?) de DNS sur TonBLog.com J'avais mis en place un catch all de sous domaines et tout fonctionnait parfaitement. *.tonblog.com pointait bien sur TonBlog.com Depuis quelques jours, aucun sous domaine ne pointe sur TonBlog. J'ai modifé la config de Bind, redémarré, quelques heures / jours après ça a refonctionné. Alors que je n'ai rien modifé ca yé ça ne refonctionne plus. Voici la configuration : $ttl 86400 tonblog.com. IN SOA ns32559.ovh.net. webmaster.tonblog.com. ( 2005090303 21600 3600 604800 86400 ) IN NS ns32559.ovh.net. IN NS ns.ovh.net. IN MX 10 mail.tonblog.com. IN A 213.251.162.12 www IN A 213.251.162.12 mail IN A 213.251.162.12 smtp IN A 213.251.162.12 pop IN A 213.251.162.12 pop3 IN A 213.251.162.12 imap IN A 213.251.162.12 sql IN A 213.251.162.12 mysql IN A 213.251.162.12 * IN A 213.251.162.12 Merci bcp
  9. Bonjour, Je viens de remarquer que mon dédié commençait à ramer. J'ai fait un top et j'ai : 8:29pm up 6 days, 3:20, 1 user, load average: 1,52, 1,25, 1,34 92 processes: 88 sleeping, 3 running, 1 zombie, 0 stopped CPU states: 24,5% user, 75,4% system, 0,0% nice, 0,0% idle Mem: 505792K av, 407228K used, 98564K free, 0K shrd, 49300K buff Swap: 522104K av, 55528K used, 466576K free 242420K cached PID USER PRI NI SIZE RSS SHARE STAT %CPU %MEM TIME COMMAND 5952 vpopmail 18 0 476 476 396 R 96,0 0,0 1:41 pscan2 23814 root 12 0 1072 1072 828 R 0,5 0,2 0:01 top 8 root 9 0 0 0 0 SW 0,3 0,0 20:39 kjournald 20586 root 9 0 0 0 0 SW 0,1 0,0 48:24 kjournald 2784 nobody 9 0 4712 4712 4348 S 0,1 0,9 0:01 httpd 1 root 8 0 508 468 444 S 0,0 0,0 0:20 init 2 root 9 0 0 0 0 SW 0,0 0,0 0:00 keventd 3 root 19 19 0 0 0 SWN 0,0 0,0 0:25 ksoftirqd_CPU0 4 root 9 0 0 0 0 SW 0,0 0,0 1:11 kswapd 5 root 9 0 0 0 0 SW 0,0 0,0 0:00 bdflush 6 root 9 0 0 0 0 SW 0,0 0,0 1:19 kupdated 7 root -1 -20 0 0 0 SW< 0,0 0,0 0:00 mdrecoveryd 6018 root 9 0 948 804 768 S 0,0 0,1 0:02 sshd 1844 root 9 0 592 576 532 S 0,0 0,1 0:04 syslogd 12651 root 9 0 1208 488 488 S 0,0 0,0 0:00 klogd 17245 root 9 0 844 652 652 S 0,0 0,1 0:00 xinetd 22479 qmails 9 0 408 384 372 S 0,0 0,0 0:07 qmail-send 20115 qmaill 9 0 368 344 340 S 0,0 0,0 0:00 multilog 4410 root 8 0 480 424 408 S 0,0 0,0 0:04 tcpserver 1868 qmaill 9 0 488 432 428 S 0,0 0,0 0:00 tcpserver 29349 qmaill 9 0 288 244 240 S 0,0 0,0 0:00 tai64n 639 root 8 0 332 300 288 S 0,0 0,0 0:00 qmail-lspawn 23190 qmailr 8 0 344 316 312 S 0,0 0,0 0:00 qmail-rspawn 30285 qmailq 9 0 348 324 324 S 0,0 0,0 0:00 qmail-clean 2128 root 8 0 604 508 508 S 0,0 0,1 0:00 couriertcpd 20636 root 9 0 452 388 388 S 0,0 0,0 0:00 courierlogger 18834 root 8 0 676 608 564 S 0,0 0,1 0:03 crond 25273 daemon 9 0 568 508 508 S 0,0 0,1 0:00 atd 6423 root 8 0 1428 1428 1344 S 0,0 0,2 0:23 watchdog 2514 root 9 0 304 256 248 S 0,0 0,0 0:11 clockspeed 21551 root 9 0 4068 1600 1220 S 0,0 0,3 0:22 miniserv.pl 31007 root 9 0 404 344 344 S 0,0 0,0 0:00 mingetty 18306 root 9 0 404 344 344 S 0,0 0,0 0:00 mingetty 9534 root 9 0 404 344 344 S 0,0 0,0 0:00 mingetty 29637 root 9 0 404 344 344 S 0,0 0,0 0:00 mingetty 24234 root 9 0 404 344 344 S 0,0 0,0 0:00 mingetty 20691 root 9 0 404 344 344 S 0,0 0,0 0:00 mingetty Savez vous ce qu'est pscan2 ? J'ai regardé sur internet et il semblerait que ce soit un troyen... :s Comment faire ? Merci,
  10. Ah quand tu me demandais si j'avais un accès ssh sur ma machine tu parlais de celle installée chez moi ? Au début je pensais la laisser sous windows avec uniquement un serveur ftp, mais sinon j'installe une distrib linux. J'ai entendu parler des rsync, c'est bien ?
  11. Oui, c'est un dédié, c'est pour ca je pensais installer un cron avec un script. Sinon je pensais le faire moi meme le script, copier les dossiers qui m'intéressent dans un dossier, le zipper et l'envoyer par ftp.
  12. je te remercie pour ta rapidité. J'avais testé avec Toto mais ca ne fonctionnait pas. je l'ai enlevé, redémarré bind et toujours pareil. Pour le domaine MonForum.fr, les dns sont ceux du registar mais l'entrée A pointe sur le dédié. J'avais lu sur OVH qu'il fallait déclarer les domaines avec nsXXXX.ovh.net et le secondaire sur le ns.ovh.net et ensuite déclarer le domaine sur le DNS d'OVH... Dans ce cas comment faut il faire ? je met les deux DNS du domaine en nsXXXX.ovh.net ? Lorsque je change les DNS de mon domaine .Fr, ca ne passe pas et apparement il y a une erreur (d'après le Zone Check de l'afnic)
  13. Pour ce qui est de l'envoi de la sauvegarde je pense que ca ne posera pas trop de problème avec un accès Free dégroupé, pour l'envoi des données si jamais j'ai besoin de restaurer, effectivement, je n'ai qu'un Mbit d'upload... Mais bon ce sera toujours mieux que rien, je n'ai pas vraiment envie de devoir prendre un autre serveur
  14. Un grand merci, je vais m'amuser un peu
  15. Bonjour, Sur le domaine MonForum.fr, j'ai appliqué cette méthode de catch all : http://www.taggle.org/index.php/2004/07/31...maines-a-gogo-1 Le problème est que ca ne fonctionne pas, j'ai alors testé sur un autre domaine (equinomy.com) et sur celui ci cela fonctionne. Voici mon fichier de Config Apache <VirtualHost 213.251.162.12> ServerAdmin webmaster_AT_monforum.fr DocumentRoot /home/monforum/www User monforum Group users ServerName www.monforum.fr ServerAlias monforum.fr *.monforum.fr CustomLog logs/monforum-access_log combined ScriptAlias /cgi-bin/ /home/monforum/cgi-bin/ </VirtualHost> <VirtualHost 213.251.162.12> ServerAdmin webmaster_AT_equinomy.com DocumentRoot /home/equinomy/www User equinomy Group users ServerName www.equinomy.com ServerAlias equinomy.com *.equinomy.com CustomLog logs/equinomy-access_log combined ScriptAlias /cgi-bin/ /home/equinomy/cgi-bin/ </VirtualHost> Bind $ttl 86400 equinomy.com. IN SOA ns32559.ovh.net. webmaster.equinomy.com. ( 2005073103 21600 3600 604800 86400 ) IN NS ns32559.ovh.net. IN NS ns.ovh.net. IN MX 10 mail.equinomy.com. IN A 213.251.162.12 www IN A 213.251.162.12 mail IN A 213.251.162.12 smtp IN A 213.251.162.12 pop IN A 213.251.162.12 pop3 IN A 213.251.162.12 imap IN A 213.251.162.12 sql IN A 213.251.162.12 mysql IN A 213.251.162.12 * IN A 213.251.162.12 $ttl 86400 monforum.fr. IN SOA ns32559.ovh.net. webmaster.monforum.fr. ( 2005080102 21600 3600 604800 86400 ) IN NS ns32559.ovh.net. IN NS ns.ovh.net. IN MX 10 mail.monforum.fr. IN A 213.251.162.12 www IN A 213.251.162.12 mail IN A 213.251.162.12 smtp IN A 213.251.162.12 pop IN A 213.251.162.12 pop3 IN A 213.251.162.12 imap IN A 213.251.162.12 sql IN A 213.251.162.12 mysql IN A 213.251.162.12 * IN A 213.251.162.12 toto IN A 213.251.162.12 Pour le domaine Equinomy.com j'ai mis les DNS du dédié : http://ns32559.ovh.net/ et ns.ovh.net Tandis que pour le domaine monForum.fr j'ai gardé les dns du registar et fait pointer le A sur l'ip du serveur OVH. Depuis qques jours, je n'arrive plus non plus à créer de sous domaines du domaine monForum.Fr Avez vous une idée ? Je pense à un paramétrage de Bind... Mais je ne suis pas un expert.
×
×
  • Create New...