Aller au contenu

Noter ce sujet :

Recommended Posts

Salutation,

Je me présente Azote (ou Ultim pour ceux qui taff dans le charme)

Je suis ravi de me joindre à vous sur ce forum, je taff Azote.org un site de domaine gratuit (redirection et domaine Ip)

Sinon j'ai 20 ans et suis domicilié dans la raison Nantaise

A+

Modifié par Azote

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Azote et bienvenue sur le Hub :)

J'ai été voir ton site qui me parait très sympa (sauf une pitite faute dans la page de vérification du nom de domaine: disponible)

Partager ce message


Lien à poster
Partager sur d’autres sites

Je n'appele pas ca vraiment des erreurs de codages dans la mesure ou tous les naviguateurs et moteurs les lisent, je fait tres attention au HTML mais de la à prendre en compte des vieilles restrictions non réévalués depuis 1997

a+

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, bienvenue

Qu'entends-tu par "vieilles restrictions non réévalué[e]s depuis 1997" ?:huh:

Parce que sans vouloir enfoncer le clou, ton site est plutôt mal codé :blush:

Partager ce message


Lien à poster
Partager sur d’autres sites

Les normes HTML sont assez anciennes, on ne peux plus parler de normes

Je sais bien qu'il n'est pas parfait , il est visible et fonctionne.le principale, pour moi le code c'est au niveau PHP que ca se juge, pas niveau HTML, je suis capable de faire du Conforme aux Normes mais je trouve que c'est totalement dépassé ... les moteurs passent sur mon site , le comprenne

Et puis tu ne fait guerre mieux , http://validator.w3.org/check?uri=http%3A%...0.xavbox.com%2F ;)

Modifié par Azote

Partager ce message


Lien à poster
Partager sur d’autres sites

:huh: Mais de quelles normes parles-tu ? Je ne comprends rien du tout :blink:

L'HTML 4 date de 1999, et l'XHTML 1.0 de 2000

En ce moment, 2005, le w3c planche sur la norme XHTML 2.0

Donc quelles normes sont anciennes ? :unsure: HTML 4 ? :huh: (ton code sans doctype semble se rapprocher d'HTML 4)

En tous cas, oui, ton code est très vieux et redondant (il n'est pas optimisé moteur d'ailleurs m'enfin si çà te convient). Mais les normes, non: la dernière révision d'XHTML 1 est sortie en 2002 (soit 2 ans après sa 1ère sortie officielle)

PS: le site Xavbox appartient à Xavfun, non à moi. Il est en signature pour faire un peu plus de béhelles© :D

Enfin, bon, bienvenue ... :unsure: bon courage

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui je comprend, enfin disons que pour moi la norme c qd c lisible par tous les naviguateurs, et contrairement a cela, si tu fait des sites qui correspondent aux normes, ils ne s'afficheront pas toujours correctement sur tous les naviguateurs, j'ai quelques sites de ma réalisation que j'ai eu la bonne idée de faire en respectant les normes mais l'interpertation de IE laissait a désirer (vu qu'il respecte pas les normes ce con). Voila voila :D

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Azote,

Et bienvenue sur le Hub :)

Les normes HTML sont assez anciennes, on ne peux plus parler de normes

Je sais bien qu'il n'est pas parfait , il est visible  et fonctionne.le principale, pour moi le code c'est au niveau PHP que ca se juge, pas niveau HTML, je suis capable de faire du Conforme aux Normes mais je trouve que c'est totalement dépassé ... les moteurs passent sur mon site , le comprenne

<{POST_SNAPBACK}>

Dis-moi, depuis quand n'es-tu plus allé sur le site du W3C ?

HTML 3.2 (14-Jan-1997) effectivement c'est dépassé :rolleyes:

Mais comme l'a dit Dudu, il y a eu d'autres spécifications depuis :D

Que tu t'assures que ton site s'affiche correctement avec les navigateurs actuels, c'est très bien.

Mais quelle garantie as-tu pour leurs futures versions, pour un éventuel nouveau navigateur ?

Un code conforme aux normes (actuelles de préférence) ne garantit sans doute pas le même affichage dans tous les navigateurs, mais au moins l'affichage correct (et l'accès à toutes tes informations) dans tous les navigateurs présents et à venir.

c qd c

A propos, sur le Hub aussi il y a des normes... comme de s'exprimer dans un français correct et d'éviter le langage SMS ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Y a des maniaques dans le coins :D

Il y a des personnes qui ont créer un langage puis d'autres personnes on dit : " ca , ca et ca faut pas les utilisés sinon t'es pas dans les normes" ....

Modifié par Azote

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour et bienvenue sur le Hub,

Pour un post de présentation je trouve tes remarques un peu acerbes. J'ai hésité a intervenir jusqu'à présent, mais vu le ton que prend le topic comme le dit MS-DOS 1991 la discussion est close, je ferme donc le sujet.

Y a des maniaques dans le coins :D

Il y a des personnes qui ont créer un langage  puis d'autres personnes on dit : " ca , ca et ca  faut pas les utilisés sinon t'es pas dans les normes" ....

Bon allez la discussion est close......Bonne continuation et @+tard sur les topics du hub ^_^

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

  • Contenu similaire

    • Par kevinjoseph
      Bonjour, j’ai un gros problème sur mon site Wordpress . Du jour au lendemain, mon site wordpress fais une redirection vers un autre site wordpress que j’ai crée ,sans que je touche à quoi que ce soit. Quand j’essai d’aller sur l’admin pour désactiver les plugins et voir d’où peut venir le problème. Impossible d’accéder, sa me redirige vers l’admin de l’autre site. Au final il est impossible que j’accède au site via (google, la bare de recherche, les favoris, l’admin…) pour voir ce qu’il fonction pas, j’ai juste accès au FTP. J'ai essayé de voir d'où pouvez venir ce bug en supprimant les plugins, le théme, mes derniers modifications, regarder sur le .htaccess si il y avais quelque par le nom de domaine de l'autre site écrit. Ca n'a rien changer, le site continue de ce rediriger automatiquement vers l'autre site. Si vous avez une idée d’où sa peut venir ou comment faire pour arranger ça et surtout comment éviter que sa ce reproduise. Sa m’aiderai beaucoup, merci d’avance.
      voici le code du .htaccess:
       
      # BEGIN WordPress
      <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteBase /
      RewriteRule ^index\.php$ - [L]
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule . /index.php [L]
      </IfModule>

      # END WordPress
      ~   Ludovic • 16:28    
    • Par leobk
      Bonjour,
       
      J'ai un sous-domaine www.fr.monsite.com dédié pour la réservation des vols
      j'ai redirigé récemment ce sous-domaine vers le site principal www.monsite.com et le nombre des erreurs 404 a explosé
      un nombre énorme d'URLs de type :
      www.fr.monsite.com/fr/vols/index?f_type=01&f_departure=TLS&f_destination=DJE&f_date_from=08/09/2013&f_date_to=22/09/2013&f_flexibility=3&f_paxs_adults=2&f_paxs_childs=0&f_paxs_infants=0
      redirigent vers :
      www.monsite.com/fr/vols/index?f_type=01&f_departure=TLS&f_destination=DJE&f_date_from=08/09/2013&f_date_to=22/09/2013&f_flexibility=3&f_paxs_adults=2&f_paxs_childs=0&f_paxs_infants=0
       
      L'URL de destination est biensur introuvable 404, puisque les variables utilisés dans les deux sites ne sont pas identiques
      Voici la structure d'URL si on fait une recherche de vol sur le site principal :
      https://www.monsite.com/fr/resa?depart=SXF&arrivee=NBE&aller=2017-11-10&retour=2017-11-30&adultes=1&enfants=1&bebes=0&departureDateTime_D=&arrivalDateTime_D=&departureDateTime_R=&arrivalDateTime_R=&fareGroupName=&fareGroupName_R=&sens=2&currency=EUR&airline=&flightNumber=&flight=&flight_retour=&webview=0&felxibilite=2
       
       
      existe-il un moyen pour rediriger l'ensemble des URLs dynamiques du sous-domaines vers une URL statique du domaine principale (autre que l'accueil)?
       
       
    • Par PieceMobile
      Bonjour,



      J'espère que vous allez tous bien.



      Auriez vous une solution pour rediriger ( via une règle htaccess par exemple ) :



      http://www.mon-site.com/blabla.html?ps_mobile_site=1



      vers : http://www.mon-site.com/blabla.html



      A mon avis, s'agissant d'un paramètre d'URL, de ce que j'ai cru comprendre -a mon petit niveau- c’était pas possible, mais ça me dépannerai pas mal si l'un d'entre vous avait une idée.



      Merci d'avance





    • Par aurelien59
      Bonjour, Je me permet de poster ce problème sur ce forum en plus de l'avoir posté sur un autre. Le problème survient sur un site codé en dur. Depuis plusieurs mois après la mise en place de redirection, je rencontre un problème. La redirection a été mise en place pour rediriger simplement les pages ayant un underscore vers un tiret. Par exemple page_1.php vers page-1.php Dans Google webmasters tools, zone "Exploration", > Erreurs d'exploration > le nombre des URL non suivies à augmenter de manière considérable sur ordinateurs et smartphone.

      Voici un exemple de page contenant l'erreur : page-1.php/page-a.php (alors que la page correcte est page-1.php, la page page-a.php est présente sur le site en racine). Lorsque je clic sur l'url d'erreur, dans l'onglet "Référencée sur". Les url qui apparaissent sont : http://www.monsite.fr/page-2.php/page-b.php'>>http://www.monsite.fr/page-2.php/page-b.php et http://www.monsite.fr/page-2.php/page-c.php'>>http://www.monsite.fr/page-2.php/page-c.php (non indexés sur Google). Voici l'extrait du .htaccess ErrorDocument 404 http://www.monsite.fr/404.phpRewriteEngine onRewriteCond %{HTTP_HOST} ^monsite.fr$RewriteRule ^(.*) http://www.monsite.fr/$1 [QSA,L,R=301]RewriteRule ^([^_]*)_([^_]*)$ /$1-$2 [L,R=301]RewriteRule ^(.*)\.php/$ http://www.monsite.fr/$1.php[L,R=301]RewriteRule ^(.*)\.php/(.*)\.php$ http://www.monsite.fr/$1.php[R=301]RewriteCond %{REQUEST_FILENAME} -s [OR]RewriteCond %{REQUEST_FILENAME} -l [OR]RewriteCond %{REQUEST_FILENAME} -dRewriteRule ^.*$ - [NC,L]RewriteRule ^.*$ /404.php [NC,L] Merci beaucoup pour votre aide.
×