Jump to content
Sign in to follow this  
cecemf

Menu Java marche sur ordi mais pas sur serveur 2 !

Rate this topic

Recommended Posts

Bonjour,

J'ai un probleme avec mon site car tout marche sauf un menu en JAVA qui marche tres bien sur l'ordi mais qui marche pas sur le serveur:

Voici la page avec le menu qui marche pas:

http://mylenefarmer.streamlinenettrial.co....eographieSC.php

Vous pouvais telecharger les fichiers ici:

http://mylenefarmer.streamlinenettrial.co....eographieSC.zip

S'IL VOUS PLAIT AIDER moi car je doit ouvrire le site le 1er Novembre

MERCI D'AVANCE

Edited by cecemf

Share this post


Link to post
Share on other sites

Sous Firefox, j'ai un message "Echec de téléchargement de l'applet Java".

As-tu bien mis l'applet où il est supposé être ? Quelles sont les permissions d'accès ?

As-tu bien respecté majuscules et minuscules. Windows s'en fiche mais pas Linux :)

Dan

Share this post


Link to post
Share on other sites

Ton Applet nécessite les fichiers suivants, qui n'aparaissent pas sur ton serveur (erreur 404 quand j'essaye de les charger) :

http://mylenefarmer.streamlinenettrial.co..../PVButton.class

http://mylenefarmer.streamlinenettrial.co....PVCaption.class

http://mylenefarmer.streamlinenettrial.co..../PVCanvas.class

Par contre, si j'essaies de charger les même fichier "avec majuscules" ça marche !!! Donc, DAN a déja soulevé un premier problème. La casse des fichiers est trés importante, à la fois sur Internet et pour Java.

Si ça ne résoud pas ton problème, ajoute ensuite le tag codebase à la balise applet. Parfois, ça marche mieux :).

Ensuite, il serait sans doute préférable de mettre ton application dans une archive .jar (commande jar cf nom_archive liste_des_fichiers)

Tiens nous au courant de l'effet de ces modifications.

Tizel

Share this post


Link to post
Share on other sites

MERCI beaucoup les gars pour vos reponce.

Je suis en train d'enlever les majuscules pour voire si ca marche, si j'avais sue j'aurais du heberger sous Windows et pas Linux pour eviter c'est problem.

Je vous tient au courant et MERCI ENCORE pour vos reponse ;)

Share this post


Link to post
Share on other sites

Ok apparament maintenant il charge completement (cool) MAIS il affiche "Init error, PicView stopped" vous pensez que ca viens de quoi maintenant ? Je pense que ca viens des majuscules aussi, je fais des tests pour voire

Je l'ecrit comme ca :

PICView.class

puis comme ca:

PicView.class

ou

PICview.class

ou picview.class

Mais ca marche toujours pas :angry:

Edited by cecemf

Share this post


Link to post
Share on other sites
Je suis en train d'enlever les majuscules pour voire si ca marche, si j'avais sue j'aurais du heberger sous Windows et pas Linux pour eviter c'est problem.

Ca n'aurais rien changé !! Et pour cause, les fichier ".class" java doivent avoir la même casse que le nom des classes. Que tu travaille sous windows ou pas.

Tu dois écrire ton fichier comme le nom de ta classe.

http://mylenefarmer.streamlinenettrial.co..../PicView.class

http://mylenefarmer.streamlinenettrial.co..../PVButton.class

http://mylenefarmer.streamlinenettrial.co....PVCaption.class

http://mylenefarmer.streamlinenettrial.co..../PVCanvas.class

Tant que tu n'aura pas uploadé correctement les fichiers sur ton serveur, on ne peut pas vraiment résoudre ton problème.

Donne nous aussi le répertoire exact dans lequel tu as mis tes fichiers.

Tizel

Share this post


Link to post
Share on other sites

SAYER J'AI REUSSI !!!!!

Le fichier "DIAPO.TXT" dans l'applet etait ecrit en petit "diapo.txt" et maintenant ca marche.

Vous pouvais essayer de votre coter SVP pouvoire si ca marche aussi ?

http://mylenefarmer.streamlinenettrial.co....eographieSC.php

MERCI MERCI MERCI pour votre aidee vous m'avais sauvez la vie :hourra::hourra::hourra:

Edited by cecemf

Share this post


Link to post
Share on other sites

Bonjour cecemf et bienvenue sur le Hub.

J'interviens pour te demander de faire attention à l'orthographe. Je suis ne suis par une star de l'orthographe mais il y a un minimum d'efforts à faire pour le respect des lecteurs.

Merci

Nicolas.

Share this post


Link to post
Share on other sites

Bravo...

Effectivement, comme le souligne Nicolas, fais attention à l'orthographe, c'est plus agréable à lire un texte bien écrit :)

Tizel

Share this post


Link to post
Share on other sites
Bonjour cecemf et bienvenue sur le Hub.

J'interviens pour te demander de faire attention à l'orthographe. Je suis ne suis par une star de l'orthographe mais il y a un minimum d'efforts à faire pour le respect des lecteurs.

Merci

Nicolas.

<{POST_SNAPBACK}>

Je suis desoler mais je fais de mon mieux car j'ai quitter la France il y a plus de 5 ans et que je vie a Londres donc parle Anglais et je perd mon Francais malheureusement

DESOLER

Share this post


Link to post
Share on other sites
Bravo...

  Effectivement, comme le souligne Nicolas, fait attention à l'orthographe, c'est plus agréable à lire un texte bien écrit :)

  Tizel

<{POST_SNAPBACK}>

Donc vous avais essayer la page et ca marche de votre coter aussi ?

Share this post


Link to post
Share on other sites

Oui, ça marche, aussi bien sous Firefox que sous Internet Explorer.

Tizel

Share this post


Link to post
Share on other sites

Desoler les gars de vous reecrire mais en faite j'ai un deuxiemes et dernier menu en java qui et a peut pret le meme et j'y est apporter les memes modification que le premier comme vous me l'avais conseiller avant et cette fois si il m'affiche "param error" seriez vous d'ou ce probleme viens MERCI D'avance

La page:

http://mylenefarmer.streamlinenettrial.co..../AQLalbumSC.php

Les fichiers:

http://mylenefarmer.streamlinenettrial.co..../AQLalbumSC.zip

PS: ceci et ma derniere requete je vous embete plus apres

MERCI D'AVANCE

Edited by cecemf

Share this post


Link to post
Share on other sites

Si je me référe à la doc (fichier source.txt) , tu doit mettre sur ton site un fichier "diaporama.txt".

Or, toi, tu as mis sur ton serveur un fichier "diaporama.TXT"...

Tizel

Share this post


Link to post
Share on other sites
Si je me référe à la doc (fichier source.txt) , tu doit mettre sur ton site un fichier "diaporama.txt".

Or, toi, tu as mis sur ton serveur un fichier "diaporama.TXT"...

Tizel

<{POST_SNAPBACK}>

MERCI encore j'avais pas fait gaffe au extension qui etait pas vivible sur mon ordi maintenant TOUT marche super bien MERCI ENCORE ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...