Aller au contenu
shest

Pear : problème de version

Noter ce sujet :

Recommended Posts

Bonjour,

Je sollicite votre aide car je ne vois pas comment résoudre un problème de compatibilité entre un script et un module Pear.

Notre site (assez complexe) fonctionnait très bien jusqu'à ce que nous ayons un problème de bande passante et nous avons été obligé de changer d'abonnement. L'hébergeur est NativeSpace. Lors du changement d'abonnement notre site a été déplacé sur un autre serveur, et lorsque nous y avons mis notre site, il ne fonctionnait plus.

Le problème est le suivant: les scripts de notre site utilisait DB_DataObject en version 1.5.3. Le serveur sur lequel nous avons été déplacé est équipé de la version 1.8.4. Du coup les requête à la base de données ne fonctionnent plus... Nativespace nous a simplement dit que nous devions réviser notre script... :thumbsdown:

Y'a-t-il un moyen de mettre à jour mon site facilement car je n'y connais RIEN en PEAR ?? les fichiers du repertoire Pear du site n'a pas grand chose à voir avec le contenu du package DB_DataObject en version 1.8.4... :wacko:

Est-ce normal que Native space nous demande de modifier le script ??

N'est-ce pas à eux de s'arranger pour que le serveur vers lequel ils nous ont déplacé soit configuré de sorte que notre site continu de fonctionner normalement? cela fait 3 semaines que notre site est bloqué...

Merci d'avance pour votre aide !!

- Shest -

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est pas pour rien que la plupart des CMS qui utilisent PEAR le fournissent avec dans les includes... car le script a été testé avec la version de PEAR fournie.

Il faut regarder au niveau des changelogs du script:

http://pear.php.net/package/DB_DataObject/download/

Si tu ne trouves pas, la communauté PEAR pourra surement te répondre:

http://pear.php.net/support/lists.php

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci beaucoup pour ta réponse!

Je n'ai pas compris comment il fallait procéder pour updater mon script avec le package le plus récent... wacko:

J'ai posté mon problème sur le forum de pear.php.net mais toujours pas de réponse...

Enfin, juste pour précision, au cas ou quelqu'un sait, je ne vois pas comment mettre à jour mon site à partir du nouveau package db_dataobject 1.8.4. S'agit-il de substituer les fichiers (dataobject.php par exemple) ? mais les contenu divergent pas mal apparement... existe-t-il une technique automatisée pour faire cela?

j'y connais rien en pear vous l'aurez compris!

merci d'avance,

Partager ce message


Lien à poster
Partager sur d’autres sites
Est-ce normal que Native space nous demande de modifier le script ??

N'est-ce pas à eux de s'arranger pour que le serveur vers lequel ils nous ont déplacé soit configuré de sorte que notre site continu de fonctionner normalement? cela fait 3 semaines que notre site est bloqué...

Si vous êtes en hébergement mutualisé c'est tout à fait normal.

Enfin, juste pour précision, au cas ou quelqu'un sait, je ne vois pas comment mettre à jour mon site à partir du nouveau package db_dataobject 1.8.4. S'agit-il de substituer les fichiers (dataobject.php par exemple) ? mais les contenu divergent pas mal apparement... existe-t-il une technique automatisée pour faire cela?

Non pas de technique automatisée, il vous suffit de remplacer les méthodes d'accès aux objets dans votre script. Certes cela peut etre fastidieux si votre site utilise souvent cette classe.

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai commencé a adapter mon script, d'erreur en erreur j'en suis la...:

DB_DataObject Error: Unable to load schema for database and table (turn debugging up to 5 for full error message)

Je dois mettre le debuglevel a 5 semble-t-il pour avoir l'affichage complet des erreurs mais ou dois-je inserer ce code :" DB_DataObject::debugLevel(5); "????

:wacko:

ajout :

Ce probleme de version survient depuis que nous avons changer de serveur (mais toujours chez le meme hebergeur). J'ai le choix entre tenter de mettre à jour mon script (mais je suis bloqué) ou bien changer carrément d'hébergeur en recherchant un hébergeur qui fonctionne avec la meme version de pear que celle pour laquelle mon script a été ecrit...... est-ce vraiment nécessaire de passer à la version supérieure de pear et d'adapter mon script???? car j'ai peur de passer trop de temps sur l'adaptation du script...

Merci,

Modifié par shest

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tu changes de serveur où ils ont la librairie PEAR qui fonctionne, tu ne fais que de repousser le problème à plus tard...

Je ne sais pas le script que tu utilises, mais il faudrait peut être que tu regardes à mettre TA copie de PEAR dans un répertoire et changer l'include_path de ton script pr utiliser TA copie de PEAR avec DB_DataObject 1.5.3.

Partager ce message


Lien à poster
Partager sur d’autres sites

La majoritée des hébergeurs vont sans doute passer un jour ou l'autre à la version superieure tu as raison;

c'est pourquoi j'ai commencé à adapter mon script, c'est à dire :

j'ai télécharger la version nécessaire de DB_dataobject et j'ai substitué le nouveau fichier dataobject.php par le nouveau en adaptant les chemins de fichier. J'en suis à l'erreure mentionnée plus haut, à savoir que je dois mettre le "debuglevel" à 5... mais je le mets ou !? (lol je suis un peu perdu là...)

De plus les auteurs des scripts du site ont de nombreux fichiers dans le repertoire PEAR, dataobject_ceci.php, dataobject_cela.php... une vaingtaine ! tous ces fichiers sont à réactualiser sans doute (?).

(ps: Pourquoi les créateurs de PEAR n'ont-ils pas fait un script pour updater automatiquement la version de PEAR dans les scripts...??!! :mad2: )

Partager ce message


Lien à poster
Partager sur d’autres sites
...j'ai substitué le nouveau fichier dataobject.php par le nouveau en adaptant les chemins de fichier.

Attends !? tu es en train de dire que c'est ton hébergeur qui a une version différente de PEAR, donc théoriquement tu n'a pas accès à la librairie.

Par contre si tu as la librairie incluse dans tes repertoires etque tu n'a pas les compétences pour mettre à jour ton application il te suffit de modifier l'include path à chaque fois que tu fais appel à la librairie que tu as installé.

...il faudrait peut être que tu regardes à mettre TA copie de PEAR dans un répertoire et changer l'include_path de ton script pr utiliser TA copie de PEAR avec DB_DataObject 1.5.3.

Lien sur l'include_path

Partager ce message


Lien à poster
Partager sur d’autres sites

Je crois comprendre ce que tu me suggères de faire mais je ne m'en sors toujours pas... En fait sur le site il y a un repertoire PEAR dans lequel est contenu ma librairie DB (1.5.3 au départ, modifié en 1.8.4 pour tester).

En local par exemple, le repertoire PEAR d'easyPHP ne sert à rien puisque le script redirige directement vers la version contenu dans le repertoire PEAR du site...

Donc, peu importe la version du serveur dans ce cas ??? les include_path renvoient bien vers MA version de Pear sur MON repertoire... Mais en production il ne se passe rien ... de base le message d'erreur était le suivant :

"dataobjects_produit Object ( [_DB_DataObject_version] => 1.5.3 [__table] => produit [N] => 0 [_database_dsn] => [_database_dsn_md5] => 1****862*******5** [_database] => "etc...

(....cela sur une trentaine de ligne...)

Donc les include ca devrait etre bon...pourquoi ça ne marche pas? je ne dois rien modifier sur le serveur si ma version de pear est contenu dans un repertoire du site..??!!

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

En local ton include_path est pas forcemment le même !

c'est quoi ton serveur de développement ? Unix ou windows ?

pense que même si il est placé dans le même répertoire mais que ton serveur de développement est windows le include_path diffère. (saleté de X !!)

Donc les include ca devrait etre bon...pourquoi ça ne marche pas? je ne dois rien modifier sur le serveur si ma version de pear est contenu dans un repertoire du site..??!!

bah non et la version de PEAR aisni que ton site doivent être totalement identique à ton ancienne version (sans la modification de PEAR, ni des fonctions du site).

Ce n'est pas vraiment ce que je recommande... mais tu avais l'air de galerer et d'être pressé.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour!

c'est encore moi... je n'ai pas résolu mon problème relatif à ma version de pear. J'ai tenté de déplacer le site sur un serveur dont la version de DB_database est la même que celle utilisé sur le site à l'origine (1.5.3). Mais j'ai à nouveau des erreurs...

J'ai donc quelques questions pour les spécialistes de PEAR :

Mon site fonctionne à peu près, c'est à dire que la partie Back-office fonctionne et les requêtes qui y sont utilisées fonctionnent correctement dans l'ensemble. Partie Front, ma première liste (qui appel son contenu dans la base) reste vide...

Si je déplace mon site (j'ai exporté puis importé la base qui est à 99% identique à celle d'origine) les classes objets doivent-elles être générées à nouveau ou bien devraient-elles fonctionner tout de suite ?

Dois-je faire des modifs sur les classes en elle-même ?

quelqu'un connait-il la procédure exact pour générer les classes?

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour le meilleurs et pour le ...PEAR :(

Est-ce que quelqu'un pourrait faire un petit tuto pour les débutants sur l'usage de PEAR ??

Mon problème n'est pas résolu... je suis en train de me demander si je ne vais pas refondre le site en remplaçant toutes les requête effectuées grâce à PEAR par des requêtes classiques... et vue le site cela ne vas pas être une mince affaire. Je suis débutant en PHP et j'avou que PEAR me pose beaucoup de difficultées.

A ce sujet quelques questions :

Que pensez-vous de l'usage des procédures PEAR pour les requêtes sur les bases de données ? (notamment DB_dataobject, version 1.5.3 en l'occurence) est-ce que cela optimise réellement les requêtes et en quel sens ?

Un site avec une base de données assez importante peut-il se passer sans problème de PEAR ? (je pense que oui mais je veux savoir si pear va se rependre dans les conceptions des webmasters ou si ces procédures vont restées marginales ? en d'autres termes la connaissance de pear va-t-elle devenir indispensable pour un webmaster ? )

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×