Jump to content
Sign in to follow this  
furious Gontran

Probleme de Php ou de wamp ?

Rate this topic

Recommended Posts

Bonjour,

Je fais un formulaire recuperant mes donnees dans la base et les affichant.

Ma requete est bonne les données sont bien recues.

Cependant le HTML n'interprete pas le php:

Je code:

<input name='Nom' type='text' size='80' maxlength='100' value='<? echo $nom; ?>'>

Et en fait dans mon champs texte j'ais le code PhP et non la variable nom...

Cela vient il de mon code ou d'un soucis de configuration de wamp ??

Share this post


Link to post
Share on other sites

Acceptes-tu les "short tags" ? Parce que avec les tags entiers il faudrait écrire <?php echo $nom; ?> plutôt ;)

Sinon, si ta page est au format .html (et nommée autrement que .php) il faut ajouter une directive pour forcer php à interpréter les pages .html aussi...

AddType application/x-httpd-php .html

Dan

Share this post


Link to post
Share on other sites

Je pense qu'en programmation (web et autre), il faut prendre le plus vite possible les bonnes habitudes : Franchement, les short-tags servent à quoi ? :sick:

Certes, cela économise 3 misérables caractères à chaque fois, mais en contrepartie ce n'est que rarement supporté par les serveurs... Pour moi, le choix est vite fait ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...