Jump to content

Flash et bordures qui apparaissent sur IE au survol


Recommended Posts

Bonjour,

je viens de m'apercevoir que mes animations flash avaient un petit bug sur IE. Je ne parviens pas à l'enlever, il s'agit de bordures qui apparaissent quand on survole le flash, quand on clique dessus, elles disparaissent.

Comment pourrais-je les enlever?

Merci d'avance

Link to post
Share on other sites

Malheureusement ce n'est pas un bug.

Pour pouvoir activer les flash dans ie, il est maintenant nécessaire de cliquer dessus (depuis quelques mois, une histoire de procès je crois... mais certains en sauront plus que moi :)).

Pour contrer cela, il faut insérer le flash à coup de javascript. Je crois avoir croisé parfois des topics concernant la manip exacte à faire sur le hub. Je pense qu'une toute petite recherche devrait te permettre de dénicher ça :)

Link to post
Share on other sites

Tout d'abord merci pour vos réponses, mais si vous regardez mon code source, il est assez spécial:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" id="accueil" align="middle" height="220" width="320">
<param name="FlashVars" value="xmlFile=http://rouvroy.info/flashadmincom/accueil.xml&preloaderBackColor=0x0099FF&preloaderBorderColor=0xCCCCCC">
<param name="movie" value="http://rouvroy.info/flashadmincom/slideshowpro.swf">
<param name="quality" value="best">
<param name="scale" value="noscale">
<param name="wmode" value="window">
<param name="bgcolor" value="#FFFFFF">
<embed src="http://rouvroy.info/flashadmincom/slideshowpro.swf" id="accueil" wmode="window" quality="best" flashvars="xmlFile=http://rouvroy.info/flashadmincom/accueil.xml&preloaderBackColor=0x0099FF&preloaderBorderColor=0xCCCCCC" scale="noscale" bgcolor="#FFFFFF" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" height="220" width="320">
</object>

Il est généré par le plugin Active SlideShow de Dreamweaver, si je modifie ce code, ça risque de ne plus fonctionner... :wacko: Quand, je regarde les démonstrations sous IE (ce que je n'avais pas vu avant), il me fait la même chose... :(

Comment pourrais-je modifier cela sans faire trop de dégats?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...