Jump to content

MODx 0.9.5 Finale ! (5/12)


davidm
 Share

Recommended Posts

Ca fait quelques temps que je donne des nouvelles de MODx via le fil de discussion original (MODx : SPIP Killer ?), mais celui-ci est devenu à mon sens un peu trop long... Je me servirai de ce fil pour annoncer les sorties de la 0.9.5, et receuillir vos témoignages :)

Après avoir annoncé la sortie de la première beta, voici l'annonce de la beta 2 et pour ceux qui ont testé la précedente, voici les points corrigés :

  • Corrigé un problème de retour à la ligne qui affectai certaines install dans /manager/includes/document.parser.class.inc.php.
  • Quelques chemins d'images corrigés dans le manager
  • Mise à jour de Wayfinder (Note : snippet de menu) à la dernière version dispo
  • Suppression des dernières références au log des visites dans le manager (Note : le système de stats intégré est supprimé à compter de la 0.9.5, préférer le plugin Slimstat, Mint ou BBClone)
  • Plusieurs fix du code qui produisait des alertes php dans certains environnements
  • Correction des headers pour les erreurs 404 et 401, utilisant une nouvelle fonction de l'API de MODx : sendForward (docId, httpResponseHeader) . Grâce à cette fonction, vous pouvez contrôler l'entête http de n'importe quel document MODx, sans redirection. Les fonctions sendErrorPage() et sendUnauthorizedPage() ont été ré-écrite pour utiliser cette fonction.
  • Lorsque le site est en maintenance, il produit un header 503 (Temporarily Unavailable)

Vous pouvez télécharger la beta 2 ici : http://modxcms.com/beta.html

Bon test !

Link to comment
Share on other sites

  • Replies 73
  • Created
  • Last Reply

Top Posters In This Topic

  • 2 weeks later...

Voici la beta3 (rev 1531) sortie aujourd'hui, avec une modification complète des contenus par défaut (snippets, exemples, menus...), ainsi que pas mal de bugs résolus et de petites améliorations fonctionnelles par rapport à la beta2.

A noter, l'admin est en train de subir une refonte donc seul le thème "Light" fonctionne avec cette beta.

Pour le téléchargement, c'est toujours ici :

http://modxcms.com/beta.html

Bon test !

Link to comment
Share on other sites

Salut

Trop vite, tu trouves?

David annonce une rev 1531 et moi j'ai obtenu la rev 1532 à 16h30.

C'est vrai qu'ils sont très réactif.

Aour

Sur ce coup là, c'est toi qui est hyper-réactif : tu obtiens la rev1532 à 16h30 et tu postes sur le forum à 16h14 :thumbsup:

Link to comment
Share on other sites

lol

disons qu'entre le serveur du Hub et mon serveur de temps il y a un décalage et on est déjà en 1533. On approche du but

<joke>OVH est toujours un peu à la traine</joke>

et une petite

Aour

Edited by aour
Link to comment
Share on other sites

Salut

Trop vite, tu trouves?

David annonce une rev 1531 et moi j'ai obtenu la rev 1532 à 16h30.

C'est vrai qu'ils sont très réactif.

Aour

c'est surtout que j'ai pas le temps de tester une version qu'une nouvelle sort... snif...

Link to comment
Share on other sites

Salut

Trop vite, tu trouves?

David annonce une rev 1531 et moi j'ai obtenu la rev 1532 à 16h30.

C'est vrai qu'ils sont très réactif.

Aour

C'est peu être que la 1531 avait qqs bug, j'ai pas réussi hier à la faire fonctionner correctement (entre autre bug sur l'encodage des caratères et l'accès à la config générale), d'ailleur ils en sont a la 1533 ce matin

Edited by Dadou
Link to comment
Share on other sites

re

oui chaque bug fait l'objet d'une correction assez rapide.

à 14h18 heure de mon pc, je suis en 1540 via le svn

Concernant les souci d'install je n'en n'ai jamais eu encore et je fais 1 install/ jour pour verifier les corections

Aour

Link to comment
Share on other sites

Rien que la nouvelle interface en back-office, c'est un grand plus ! :cool:

Moi qui galère avec drupal (produit génial mais avec qqs défauts de "jeunesse" et requiérant des bonnes connaissance php pour les templates et pour comprendre son fonctionnement...), je crois que je vais changer mon fusil d'épaule... ;)

Par contre, j'ai un petit problème d'encodage sur les caractères accentués en back-office, normal ?

Edited by NiCoS
Link to comment
Share on other sites

Content de voir qu'on a fait un converti :P Et au fait, MODx (1 an + presque 2 ans d'Etomite) est bien plus jeune que Drupal (>4/5ans)

Pour les caractère accentués, oui normal si tu n'as pas basculé en ISO-8859-1 (latin1, c'est le réglage juste en dessous de la langue)... sinon il faudra faire comme moi et basculer ton ficher de langue (dans manager/includes/lang/francais.inc.php) en utf-8. Je suis en train de militer en interne pour basculer les fichiers de langue en utf-8, d'ailleurs :)

Petite astuce aussi, ajouter

setlocale(LC_TIME, 'fr', 'fr_FR', 'fr_FR.ISO8859-1');

en tête de fichier de langue pour la localisation des dates :) (Merci Nissai pour l'astuce)

Pour les nouvelles interfaces (MODX Light, LightGrey, LightBlue, MODx Red, MODx Black), elles sont sympa oui. Les versions "light" sont rapide, avec un thème léger.

D'autre part, le javascript a été largement "nettoyé" d'où le gain en vitesse aussi :)

Link to comment
Share on other sites

A noter, l'admin est en train de subir une refonte donc seul le thème "Light" fonctionne avec cette beta.
Rien que la nouvelle interface en back-office, c'est un grand plus ! :cool:
Voilà la nouvelle que j'attendais depuis longtemps ! :)

Je fonce sur cette version, j'avais boudé les autres rien que pour ça :blush:

Je rêve d'une interface admin en vrai AJAX, sans cadres, et rapide: on va voir ce que ça donne..

Merci pour l'info.

Link to comment
Share on other sites

Content de voir qu'on a fait un converti :P Et au fait, MODx (1 an + presque 2 ans d'Etomite) est bien plus jeune que Drupal (>4/5ans)

Oui mais non, modx ne gère pas le multicatégories et j'en ai vraiment besoin... je vais donc continuer avec drupal pour mon projet et reviendrait sur modx pour un autre plus tard ;)

Merci pour l'astuce pour l'encodage ;)

Bizarre que modx pousse le latin1 alors que de plus en plus de cms vont vers l'utf8 only...

Link to comment
Share on other sites

@Dudu : non l'admin a été nettoyée, javascript et styles, mais il y a toujours du js et des frames :( C'est une étape transitoire avant la véritable refonte complète... Il est probable qu'on utilisera MooTools pour l'admin (et d'ailleurs aussi qu'on lâche script.aculo.us pour MooTools côté frontend...).

@NiCoS : si tu n'as pas besoin de catégorie "hiérarchiques", les tags peuvent être une solution rapide et viable pour catégoriser l'information et la trier ensuite via Ditto...

Pour le latin1, je suis 100% d'accord... un héritage d'Etomite :P

Link to comment
Share on other sites

Bonjour,

Concernant l'encodage, Modx laisse le choix et je trouve cela préférable.

Par défault Modx est en UTF8 mais le fichier french fourni est en latin1.

Il suffit de remplacer le fichier dans la distrib.

Concernant les catégories, il y a les tags

Aour

Link to comment
Share on other sites

@NiCoS : si tu n'as pas besoin de catégorie "hiérarchiques", les tags peuvent être une solution rapide et viable pour catégoriser l'information et la trier ensuite via Ditto...

Non j'ai "malheureusement" de multicatégories hiérarchiques ;)

Link to comment
Share on other sites

Je viens juste de poster sur les forums le fichier de langue pour MODx 0.9.5, vous pouvez en savoir plus et le télécharger ici :

Fichier de langue mis à jour pour 0.9.5 (Latin1 + utf-8) : a tester !

Ceux qui n'ont pas encore eu l'occasion de le faire devraient jeter un coup d'oeil aux thèmes MODx Light et MODx LightBlue !

Link to comment
Share on other sites

  • 2 weeks later...

Bonsoir :)

Je m'intéresse depuis quelques heures à MODx que je viens de découvrir.

J'ai visité plusieurs forums, anglais et français, parcouru quelques fichiers d'infos. Avant de poursuivre mes recherches, j'aurai apprécié vous poser une question, à vous qui êtes expérimentés.

Donc, ai-je raison d'imaginer qu'il est possible de créer un fichier Xhtml pour les conteneurs, une feuille CSS pour la mise en forme et d'y inclure des éléments propres à MODx (des snipplets, chunks je crois aussi et autres modules) afin d'obtenir un CMS totalement personnalisé ?

Si oui, où puis-je trouver de la documentation en français (de préférence, en anglais il semble beaucoup y en avoir) sur l'intégration de ces éléments propres à MODx ?

Ah, une autre question, je n'ai pas réussi à comprendre, de par mes lectures, s'il était possible d'intégrer un forum, du moins cela demeure flou par rapport à ce que j'ai lu, il semble que oui (j'ai trouvé un module nommé SFM_Forum_Intégration) mais je ne trouve pas comment établir le lien entre ce module et mon MODx de test. Il y a bien un dossier plugin et un autre modules dans "assets" mais une fois copié dedans via FTP je patauge un peu (beaucoup) pour l'afficher dans la page. Et toutes mes recherches de tutos ou dans les FAQ sont restées vaines.

Merci à vous.

Cordialement.

Link to comment
Share on other sites

Donc, ai-je raison d'imaginer qu'il est possible de créer un fichier Xhtml pour les conteneurs, une feuille CSS pour la mise en forme et d'y inclure des éléments propres à MODx (des snipplets, chunks je crois aussi et autres modules) afin d'obtenir un CMS totalement personnalisé ?

Oui tu as raison, mais en fait, ce n'est pas propre à MODx.

La plupart des CMS permettent de construire des templates html au sein duquel sont insérés des éléments dynamiques, et CSS pour les styles. Maintenant, certains sont plus facilement conformes à xhtml et ont une bonne séparation entre la présentation et le contenu (c'est à dire, peu d'éléments de présentation "harcodés" dans le code qui lui vise avant tout à effectuer des manipulations sur le contenu, et quand il y en a des éléments qui soient propres i.e conforme xhtml). MODx fait partie de la famille des CMS récents qui ont un haut degré de séparation entre présentation et contenu.

Un de ses points forts, c'est aussi le contrôle du code xhtml produit par les extensions (snippets, modules, plugins), via un système de micro-templates (en quelque sorte la couche "présentation" des extensions qui étendent les capacités de traitement du contenu). Les micro-templates permettent de contrôler très précisémment le placement des valeurs des variables disponibles pour une extension donnée. Cela semble un peu abstrait, mais les exemples de code ne manquent pas sur le forum.

Pour préciser les choses :

- les chunks sont des bouts de code ré-utilisables

- les snippets sont des programmes php qui étendent les fonctionnalités de MODx au niveau du frontend, ils sont "appelés" (exécutés) par des tags et permettent de passer des paramètres et de définir des micro-templates

- les plugins sont des programmes php qui étendent aussi les fonctionnalités de MODx, qui concerne le backend (manager) ou le frontend mais alors ils ont une étendue globale (tout le site). Leur particularité est aussi qu'ils tirent parti du système d'évènement qui fait partie de l'API (un plugin peut être activé à un moment précis du parsing, par exemple, OnLoadWebDocument ou OnSaveDocument...etc).

- les modules sont aussi des extensions php mais qui étendent les fonctionnalités du manager (backend ou admin) ou qui permettent de se connecter à d'autres applications (exemple du module SMF qui intègre le mécanisme d'authentification de SMF avec MODx et qui permet d'accéder à l'admin de SMF via l'admin de MODx de manière transparente).

Si oui, où puis-je trouver de la documentation en français (de préférence, en anglais il semble beaucoup y en avoir) sur l'intégration de ces éléments propres à MODx ?

La doc française se trouve ici : http://www.tattoocms.info/wiki/doku.php

Ah, une autre question, je n'ai pas réussi à comprendre, de par mes lectures, s'il était possible d'intégrer un forum, du moins cela demeure flou par rapport à ce que j'ai lu, il semble que oui (j'ai trouvé un module nommé SFM_Forum_Intégration) mais je ne trouve pas comment établir le lien entre ce module et mon MODx de test. Il y a bien un dossier plugin et un autre modules dans "assets" mais une fois copié dedans via FTP je patauge un peu (beaucoup) pour l'afficher dans la page. Et toutes mes recherches de tutos ou dans les FAQ sont restées vaines.

Oui il existe un module pour SMF, et un pour Phorum (en cours de développement).

Pour installer un module comme celui de SMF il faut :

- avoir une install de SMF en ordre de marche, avec les paramètres sous la main

- créer un nouveau module dans l'admin, copier-coller le code du module et sauver, en suivant les instruction de configuration.

- lancer la synchronisation des utilisateurs et du compte admin

- et voilà !

Pour plus de détail, se reporter à la doc incluse.

En cas de souci, rendre visite aux forums :)

Link to comment
Share on other sites

Un grand merci à toi David pour avoir pris le temps de m'expliquer tout ça :)

C'est clair et je vois mieux maintenant l'interaction de ces différents éléments. Suis bien tenté de me lancer dans l'écriture d'un modèle et de voir ce que je pourrai y ajouter ensuite comme fonctionnalités :)

Bonne journée à toi, merci pour les liens d'infos aussi.

Philos

Link to comment
Share on other sites

Oui, j'ai pris ma pelle et mon seau et je creuse tout ça :)

Totalement HS, mais es tu aussi modérateur sur Alsacreations ?

Bon week end.

[Edit Philos] Je peux m'appuyer sur ce post pour poser d'autres questions, ou bien ailleurs ou pas du tout car ça saoule ? :)

Edited by Philos
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By aurelien59
      Bonjour,   Je me permet de poster ce problème sur ce forum en plus de l'avoir posté sur un autre.   Le problème survient sur un site codé en dur.   Depuis plusieurs mois après la mise en place de redirection, je rencontre un problème. La redirection a été mise en place pour rediriger simplement les pages ayant un underscore vers un tiret. Par exemple page_1.php vers page-1.php   Dans Google webmasters tools, zone "Exploration", > Erreurs d'exploration > le nombre des URL non suivies à augmenter de manière considérable sur ordinateurs et smartphone.
      Voici un exemple de page contenant l'erreur :   page-1.php/page-a.php (alors que la page correcte est page-1.php, la page page-a.php est présente sur le site en racine).   Lorsque je clic sur l'url d'erreur, dans l'onglet "Référencée sur". Les url qui apparaissent sont : http://www.monsite.fr/page-2.php/page-b.php'>>http://www.monsite.fr/page-2.php/page-b.php et http://www.monsite.fr/page-2.php/page-c.php'>>http://www.monsite.fr/page-2.php/page-c.php (non indexés sur Google).   Voici l'extrait du .htaccess ErrorDocument 404 http://www.monsite.fr/404.php RewriteEngine on RewriteCond %{HTTP_HOST} ^monsite.fr$ RewriteRule ^(.*) http://www.monsite.fr/$1 [QSA,L,R=301] RewriteRule ^([^_]*)_([^_]*)$ /$1-$2 [L,R=301] RewriteRule ^(.*)\.php/$ http://www.monsite.fr/$1.php[L,R=301] RewriteRule ^(.*)\.php/(.*)\.php$ http://www.monsite.fr/$1.php[R=301] RewriteCond %{REQUEST_FILENAME} -s [OR]RewriteCond %{REQUEST_FILENAME} -l [OR]RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^.*$ - [NC,L]RewriteRule ^.*$ /404.php [NC,L] Merci beaucoup pour votre aide.
    • By Asaiel
      Bonjour à tous,
       
      Nouveau sur ce site, je sollicite votre aide pour résoudre un problème que je rencontre actuellement sur l'utilisation de "mod_rewrite" et de ses directives.
      Je précise que je suis novice concernant cet élément.
       
      Les données:
      Les fichiers relatifs au site que je développe actuellement se trouvent dans un dossier qui n'est pas à la racine de mon serveur de test (NAS Synology).
      l'url de base est donc de la forme suivante: https://MonNas.local/private/MonSite (et non pas https://MonSite).
       
      Je dispose du .htaccess suivant à la racine du site:
      RewriteEngine On RewriteBase /private/MonSite/ RewriteRule ^([a-zA-Z0-9\-\_\/]*)$ index.php?p=$1  
       Cette directive me permet (en principe 😅) de convertir l'adresse suivante (vérifié depuis ce site)
      URL 1 (demandée): https://MonNas.local/private/MonSite/login/lostpassword En:
      URL 2 (réécrite): https://MonNas.local/private/MonSite/index.php?p=login/lostpassword  
      Dans ma page à afficher, j'ai les références suivantes dans les en-têtes:
      <head> <meta charset="utf-8"> <title>MonTitre</title> <!-- css --> <link rel="stylesheet" href="./resources/vendor/fa/css/all.min.css"><!-- css font-awesome --> <link rel="stylesheet" href="./resources/vendor/bootstrap/css/bootstrap.min.css" id="bootstrap-css"><!-- css bootstrap --> <link rel="stylesheet" href="style.css" type="text/css"><!-- css custom --> <!-- js libraries --> <script src="./resources/vendor/bootstrap/js/bootstrap.bundle.min.js"></script><!-- js bootstrap --> <script src="./resources/vendor/jquery/js/jquery-3.6.0.min.js"></script><!-- js jquery --> <meta name="viewport" content="width=device-width, initial-scale=1"> </head>  
      Le problème:
      Lorsque j'accède à l'URL 1, aucune de mes références CSS, JS et img ne fonctionne.
      Lorsque je tape directement l'URL 2 dans la barre d'adresse, tout fonctionne bien.
       
      Pouvez-vous svp m'aider à trouver où se trouve mon erreur?
       
      Merci d'avance 🙂
    • By cyberdede
      Bonjour à tous

      je voudrais quand je tape https;//monsite/dossier accéder à https;//monsite/dossier/index.php
      or j'accède à https;//monsite/dossier/ avec un 404

      en localhost ca fonctionne

      pour la racine https;//monsite c'est ok

      mon htaccess
       
      RewriteEngine On Options -Indexes RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^([^\.]+)$ $1.php [NC,L] RewriteCond %{HTTPS} ^off$ [NC] RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L] AddDefaultCharset UTF-8 ErrorDocument 404 /404.php  
    • By kevinjoseph
      Bonjour, j’ai un gros problème sur mon site Wordpress . Du jour au lendemain, mon site wordpress fais une redirection vers un autre site wordpress que j’ai crée ,sans que je touche à quoi que ce soit. Quand j’essai d’aller sur l’admin pour désactiver les plugins et voir d’où peut venir le problème. Impossible d’accéder, sa me redirige vers l’admin de l’autre site. Au final il est impossible que j’accède au site via (google, la bare de recherche, les favoris, l’admin…) pour voir ce qu’il fonction pas, j’ai juste accès au FTP. J'ai essayé de voir d'où pouvez venir ce bug en supprimant les plugins, le théme, mes derniers modifications, regarder sur le .htaccess si il y avais quelque par le nom de domaine de l'autre site écrit. Ca n'a rien changer, le site continue de ce rediriger automatiquement vers l'autre site. Si vous avez une idée d’où sa peut venir ou comment faire pour arranger ça et surtout comment éviter que sa ce reproduise. Sa m’aiderai beaucoup, merci d’avance.
      voici le code du .htaccess:
       
      # BEGIN WordPress
      <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteBase /
      RewriteRule ^index\.php$ - [L]
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule . /index.php [L]
      </IfModule>

      # END WordPress
      ~   Ludovic • 16:28    

×
×
  • Create New...