Jump to content
Sign in to follow this  
DuR0

Url rewriting + gentoo

Rate this topic

Recommended Posts

Bonsoir,

Après avoir regarder un peu d'ou pouvait venir le problème... Je viens à vous encore une fois.

Voici mon .htacces

RewriteEngine on
RewriteRule ^index\.html$ /index\.php [L]

-> Rien de plus simple. Place à la racine de mon site web. Dans httpd.conf j'ai bien :

LoadModule rewrite_module module/mod_rewrite.so

Mais il lors de l'appelle à index.html il ne me trouve pas la page...

D'ou peut venir le problème sachant que le "Multiviews" à déjà été supprimer.

Merci d'avance!

Share this post


Link to post
Share on other sites

En fait je crois que j'ai supprimer tout un bloc avec multiviews... Quelqu'un peut me filer les deux "bloc" ou apparraissait le multiview dans httpd.conf?

Share this post


Link to post
Share on other sites

Quelle version de apache utilises-tu ?

A tout hasard, essaye cette règle :

RewriteRule ^index\.html$  index.php [L]

ou celle-ci

RewriteRule (.*)/index\.html$ $1/index.php

Share this post


Link to post
Share on other sites

Non rien n'y change... Je rage...

J'ai apache 2

Edited by DuR0

Share this post


Link to post
Share on other sites

Depuis Apache 2, le paramétrage des sites ne s'effectue pas dans le httpd.conf, mais dans des fichiers séparés, dans le répertoire /etc/apache2/vhosts.d/. Par défaut (sans virtual host), le site par défaut est paramétré dans /etc/apache2/vhosts.d/00_default_vhost.conf . Est-ce que tu pourrais nous montrer ce fichier ? J'ai l'impression que le mod_rewrite fonctionne bien (c'est un module par défaut dans apache 2), donc il doit y avoir un problème dans la conf des vhosts. (si il y a plusieurs fichiers dans /etc/apache2/vhosts.d/, mets les tous)

Share this post


Link to post
Share on other sites

Désolé j'étais parti à Paris. Je t'envois ça par mp pour que tlm ne le vois pas.

Share this post


Link to post
Share on other sites
Voici mon .htacces

RewriteEngine on
RewriteRule ^index\.html$ /index\.php [L]

En réécrivant cela correctement cela devrait aller mieux, non ? :P

RewriteEngine on
RewriteRule index\.html$ index.php [L]

Le / devant le second argument est réservé aux règles sur les MUTUALISES OVH.

Dans tous les autres cas il est incorrect. ;)

Et le ^ du début de ligne empêchera la règle de fonctionner si tu reçois /index.html !

Share this post


Link to post
Share on other sites

J'imagine que tu bosses sur top-jeux.info ?

est-ce bien ce serveur virtuel qui répond ? (ie : tu arrive bien sur l'index de /home/bar/public_html/topjeux/public/ quand tu tappes www.top-jeux.info dans le navigateur).

Si oui, teste la config suivante:

<VirtualHost 91.121.0.13:80>
ServerName www.top-jeux.info
ServerAlias top-jeux.info *.top-jeux.info
ServerAdmin admin_AT_top-jeux.info
DocumentRoot /home/bar/public_html/topjeux/public/
RewriteEngine on
RewriteRule (.*)/index\.html$ $1/index.php
<Directory /home/bar/public_html/topjeux/public/>
AllowOverride all
Allow from all
Order allow,deny
</Directory>
</VirtualHost>

Et essaye aussi en remplaçant la règle par les autres règles données dans le topic.

Edited by dams41

Share this post


Link to post
Share on other sites

Je bosse sur loicbar.com...

mais en effet ça fonctionne sur loicbar avec :

RewriteEngine on

RewriteRule (.*)/index\.html$ $1/index.php

Edited by DuR0

Share this post


Link to post
Share on other sites

Mais mes .htacces? je peu pas l'utiliser il faut que je config tout dans mes vhost?

Share this post


Link to post
Share on other sites

Regarde comment est configurée la directive "AllowOverride"... si c'est sur "none" c'est logique.

Mets "All" et refais un essai ;)

Après on verra à sécuriser le tout :)

Share this post


Link to post
Share on other sites

Oui je l'ai fait mais rien..

Edited by DuR0

Share this post


Link to post
Share on other sites

Il faut bien évidemment redémarrer Apache ;)

Share this post


Link to post
Share on other sites

Pour mes sites, je configure tout dans les vhosts, car ils ne sont pas accessibles dans l'arborescence du site, ce qui peut être préférable ... Cependant les htaccess c'est très pratique, donc si tu ne peut vraiment pas t'en passer ...

Essaye comme ça :

<VirtualHost 91.121.0.13:80>
ServerName www.loicbar.com
ServerAlias loicbar.com *.loicbar.com
ServerAdmin admin_AT_loicbar.com
DocumentRoot /home/bar/public_html/loicbar/
AllowOverride all
<Directory "/home/bar/public_tml/loicbar">

#
# Possible values for the Options directive are "None", "All",
# or any combination of:
# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important. Please see
# http://httpd.apache.org/docs-2.0/mod/core.html#options
# for more information.
#
Options Indexes FollowSymLinks

#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
# Options FileInfo AuthConfig Limit
#
AllowOverride all

#
# Controls who can get stuff from this server.
#
Order allow,deny
Allow from all
</Directory>

</VirtualHost>

Edited by dams41

Share this post


Link to post
Share on other sites

Oui j'avais essayé... Mais alors là apache veut plus redémarer il aime pas du tout :(

Share this post


Link to post
Share on other sites

Heu, j'ai vraiment beaucoup de mal à comprendre ce qui se passe. Ce qu'on sait maintenant c'est qu'Apache ne tien pas compte de ton .htaccess.

Dans quel dossier le met tu ?

Share this post


Link to post
Share on other sites

Dans le même dossier que l'index.php... A la racine quoi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...