Jump to content

erreur mysql 1130


Mado

Recommended Posts

bonjour,

j'ai ce message d'erreur 1130 comme quoi l'hôte localhost ne peut pas se connecter a la base mysql

apres avoir cherche sur google j'ai trouve une reponse eventuelle ou je dois faire :

ouvrir "MySQL Command Line Client" taper:

mysql> GRANT ALL PRIVILEGES ON *.* TO 'root'@'serveur' IDENTIFIED BY 'mon_mot_de_passe_secret' WITH GRANT OPTION;

mais je fait comment pour taper cela puisque je n'ai pas acces de l'administration

merci

Link to post
Share on other sites

Ton hebergement et où ? que précaunise ton hebergeur, souvent en local on laisse localhost mais sur nombre d'hebergement

on doit mettre un nom de serveur à la place de localhost.

Link to post
Share on other sites
bonjour,

j'ai ce message d'erreur 1130 comme quoi l'hôte localhost ne peut pas se connecter a la base mysql

apres avoir cherche sur google j'ai trouve une reponse eventuelle ou je dois faire :

ouvrir "MySQL Command Line Client" taper:

mysql> GRANT ALL PRIVILEGES ON *.* TO 'root'@'serveur' IDENTIFIED BY 'mon_mot_de_passe_secret' WITH GRANT OPTION;

mais je fait comment pour taper cela puisque je n'ai pas acces de l'administration

merci

bonjour,

c'est bien appache qui determine l'hôte? ou c'est easy php? ou ca se passe autrement?

ca marchait avec 127.0.0.1 et la ca ne fonctionne plus ... qu'ai je pu faire comme modif qui a modifier cela?

Merci de vos lumières

Marie

merci

Link to post
Share on other sites

c'est encore moi... desolée ;)

comment et ou puis je taper ses lignes de commande :blush:

shell> mysql --user=root mysql

mysql> INSERT INTO user VALUES('localhost','monty',PASSWORD('un_mot_de_passe'),

-> 'Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y');

mysql> INSERT INTO user VALUES('%','monty',PASSWORD('un_mot_de_passe'),

-> 'Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y');

mysql> INSERT INTO user SET Host='localhost',User='admin',

-> Reload_priv='Y', Process_priv='Y';

mysql> INSERT INTO user (Host,User,Password)

-> VALUES('localhost','dummy','');

mysql> FLUSH PRIVILEGES;

merci

Link to post
Share on other sites

Si tu as laissé l'option skip-networking dans le fichier de config, il est logique que tu ne puisses pas accéder à la base au départ d'un autre host.

Il faut la commenter et redémarrer mysql :)

Dan

Link to post
Share on other sites

bonjour Dan

je la trouve ou cette ligne skip-networking stp dans le fichier my.cnf? je ne le trouve pas

commenter c'est bien mettre un # devant?

merci

Link to post
Share on other sites

Bonjour Mado,

Elle doit s'y trouver, regarde dans le répertoire /etc (si tu tournes sous Linux). Et oui, commenter c'est mettre un caractère dièse (#) en début de ligne.

Dan

Link to post
Share on other sites
  • 4 months later...
Bonjour Mado,

Elle doit s'y trouver, regarde dans le répertoire /etc (si tu tournes sous Linux). Et oui, commenter c'est mettre un caractère dièse (#) en début de ligne.

Dan

Bonjour, juste pour info, si vous utilisez une version 4 ou supérieure de mysql, en plus de /etc/my.cnf , il faut regarder aussi dans le /etc/sysconfig/mysqld

Personnellement, c'est là que se trouve mes options de démarrage de mysql notamment le skip_networking...

Pour revenir au problème d'origine, au début je n'arrivais pas à me connecter à ma base en dehors d'une connexion localhost.

J'ai retiré cette option et depuis j'ai le message d'erreur 1130...

Bref, je ne pense pas que le problème vienne de cette option dans la mesure où elle est surement déjà à OFF...

Je partiraît plutôt sur un pb de droit d'accès aux fichiers.

Maintenant dans le cas présent, sans droit d'administration, ça va être dur.

Choubak

Link to post
Share on other sites

Je vais completer ma réponse de tout à l'heure...

Etrangement, en enregistrant manuellement mon ip et tout et tout dans la base mysql avec un phpmyadmin correctement installé, je ne suis pas parvenu à résultat probant...

Par contre en ajoutant manuellement les droits, bizarrement ça marche.

Donc connexion normale, ouverture d'un shell, SU avec le mot de passe qui va bien, ouverture de la console d'administration mysql en tapant... mysql

puis par exemple

mysql> grant all prvileges on *.* to root @ monIP

(j'ai mis des espaces de chaque côtés du @ sinon cela ne s'affiche pas correctement).

J'ai aussi essayé sans saisir la partie @ monIP et étrangement, le UNKNOWN est remplacé par un % ... et là ça fonctionne sans pb... Youpi !

L'art de perdre du temps pour pas grand chose.

Ce genre de sécurité evite qu'on essaye de se connecter via un logiciel SQL comme mysqlfront ou navicat. Si cette ligne n'est pas insérée dans le fichier mysql/user il ne reste plus que les outils en ligne fourni par le gestionnaire de la base.

Choubak

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...