Jump to content
Sign in to follow this  
Dan

Version 2.2.2 d'Invision

Rate this topic

Recommended Posts

Salut,

Petite suggestion d'ergonomie : faire un hover plus évident sur les éléments de "options" sur les posts. La version actuelle peut poser des problèmes de lisibilité à pas mal de monde, je pense; un simple effet de type "inversion" des couleurs devrait assez bien marcher je pense.

Share this post


Link to post
Share on other sites

J'ai changé la couleur au survol, ainsi que passé la police en "bold".

Cela devrait aller mieux déjà, non ?

Share this post


Link to post
Share on other sites

Salut

J'ai repéré quelques problèmes dans le module de blogs.

Dans la liste des blogs, il manque deux images:

http://www.webmaster-hub.com/style_images/hub/add_fav.gif

http://www.webmaster-hub.com/style_images/hub/del_fav.gif

404 pour les deux.

Ensuite, lorsqu'on est sur un blog, le menu de navigation semble être celui d'Invision par défaut. Et non la version customisée utilisée sur les autres pages du Hub.

Enfin, et cela ne touche qu'un seul blog, celui de Régis (Blog Webmaster Toulouse), l'image d'en-tête n'apparaît pas.

Et en appelant directement l'image, on reçoit un message d'erreur.

**

Sinon, pour les détails insignifiants:

  • le titre de la pop-up "Mes amis" est en anglais
  • on a visiblement perdu le moteur de recherche "Hub", celui qui cherche à la fois dans le forum et dans les publications
  • je cherche toujours en vain le moyen d'avoir la liste des derniers sujets auxquels j'ai participé, affichée en liste de sujets (pas en messages). Comme le lien "Nouveaux messages", mais avec uniquement les topics dans lesquels on a posté. Pour l'instant, je recours encore à une bidouille via l'outil de recherche (en tapant mon pseudo dans le champ "auteur" et en laissant vide le champ des mots-clés).
    C'est extrêmement utile pour lire les réponses à une discussion à laquelle on s'intéresse.
  • Dans la fenêtre de rédaction d'un message, il y a deux listes d'emoticônes. Je ne sais pas si c'est voulu, mais c'est inutilement redondant.

** edit **

Un autre problème déjà présent dans les version antérieures.

Quand je clique sur mon pseudo ici à gauche au-dessus de l'avatar

( <-- là, un peu plus haut)

et que je veux l'ouvrir dans un autre onglet. Et bien l'autre onglet s'ouvre.. et la page courante change aussi ! Dans ce cas, aucune utilité de demander un nouvel onglet :unsure:

(edit #2) via le clic droit, aucun souci. Mais avec le raccourci clavier ou le clic molette, j'ai la page en double (navigateur: Safari, la plus récente version).

Share this post


Link to post
Share on other sites

Merci pour le "bug report" dudu !

J'ai ajouté les deux fichiers images manquant, et ai réglé le problème de l'image dynamique du titre de chaque blog.

Seul celui de Régis posait problème parce que c'était le seul a avoir été modifié depuis la mise à jour.

Mais le problème était général... il manquait une image là aussi.

Pour le menu de nav des blogs, je m'en occupe

Le moteur de recherche n'est pas "perdu"... il n'est pas encore intégré dans le template de recherche, sans plus :P

La seconde liste des emoticônes ? Tu veux dire le menu déroulant dans la barre d'outils de formatage ?

Dan

Share this post


Link to post
Share on other sites
La seconde liste des emoticônes ? Tu veux dire le menu déroulant dans la barre d'outils de formatage ?
Voilà. Il y a le panneau latéral, et le menu déroulant dans la barre d'outils de formatage. Ils sont à 2cm maxi l'un de l'autre sur mon écran donc je ne vois pas bien l'utilité.

(je rapelle que j'avais qualifié ça de "détail insignifiant" :blush: ce n'est pas très grave).

Dans le même genre, je trouve l'expression "Mon contenu" inappropriée dans les profils.. même si je n'ai aucune idée de par quoi la remplacer :whistling:

Par rien, peut-être...

Sinon, j'avais repéré un autre bug mais qui semble être réglé: le manque de synchronisation entre l'ancien champ custom "genre" et la nouvelle fonctionnalité Masculin/Féminin. Et le doublon que ça faisait.

Mais tu as visiblement déjà vu ça :thumbsup:

Pour le reste, génial. J'ai toujours une dent contre Invision à cause du surplus de JS non dégradable... mais ça concerne Invision et non le Hub.

Joli travail, merci Dan ! ;)

Share this post


Link to post
Share on other sites

Sous firefox (Ubuntu), l'icone RSS du bas bug.

Je clique, ça se déroule vers le bas (déjà c'est moyen), je scroll pour descendre, et ça me remonte...

Je dois utiliser l'ascenseur pour descendre, et parfois ça me remonte.

Un bug javascript sans doute, mais bon, c'est vraiment pas important c'est juste de la finition.

Share this post


Link to post
Share on other sites
Sous firefox (Ubuntu), l'icone RSS du bas bug.

Je clique, ça se déroule vers le bas (déjà c'est moyen), je scroll pour descendre, et ça me remonte...

Je dois utiliser l'ascenseur pour descendre, et parfois ça me remonte.

Un bug javascript sans doute, mais bon, c'est vraiment pas important c'est juste de la finition.

Cela a déjà été signalé par Zirone

Quand on clique sur le logo rss.png, la liste des flux rss s'ouvre par le bas. N'y a-t-il pas moyen qu'elle s'ouvre par le haut ? (ce n'est pas un bug, mais c'est assez dérangeant, je trouve ^^)

Je ne suis malheureusement pas suffisamment compétent en JS (ni en Ajax) pour faire dérouler ce menu vers le haut au lieu du bas...

Si quelqu'un a une idée, je suis preneur !

Dan

Share this post


Link to post
Share on other sites

Bonjour,

Certains d'entre vous l'auront peut-être déjà remarqué, nous affichons maintenant une valeur séparée pour le nombre de robots qui visitent Webmaster Hub.

Je trouvais surprenant d'avoir autant d'activité disque avec un nombre de visiteurs plutôt faible (tout est relatif), mais il était difficile de se rendre compte du nombre de moteurs présents à un instant donné.

Avec cet affichage séparé, on voit bien que Webmaster Hub a la faveur des principaux moteurs du marché. Pas étonnant alors que les sites qui traînent à se faire indexer se retrouvent rapidement dans l'index après avoir mis un lien sur le Hub. :)

Et au moins, on y voit plus clair dans les statistiques, en ne mélangeant pas les visiteurs et les moteurs :

Durant les 30 dernières minutes, nous avons eu plus de 500 bots qui ont visité le Hub. C'est beaucoup et ce n'est certainement pas notre record !

Le record établi à la date d'aujourd'hui est de près de 90 000 passages de Googlebot durant la même journée (de 0 à 24 heures)

Dan

PS: les chiffres affichés ne tiennent pas compte du passage des moteurs ou des visiteurs sur les publications, ils sont seulement pour le forum.

Share this post


Link to post
Share on other sites

Bonjour,

Justement :

515 invité(s), 53 membres 0 membre(s) anonyme(s), 525 moteurs

Comment avez-vous pour "repertorier" ces moteurs ?

Via IPs ?

Merci et bravo pour le développement.

Share this post


Link to post
Share on other sites
Comment avez-vous pour "repertorier" ces moteurs ?

Via IPs ?

En modifiant les sources, les moteurs étant nativement reconnus par Invision sur base du User Agent.

Dans la version "de base" ... Invision ne comptait un moteur qu'une seule fois. Par exemple, si on avait 100 invités et 200 instances de Googlebot, ces 200 instances n'étaient comptabilisées qu'une seule fois, et ce simple visiteur "unique" était ajouté aux invités.

Cela menait donc à un total de 101 .... "100" visiteurs + "1" Googlebot.

J'ai modifié les sources pour comptabiliser ces moteurs et en comptabiliser le nombre exact, que je n'ajoute plus aux visiteurs mais que j'affiche séparément.

C'est beaucoup plus précis ainsi, car dans l'exemple précédent, cela affiche maintenant 100 visiteurs et 200 robots, qui sont les valeurs exactes

Dan

Share this post


Link to post
Share on other sites

Cette nouvelle version d'IPB est une jolie réussite et félicitation à toi, Dan, pour cette migration plutôt réussi (une migration de ce type laissant toujours quelques petites traces au début...).

Par contre je ne trouve plus comment on peut éditer sa signature dans le profil ?

Share this post


Link to post
Share on other sites

Tu vas dans "Mes contrôles" (lien en haut de cette page) et tu choisis "Modifier ma signature" dans le menu à gauche.

C'est vrai que cela ressemble de plus en plus à un tableau de bord d'Airbus... et tu n'as pas vu le panneau d'admin :lol:

Share this post


Link to post
Share on other sites
Tu vas dans "Mes contrôles" (lien en haut de cette page) et tu choisis "Modifier ma signature" dans le menu à gauche.

Cela te permettra en effet de modifier ta signature qui est lisible dans tes réponses...

Par contre, si tu souhaites changer le lien qui se trouve dans ton profil... tu dois passer par Mes contrôles > Profil personnel > Modifier mes infos de profil

Un vrai tableau de bord d'Airbus...

Ps : Yazerty... ton avatar ne s'affiche plus.... ???????

Share this post


Link to post
Share on other sites

Ah oui en fait je cliquais sur le lien de mon pseudo (en haut à gauche). Merci Dan ;) !

Régis > Je viens de réuploader mon avatar, je ne sais pas d'où venait le problème. Mais merci de me l'avoir signalé, je pensais que c'était un bug de chez moi :).

Share this post


Link to post
Share on other sites

Bonsoir,

Je suis obligé de me reconnecter (login et pass) à chaque fois que je reviens sur site. Quelle manip dois-je faire (vidage de cache? ccokie?) afin de retrouver la connection automatique?

Share this post


Link to post
Share on other sites

Salut

slender, as-tu coché la case adéquate ? Celle qui permet de conserver tes identifiants à chaque visite sans besoin de se reconnecter à chaque fois ? Elle se trouve sur la page de connexion.

Si elle est cochée et inopérante, tente effectivement de supprimer les cookies. Pour cela, rien de plus simple:

Page d'accueil des forums > en bas à droite au-dessus de la liste des connectés, tu as un lien intitulé "Effacer tous les cookies enregistrés par ce forum"

PS linguistique: Connexion en français. Connection, c'est en anglais ;)

Share this post


Link to post
Share on other sites

Merci dudu,

Opération réussie, je 'connexe' à nouveau sans être obligé de passer par la case départ et recevoir 20000 cookies :fou:

PS linguistique: Connexion en français. Connection, c'est en anglais ;)

J'avais effectivement la vague impression de commettre un impair de français en l'écrivant.... Thanks for the lesson :clap:

Share this post


Link to post
Share on other sites

J'ai 2 petits bug sur le sous menu en haut a droite

j'ai

le lien Mes amis ne fonctionne pas chez moi

et j'ai -4 message(s) :wacko:

Share this post


Link to post
Share on other sites
J'ai 2 petits bug sur le sous menu en haut a droite

j'ai

le lien Mes amis ne fonctionne pas chez moi

et j'ai -4 message(s) :wacko:

J'ai aussi un problème d'affichage du nombre de messages: -71 messages pour moi.

Je signale le bug à Invision.

Share this post


Link to post
Share on other sites

Le bug est connu depuis les premières version beta de la 2.2.2.

J'ai lancé ceci pour mettre la base à jour en attendant:

UPDATE ibf_members SET new_msg = 0 WHERE new_msg < 0

Dan

Share this post


Link to post
Share on other sites

Après avoir fait le ménage dans ma BAL... j'ai maintenant, moi aussi, le bug des -xxx messages :unsure: alors que je ne l'avais pas.....

Cause => effet ?

[EDIT]Joie et mystère.... le temps de rédiger le post et je n'ai plus le bug ! :blush: [/EDIT]

Share this post


Link to post
Share on other sites

C'est un bug de la version 2.2.x ... qui a été identifié par Invision et sera corrigé dans la prochaine version.

J'ajoute une petite modif dans les sources... histoire d'être tranquille jusqu'à cette nouvelle version.

Dan

<edit: sources modifiées, cela ne devrait plus se produire>

Share this post


Link to post
Share on other sites

Chez moi le bug a disparu => 0 message

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Similar Content

    • By Dan
      S'il est un domaine dans lequel Invision se démarque de beaucoup d'autres forums, dont phpBB, c'est dans la capacité qu'a l'utilisateur d'archiver ses messages perso. C'est plutôt cool !

      En demandant un archivage de vos messages, il vous sera proposé de choisir entre un fichier importable dans excel (format xml) ou un fichier html.

      Ce fichier sera envoyé à l'adresse email de votre profil (vérifiez qu'elle ne comporte pas d'erreur).
      Le mieux est encore de choisir "tous les messages" et "tous les dossiers", comme cela vous n'oublierez rien.
      Faites un essai à blanc avant de demander la supression des messages après archivage.

      Dan
    • By Dan
      Bonjour à tous,

      Invision a développé un "chat" s'intégrant parfaitement à leur forum.

      L'explication et la démo se trouvent à http://www.invisionchat.com/ (en anglais - il faut s'inscrire pour utiliser la démo)

      Pensez-vous que l'inclusion d'un chat serait un plus pour le Hub ?

      Dan
    • By Dan
      Bonjour à tous,

      Le Hub met en place un système de publication pour permettre à tous ceux qui le désirent d'apporter leur contribution sous forme d'articles et brèves.

      Le système mis en opération est basé sur Spip, en attendant la sortie du CMS d'Invision qui permettra peut-être une plus grande interactivité avec le forum.

      La charte graphique actuelle est néanmoins en accord avec celle du forum.

      Chaque membre souhaitant contribuer à la vie du Hub avec des articles en rapport avec le monde de l'internet peut aisément s'enregistrer dès la page d'accueil de la partie publication.

      Cordialement,

      Dan

      Pour contribuer à la vie du Hub en proposant vos articles, rendez-vous sur cette page, une fois obtenu votre mot de passe de rédacteur
    • By Dan
      Pour lever toute équivoque, la question nous ayant déjà été posée sur le forum, les administrateurs de webmaster-hub.com tiennent à préciser le point suivant:
      Ci joint copie de l'email reçu ce jour d'Invision (au format gif pour éviter les "spam bots" sur les adresses email)

      Cordialement,

      Les administrateurs de Webmaster Hub

    • By lionel
      Je lance le débat dans cette rubrique car je voyais pas bien ou le mettre (vous pouvez le déplacer si il y a une rubriques plus pertinante)

      Aujourd'hui trois gros forums php tiennent le tête de liste: vbulletin, invision, phpbb.

      Je trouve que phpbb a pris un retard certain par rapport aux deux autres, mais on attend la prochaine version qui apparement devrai remettre le forum dans la course.

      Invision, le petit dernier prend une sacré longeur d'avance par rapport à phpbb et cela dés ses premieres versions. Aujourd'hui la strategie de invision et de le "donner" gratuitement, mais jusqu'à quand ?

      Vbulletin, c'est à mon avis le numéro un du moment, des possibilités et une communauté énormes. Les gros forums pro utilisent majoritairement vbulletin.

      Aujourd'hui je vais migrer de phpbb vers invision un de mes gros forums, j'ai choisis invision pour son côté (encore) gratuit car ce forum appartient a une association et nous n'avons pas encore beaucoup d'argent.

      Par contre je compte bien prendre une licence vbulletin pour un autre site, car vbulletin me semble beaucoup plus complet que invision.
×
×
  • Create New...