Jump to content

Problême donnée Latin 1 reconnu UTF8


blue51

Recommended Posts

Bonjour,

Au départ je possèdais une base de donnée SQL dont les données étaient encodé en Latin1 (iso 8859-1).

Suite à une mise à jour du forum les données de la base de donnée du forum ont été convertis en UTF-8.

Alors que les données propre au site ( news.. articles) étaient rester en iso8859-1

Quand on fait un dump de la base de donnée et qu'on li la base de donnée, les logiciels indiquent que la base est en UTF-8

Comment faire pour un dump des tables que l'on souhaite et que celle-ci soient encodé en iso8859-1 et pas en utf8 ? même en selectionnant les tables à dumper cela apparait toujours en utf8 ?

Comme les logiciels pensent que les tables sont en utf8 je ne peux pas les encodés en utf8.

Quand je lance mon nouveau site qui est du pure jus utf-8 et que je met cette fameuse base de donnée latin1 d'origine mais que les autres softs en disait de l'utf8, j'ai droit à des losanges noir avec un point d'intérogation sur les caractères accentué qui montre bien au final que les données propre son bien en latin1 :/

J'en perd mon latin :wacko:

Je ne peut passer par Phpmyadmin le volume de donnée faisant le Gigaoctet..

Quelqu'un à une idée sur le script miracle pour réaliser le dump sous mysql ?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...