Jump to content
Sign in to follow this  
Circobaz

Autre pb de cadre avec <a>img</a>

Recommended Posts

Bonjour,

Voici ma première entrée dans ce forum.

Je suis en train d'écrire mon premier site et j'ai un problême d'affichage :

Sur certaines pages, j'ai utilisé le code <a href="#">TEXT<span>IMAGE</span></a> pour afficher une image au moment où la souris passe sur le texte (l'affichage de l'image est bloqué au départ en utilisant #Text a span {display: none; text-decoration:none;}).

Cette technique marche bien avec IE7 et Safari, mais avec Firefox un cadre blanc entoure l'image et je ne sais pas comment le retirer.

J'ai remarqué que si je mettais un texte à la place de l'image, alors aucun cadre n'entourait mon texte dans Firefox. c'est donc bien spécifique au fait d'avoir une image.

Pour mieux illustrer, voici l'une page qui pose problême : http://www.kalessan.com/memo/Borea/Borea-Lower1.html

(passer la souris sur le descriptif des pièces et de leur surface).

Merci d'avance à ceux et celles qui prendront le temps de jeter un coup d'oeil,

Circobaz.

Share this post


Link to post
Share on other sites

Bonjour,

Ajoute un Border: 0px dans le style IMG ou du A:Hover :)

Portekoi

Share this post


Link to post
Share on other sites

reBonjour,

Merci pour ta réponse, Portekoi.

Malheureusement, ça ne marche pas. Si je rajoute un Border: 0px à #Text a:hover span, ça ne fait aucune différence.

En effet, le cadre est autour de l'image, pas autour du calque (qui a d'ailleurs une largeur plus grande, c'est donc facile de le vérifier).

D'autres suggestions?

Circobaz.

Share this post


Link to post
Share on other sites

Bonjour à nouveau,

J'ai un autre problème de cadre non désiré qui s'affiche.

Cette fois c'est lorsque j'utilise l'image comme lien : <a href="...">img</a>.

Le cadre entoure l'image et non le calque, donc ajouter un border: 0px pour le calque (ou les liens de mon calque, comme "#DIV a") de mon image ne change rien.

Le cadre n'apparait qu'avec IE. Il est bleu lorsque le lien n'a jamais été cliqué et violet une fois qu'il a déjà été visité. Comme l'affichage des liens par défaut.

J'ai pourtant précisé la couleur noire pour l'affichage des liens de ce calque.

Il s'agit de l'image de mon logo :

www.kalessan.com

Merci pour ceux et celles qui ont des suggestions à me faire,

Circobaz.

Share this post


Link to post
Share on other sites

Salut,

Nan !

Portekoi a voulu dire #Text a span img {border: 0;}

Joli pied à terre :whistling:

Edited by ghost

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...