Jump to content
Sign in to follow this  
destroyedlolo

VirtualBox : connection entre le host et le guest

Rate this topic

Recommended Posts

Salut,

j'ai installe la derniere version de VirtualBox 2.1.2 sur mon portable du taf sous XP. J'ai creer une VM Unbutu et j'en ferai peut etre une autre avec NetBSD.

Pour que ces VM soient totalement accessible depuis mes autres machines, j'utilise une "Host Interface Networking" au niveau du reseau (ca marche d'ailleurs vraiment tres bien, meme avec une configuration reseau complique comme j'ai a la machine).

Mais ma question est la suivante : vu que c'est sur un portable, il se peut que j'ai a faire des demos sans aucune connection reseau (c'est a dire que la PC n'est pas connecte a un reseau).

Comment faire alors dans ce cas pour faire discuter la VM avec le host ?

Ce que je vise, c'est d'avoir un serveur apache tournant dans la VM et que je puisse y acceder depuis XP.

Merci et A+

Lolo

Edited by destroyedlolo

Share this post


Link to post
Share on other sites

bonjour,

J'ai le même problème que toi mais je suis sous Vista.

As-tu trouvé une solution?

J'ai posté un message sur un autre forum mais ça n'a pas été concluant.

C'est vrai qu'il est dommage de pas pouvoir fonctionner un nomade!

Merci par avance

Edited by matou82

Share this post


Link to post
Share on other sites

J'ai eu la reponse sur l'excellentissime forum SunWizard

En resume, il faut creer une interface de bouclage cote winmachin (le liens vers la procedure d'installation est donner dans le post de Sunwizard) et de creer une interface reseau vers ce bouclage dans VB.

Par contre :

  • il faut utiliser des IP fixes
  • j'ai devalide l'IPv6 cote Ubuntu car le loopback semble ne gerer que l'IPv4 (mais je n'ai pas ete voir plus loin, de toute facon, l'IPv6 ne me sert a rien)
  • Il faut faire gaffe a la config reseau du navigateur : par exemple, dans mon car, il recupere le proxy automatiquement (config du taf) et evidement mon reseau prive n'est pas exclu dans ca ne marche pas. Par contre, connecte chez moi, donc sans cette config proxy, ca fonctionne tres bien. La solution est evidement de force une configuration sans proxy ou de le configurer a la main.

Pour le reste, ca fonctionne tres tres bien.

En esperant que ca t'aide ...

Bye

Lolo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...