Jump to content

Outils Google pour les webmaster, 2 erreurs (voir corp message)


 Share

Recommended Posts

Bonjour à tous,

l'outil google pour les webmaster m'indique deux erreurs sur un site que je gère:

Url non suivie(1): erreur liée à des redirections:

http://www.cb-bois-chauffage.fr/partenaire...ns-le-rhone.htm

je vous la mets pour vous permettre de voir que la redirection (redirectpermanent) que j'ai faite dans mon htaccess fonctionne bien.

URL à accès restreint par un fichier robots.txt (1):

http://www.cb-bois-chauffage.fr/visiteguid...auffage.htm,URL

celle-ci, je l'ai redirigée en permanent dans htaccess car le nom de dossier a changé.

cette redir fonctionne.

voici mon robot:

Sitemap: http://www.cb-bois-chauffage.fr/sitemap.xml

User-Agent: *

Disallow: /include/

Allow: /

celle-ci m'embête d'avantage car cette page va être totalement actualisée sous peu et je ne voudrais pas qu'elle n'existe pas pour notre vieil ami gg.

l'outil gg m'indique une mise à jour à hier soir

Enfin, j'ai changé totalement le charset de toutes les pages en utf-8, et ggbot le voit toujours en iso8859-15.

pourquoi mes modifs ne sont pas prises en compte, à votre avis?

problème de délai (9 jours depuis la détection des erreurs) ? ...

merci pour vos pistes éventuelles.

Link to comment
Share on other sites

Bonjour,

Pour le jeu de caractères, tu devrais mettre ta balise avant la balise <title> vu que celle-ci comporte des caractères accentués (par exemple Rhône)

Je ne vois pas en quoi ta seconde URL a un accès restreint par le fichier robots.txt ???

Link to comment
Share on other sites

Pour le charset, bon conseil que je vais mettre en place maintenant.

pour l'accès restreint, je ne vois pas non plus.

il y a très longtemps (plusieurs mois au moins) j'avais mis le répertoire visiteguide dans le robots.txt, mais ça fait bien longtemps que ce fichier est propre...

ai-je oublié une tépae, une sorte d'avetissement à gg que mon robots.txt a changé depuis tout ce temps?

j'ai vérifié ce fichier vu en cache par google, c'est le bon.

reste un truc, j'avais demandé à gg la suppression d'une adresse (comme par hasard celle-là, sur la visite) via l'outil webmaster:

13 août 2008 http://www.cb-bois-chauffage.fr/visite....s-chauffage.htm Suppression de page Web Annulé

je n'arrive pas à virer ce truc, et je n'arrive pas à voir le contenu des trois-points (...)

est-ce que ça peut avoir un lien, est-ce que je peux finalement demander la suppression de l'adresse en cause pour définitivement virer ce problème ?

merci!

Link to comment
Share on other sites

Bonjour,

Pour ton url à supprimer, le problème à mon avis c'est qu'elle envoie en 302 sur ta page 404,

alors qu'elle devrait directement tomber en 404.

Pour tester la redirection:

http://www.annuaire-info.com/outil-referen...st-redirection/

Lien testé : http()//www()/visite.../visite-...-chauffage(.)htm

Type de redirection : 302 Found

Redirigé vers : http()//www..../include/404(.)htm

le plus simple serait peut-être d'interdire cette url par robots.txt et de demander sa suppression, ça peut fonctionner je pense.

A+

Link to comment
Share on other sites

J'ai testé toutes mes pages redirigées et tout fonctionne bien:

Type de redirection : 301 Moved Permanently

j'ai vérifié le contenu du sitemap et robots, ok aussi.

en désespoir de cause, j'ai demandé à google la suppression des fausses url, onverra bien.

merci

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By aurelien59
      Bonjour,   Je me permet de poster ce problème sur ce forum en plus de l'avoir posté sur un autre.   Le problème survient sur un site codé en dur.   Depuis plusieurs mois après la mise en place de redirection, je rencontre un problème. La redirection a été mise en place pour rediriger simplement les pages ayant un underscore vers un tiret. Par exemple page_1.php vers page-1.php   Dans Google webmasters tools, zone "Exploration", > Erreurs d'exploration > le nombre des URL non suivies à augmenter de manière considérable sur ordinateurs et smartphone.
      Voici un exemple de page contenant l'erreur :   page-1.php/page-a.php (alors que la page correcte est page-1.php, la page page-a.php est présente sur le site en racine).   Lorsque je clic sur l'url d'erreur, dans l'onglet "Référencée sur". Les url qui apparaissent sont : http://www.monsite.fr/page-2.php/page-b.php'>>http://www.monsite.fr/page-2.php/page-b.php et http://www.monsite.fr/page-2.php/page-c.php'>>http://www.monsite.fr/page-2.php/page-c.php (non indexés sur Google).   Voici l'extrait du .htaccess ErrorDocument 404 http://www.monsite.fr/404.php RewriteEngine on RewriteCond %{HTTP_HOST} ^monsite.fr$ RewriteRule ^(.*) http://www.monsite.fr/$1 [QSA,L,R=301] RewriteRule ^([^_]*)_([^_]*)$ /$1-$2 [L,R=301] RewriteRule ^(.*)\.php/$ http://www.monsite.fr/$1.php[L,R=301] RewriteRule ^(.*)\.php/(.*)\.php$ http://www.monsite.fr/$1.php[R=301] RewriteCond %{REQUEST_FILENAME} -s [OR]RewriteCond %{REQUEST_FILENAME} -l [OR]RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^.*$ - [NC,L]RewriteRule ^.*$ /404.php [NC,L] Merci beaucoup pour votre aide.
    • By Asaiel
      Bonjour à tous,
       
      Nouveau sur ce site, je sollicite votre aide pour résoudre un problème que je rencontre actuellement sur l'utilisation de "mod_rewrite" et de ses directives.
      Je précise que je suis novice concernant cet élément.
       
      Les données:
      Les fichiers relatifs au site que je développe actuellement se trouvent dans un dossier qui n'est pas à la racine de mon serveur de test (NAS Synology).
      l'url de base est donc de la forme suivante: https://MonNas.local/private/MonSite (et non pas https://MonSite).
       
      Je dispose du .htaccess suivant à la racine du site:
      RewriteEngine On RewriteBase /private/MonSite/ RewriteRule ^([a-zA-Z0-9\-\_\/]*)$ index.php?p=$1  
       Cette directive me permet (en principe 😅) de convertir l'adresse suivante (vérifié depuis ce site)
      URL 1 (demandée): https://MonNas.local/private/MonSite/login/lostpassword En:
      URL 2 (réécrite): https://MonNas.local/private/MonSite/index.php?p=login/lostpassword  
      Dans ma page à afficher, j'ai les références suivantes dans les en-têtes:
      <head> <meta charset="utf-8"> <title>MonTitre</title> <!-- css --> <link rel="stylesheet" href="./resources/vendor/fa/css/all.min.css"><!-- css font-awesome --> <link rel="stylesheet" href="./resources/vendor/bootstrap/css/bootstrap.min.css" id="bootstrap-css"><!-- css bootstrap --> <link rel="stylesheet" href="style.css" type="text/css"><!-- css custom --> <!-- js libraries --> <script src="./resources/vendor/bootstrap/js/bootstrap.bundle.min.js"></script><!-- js bootstrap --> <script src="./resources/vendor/jquery/js/jquery-3.6.0.min.js"></script><!-- js jquery --> <meta name="viewport" content="width=device-width, initial-scale=1"> </head>  
      Le problème:
      Lorsque j'accède à l'URL 1, aucune de mes références CSS, JS et img ne fonctionne.
      Lorsque je tape directement l'URL 2 dans la barre d'adresse, tout fonctionne bien.
       
      Pouvez-vous svp m'aider à trouver où se trouve mon erreur?
       
      Merci d'avance 🙂
    • By cyberdede
      Bonjour à tous

      je voudrais quand je tape https;//monsite/dossier accéder à https;//monsite/dossier/index.php
      or j'accède à https;//monsite/dossier/ avec un 404

      en localhost ca fonctionne

      pour la racine https;//monsite c'est ok

      mon htaccess
       
      RewriteEngine On Options -Indexes RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^([^\.]+)$ $1.php [NC,L] RewriteCond %{HTTPS} ^off$ [NC] RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L] AddDefaultCharset UTF-8 ErrorDocument 404 /404.php  
    • By kevinjoseph
      Bonjour, j’ai un gros problème sur mon site Wordpress . Du jour au lendemain, mon site wordpress fais une redirection vers un autre site wordpress que j’ai crée ,sans que je touche à quoi que ce soit. Quand j’essai d’aller sur l’admin pour désactiver les plugins et voir d’où peut venir le problème. Impossible d’accéder, sa me redirige vers l’admin de l’autre site. Au final il est impossible que j’accède au site via (google, la bare de recherche, les favoris, l’admin…) pour voir ce qu’il fonction pas, j’ai juste accès au FTP. J'ai essayé de voir d'où pouvez venir ce bug en supprimant les plugins, le théme, mes derniers modifications, regarder sur le .htaccess si il y avais quelque par le nom de domaine de l'autre site écrit. Ca n'a rien changer, le site continue de ce rediriger automatiquement vers l'autre site. Si vous avez une idée d’où sa peut venir ou comment faire pour arranger ça et surtout comment éviter que sa ce reproduise. Sa m’aiderai beaucoup, merci d’avance.
      voici le code du .htaccess:
       
      # BEGIN WordPress
      <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteBase /
      RewriteRule ^index\.php$ - [L]
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule . /index.php [L]
      </IfModule>

      # END WordPress
      ~   Ludovic • 16:28    
×
×
  • Create New...