Jump to content

Spip : Lenteur de source inconnue


Recommended Posts

Bonjour à tous.

Je suis admin d'un serveur (sur un intranet), qui héberge plusieurs sites dont un CMS SPIP 1.9.2, avec le plugin sarkaspip pour le template.

Alors depuis plusieurs mois, ce site est lent... très lent. Il nous fait parfois des erreur d'excecution time (dépasse les 30 sec de chargement) et en moyenne il faut 10 sec pour charger une page.

Mais d'un autre côté, nos autres sites sont tout à fait réactifs.

Ca devient inutilisable, les utilisateurs perdent beaucoup trop de temps dessus, mais n'ont pas le choix...

J'ai tenté diverses solutions suite à mes recherches, mais aucune ne fonctionne.

J'ai modifié le fichier de conf (./ecrire/inc_version.php) pour notament désactiver la compression automatique des pages à la volée.

J'ai donné plus de mémoire à PHP (car il nous sort parfois des erreurs d'allocation mémoire).

J'ai reconstruit la base de données.

J'ai réinstallé SPIP et fait un dump de la base.

J'ai essayé de migrer vers la version 2.0, mais j'ai des gros soucis, il faut que je cherche encore à ce sujet.

... et j'en oublie peut-être d'autres.

Mais pas d'améliorations sensible.

Si jamais vous aviez une solution à proposer j'en serai ravi =D

Edited by rimiks
Link to post
Share on other sites

Les pages sont-elles mises en cache ?

Si mon souvenir est bon, dans ta version de SPIP il faut définir #CACHE{duree_en_secondes} en première ligne des fichiers de squelette.

Link to post
Share on other sites

Il est possible que ta base de données ait quelques soucis.

Tu peux lancer en ligne un "mysqlcheck -r -uroot -pmot_de_passe" ou un "myisamchk"

Le premier demande un mysql qui tourne, alors que le second nécessite que mysql soit arrêté.

Dan

Link to post
Share on other sites

Merci pour vos réponses rapides =P

Oui le cache est activé (2h)

Sinon, au risque de passer pour un manchot d'admin serveur (je suis pas vraiment qualifié pour ça)... les deux lignes que tu m'as demandé Dan, c'est à entrer en commande DOS ? Si oui, elles ne fonctionnent pas sur mon local, et je preferai que tout fonctionne bien dessus avant.

(ah oui, j'ai oublié de préciser que sur mon local c'est tout aussi lent, voir plus)

Link to post
Share on other sites

Disons que ce sont deux lignes à entrer en console shell (sous Linux).

Je ne sais pas si les équivalents existent sous installation Apache/Mysql/Php windows :(

Tu peux faire un export de ta base spip, l'effacer, puis faire un import.

Assure-toi d'avoir tous tes index opérationnels.

Link to post
Share on other sites

Me revoilà,

Manip déjà faite par le passé, et réhitérée mais sans mieux.

Sinon à propos d'index, les tables spip_index et spip_index dico rescensent quoi ? Les requetes du moteur de recherches non ?

Ces tables pesaient 3Mo, je les ai vidées à l'instant. J'ai cru sentir un bon mieux sur les pages que je venais de visiter, mais c'était soit dans ma tête soit temporaire...

Quand tu parles d'index, j'imagine que se sont ceux des tables. Comment savoir si ils sont bons ? Cela dit, je n'y ai jamais touché.

Link to post
Share on other sites

> spip_index et spip_index dico

Je crois qu'elle n'existe plus sur la 2.0. Ce n'est pas les indexations du moteur de recherche et de l'ancien correcteur orthographique ?

Les stats et les referrers sont aussi des gros consommateurs de ressources et il ne faut pas à hésiter à vider la table.

De plus par expérience SPIP n'arrivent pas à différencier les attaques des visiteurs comme le fait Google Analytics par exemple donc des stats qui ne servent quasiment à rien.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...