Aller au contenu
blig

Sessions php et IE 6

Noter ce sujet :

Recommended Posts

Salut à tous les hubmasters!

Alors voilà mon probleme, j'ai une page sur mon site qui mène à un formulaire php pour envoyer un mail

Ca commence par l'ouverture d'une session parce que je veux controler si il a bien rempli les champs... et sinon afficher ce qui manque etc...

Bref rien de nouveau sous le soleil!

Ca marche avec tout les navigateur sauf un.... IE 6!

Enfin la page ne s'affiche pas du premier coup, c'est tout blanc, et il faut actualiser la page pour qu'elle s'affiche.

Rrrrrrrrrrrrrrrrrrrrr...

Ca m'emebete parce que IE 6 c'est quand même utiliser par pas mal de monde encore il me semble

Voilà alors est-ce que quelqu'un saurait d'où ca peut venir ?

Je précise que lorsque je retire l'ouverture de session la page s'affiche mais évidemment plus rien ne fonctionne.

je vous met le code de la page du formulaire:

<?php session_start(); ?>
<?php include('./includes/head.php'); ?>
<?php include('./includes/head_photo.php'); ?>
<?php include('./includes/debut_body.php'); ?>
<?php include('./includes/onglet_contact.php'); ?>
<?php include('./includes/message_contact.php'); ?>
<?php include('./includes/photo_haut.php'); ?>


<div class="contenu">
<br/>
<center>
<div>
<form method=POST action=formmail.php >

<div style="font-size : 16px;font-family: Arial, Verdana, Times New Roman;font-weight: bold;font-style: italic;">
Ton contact mail:
<br/> <input align="left" type=text name=email size=66 /></div>

<div style="font-size : 16px;font-family: Arial, Verdana, Times New Roman;font-weight: bold;font-style: italic;">
(et/ou) Ton téléphone:
<br/> <input align="left" type=text name=tel size=66 /></div>

<?php if( isset($_SESSION['erreur1']) ){
if($_SESSION['erreur1']) echo('<font color="#fd0000">Tu ne nous as laissé ni ton mail, ni ton téléphone, nous ne pourrons pas te répondre!</font><br/>');
}
?>

<br/><div style="font-size : 16px;font-family: Arial, Verdana, Times New Roman;font-weight: bold;font-style: italic;">
Ton message:

<br/> <textarea COLS=50 ROWS=15 name=message ></textarea>
</div>
<?php
if( isset($_SESSION['erreur2']) ){
if($_SESSION['erreur2']) echo('<font color="#fd0000">Ton message est vide!</font>');
}
?>
<br/>
<?php
$nb_image=5;
srand();
$n_image=rand(1,$nb_image);
$_SESSION['n_image']= $n_image;
echo "<img src=\"/spam/".$n_image.".jpg\" />";
?>
<br/><div style="font-size : 16px;font-family: Arial, Verdana, Times New Roman;font-weight: bold;font-style: italic;">
Entre ici le nom de l'objet que tu vois:
<br/>(un seul nom commun simple)
<br/><input type=text name=verif_image size=66 >
</div>
<?php
if( isset($_SESSION['erreur1']) ){
if($_SESSION['erreur3']) echo('<font color="#fd0000">Le mot ne correspond pas à l\'image.</font>');
}
?>
<br/><br/><center><input type=submit value=Envoyer>
<input type=reset value=Annuler ><center>


</form>
</div>
</center>

<?php include('./includes/fin_html.php'); ?>

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Blig,

Ne serait-ce pas un simple problème de cookies ? As-tu le souci sur n'importe quel PC sous IE6 ?

Mona.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut merci de ton attention mona,

Bas peut etre c'est vrai que chez moi j'ai un simulateur de IE 6 , Ietester et ca le fait pas

mais je m'y fi pas trop pace que je sais qu'il est pas très fidèle à la vrai version.

Mais le problème c'est que quand je fais un nettoyage avec Ccleaner avec les cookies ca marche pas non pluis.

Et comment s'assurer que ca le fera pas ailleurs?

Partager ce message


Lien à poster
Partager sur d’autres sites

Blig,

Il ne faut pas tester avec ce genre de soft. Si tu veux savoir si ton site tourne sur IE6, le seul moyen de t'en assurer est de le tester avec IE6. Mais attention, le langage Web est en constante évolution. IE6 peut ne pas supporter certains éléments de langages récents. Dans tous les cas, ce n'est pas un souci PHP. PHP est un langage serveur, il ne s'exécute pas sur le navigateur mais sur le serveur Web. Enfin, comment s'assurer que cela fonctionne partout... ? tu ne pourras jamais en être sûr à 100% à moins de n'utiliser que du HTML pur, et encore ! Par exemple, si tu as du javascript, certaines choses ne fonctionneront pas sur les navigateurs où il est désactivé, idem sur tu utilises du flash, java etc... Et même en HTML pur, il est possible de configurer un navigateur pour qu'il n'affiche pas les images, qu'il utilise des polices particulières, le "contraste élevé" (plus de couleurs), etc.

Ce que je peux te dire, c'est qu'à ce jour, 60% environ des internautes qui visitent mes sites utilisent IE, et parmi ces internautes utilisant IE, 20% environ utilisent la version 6... soit 12% au total. Restent 30% pour Firefox, vient ensuite Chrome (3%), puis le reste (ps2, téléphones, IE5,... etc.).

Mona.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok, je suis d'accord avec toi je sais bien que php c'est côté serveur mais ce qui est bizarre c'est qu'il suffit que j'enlève

<?php session_start(); ?>

pour que la page s'affiche.

Enfin, j'ai bien l'impression que je vais laisé cette affaire et les malheureux qui utilise ie6

parce que je vois vraiment pas d'où ca vient

Merci à toi

Partager ce message


Lien à poster
Partager sur d’autres sites

Je ne suis pas un pro de php, mais ce code correspond bel et bien à la création de session, donc d'un cookie ou d'un identifiant passé au niveau de l'URL si les cookies sont refusés. Cela semble poser un souci à ton navigateur qui n'en est pas vraiment un :hypocrite: .

Partager ce message


Lien à poster
Partager sur d’autres sites

"Ca m'emebete parce que IE 6 c'est quand même utiliser par pas mal de monde encore il me semble"

Nom, :

1- Mozilla Firefox

2- Opera

3- Google Chrome

4- Netscape

5- IE (0.2%)

Plus aucun site web ne prend maintenant en considération IE, du mois, sur chaque site en code source tu trouve :

If Browser=not IE then style.css else ie.css (en algorithmique)

Partager ce message


Lien à poster
Partager sur d’autres sites

Non tout dépend du public du site.

Au moins 60% d'IE sur les sites grands publics.

Sur les sites à destination d'informaticiens, plus de Mozilla et autres navigateurs Linux. Je te parle pas sur MacBidouille par exemple :-p

Quelques stats : http://www.w3schools.com/browsers/browsers_stats.asp

Tu veux pas donner l'adresse ? plutôt que de dire qu'on va ignorer IE, on peut aussi essayer de trouver le pb ?

J'utilise des sessions presque partout et aucun IE n'a de problème...

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×
×
  • Créer...