Aller au contenu
destroyedlolo

Question DNS

Noter ce sujet :

Recommended Posts

Bonjour,

J'ai a la maison un reseau servit par mon propre DNS et dont le nom de domaine est "chez.moi".

En parallèle, j'ai mon site web dont l'adresse publique est "destroyedlolo.homeunix.org" et qui est physiquement heberge sur une de mes machines nomee "actif.chez.moi" qui a l'adresse 192.168.0.3, le tout derriere ma freebox en mode routeur.

Le probleme est que je peux utiliser http://destroyedlolo.homeunix.org depuis une de mes machines internes pour la simple et bonne raison, que le DNS me retourne mon adresse publique qui evidement n'est pas routable chez moi.

Comment puis-je faire pour que mon DNS me renvoie l'adresse IP d'actif et non l'IP publique ?

J'ai essaie de creer une zone DNS "homeunix.org" sur mon propre DNS mais, ca n'aide pas vu que ca m'interdit tout autres machines de ce domaine :wacko:

Bye

Laurent

Partager ce message


Lien à poster
Partager sur d’autres sites
jcaron    11

Tu dois pouvoir créer une zone "destroyedlolo.homeunix.org"...

Jacques.

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu dois pouvoir créer une zone "destroyedlolo.homeunix.org"...

Oui mais dans ce cas la comment lui associer une IP :?:

Je veux dire, si j'y met une machine nomee truc, truc.destroyedlolo.homeunix.org fonctionne ... mais je ne sais pas comment associer une adresse uniquement a destroyedlolo.homeunix.org.

Partager ce message


Lien à poster
Partager sur d’autres sites
jcaron    11

De la même façon que tu associes un SOA, un MX, des NS... Pareil que tu ferais si tu voulais que ton site soit accessible par "toto.com" et pas seulement "www.toto.com".

Le "nom" doit être "@", ou vide si la ligne précédente avait déjà @ ou rien.


@ IN SOA ...
IN NS ...
IN NS ...
IN MX ...
IN A ...

Jacques.

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci Jacques pour les infos (j'ai ete long a repondre car pris par plein d'autres trucs).

Ca fonctionne.

Pour ceux qui aurait le meme genre de question, mon fichier de configuration donne

$TTL 3D
@ IN SOA actif.chez.moi. l_faillie.yahoo.com (
2010040300 ; serial (aaaammddrr)
8H ; refresh
2H ; retry
4W ; expire
1D ; minimum negative cache TTL
)

; name server
IN NS actif.chez.moi.

; Canonical names

@ IN A 192.168.0.3

Partager ce message


Lien à poster
Partager sur d’autres sites

Arg, y'a un autre truc qui merdoit :unsure:

J'utilise la meme definition que ci dessus pour un second nom de domaine que je gere, mais qui contient des sites : clubphotos.fr

Si je fait

root_AT_bidule:/var/cache/bind# nslookup clubphotos.fr
Server: 192.168.0.3
Address: 192.168.0.3#53

Name: clubphotos.fr
Address: 192.168.0.3

Ca fonctionne, mais pas si j'essaie d'acceder a un des sites.

root_AT_bidule:/var/cache/bind# nslookup clubphotos.fr
Server: 192.168.0.3
Address: 192.168.0.3#53

Name: clubphotos.fr
Address: 192.168.0.3

Pourquoi ? Normalement avec la ligne '@', ca devrait marcher avec n'importe quels sites non ?

Bye

Laurent

Partager ce message


Lien à poster
Partager sur d’autres sites
jcaron    11

Tu as remis deux fois le même nslookup, mais je suppose que dans le deuxième cas tu veux dire nimportequoi.clubphotos.fr?

Dans ce cas il faut soit utiliser une ligne pour chaque site, soit utiliser un wildcard, donc * IN A addresse.ip.du.serveur

@ c'est juste le domaine lui-même sans rien devant.

Jacques.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×