Aller au contenu
balooo

Serveur kimsufi tout neuf - Bind refuse de démarrer

Noter ce sujet :

Recommended Posts

balooo    0

Bonjour,

Je viens d'acquérir un serveur Kimsufi tout neuf (redhat release 1) et Bind refuse de démarrer. pas de message d'erreur j'ai juste ça dans webmin

Stopping named: [FAILED] Starting named: [FAILED]

via Putty pareil.

Est-ce qu'il y a de slogs sur Bind ça pourrait peut-être m'aider ?

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites
balooo    0

Dans /var/log/messages peut-être?

Jacques.

effectivement je cherchais un named.log sans succès par contre tu as raison il y a ces infos dans /var/log/messages*


Apr 11 09:53:23 XXXXXX sshd[3202]: Did not receive identification string from 195.69.148.133
Apr 11 11:14:42 XXXXXX sshd[6350]: Did not receive identification string from 116.255.152.34
Apr 11 12:53:42 XXXXXX sshd[10051]: Did not receive identification string from 92.87.160.227
Apr 11 16:44:40 XXXXXX sshd[18868]: Did not receive identification string from 64.120.251.131
Apr 11 20:48:46 XXXXXX sshd[28180]: Did not receive identification string from 217.219.2.162
Apr 11 21:56:29 XXXXXX sshd[30760]: Did not receive identification string from 84.58.245.113
Apr 12 01:02:11 XXXXXX sshd[5620]: Did not receive identification string from 201.47.175.183
Apr 12 04:02:00 XXXXXX syslogd 1.4.1: restart.
Apr 12 04:02:01 XXXXXX syslogd 1.4.1: restart.
Apr 12 08:33:47 XXXXXX sshd[23562]: Did not receive identification string from 212.60.242.210
avr 12 09:26:46 XXXXXX named: failed
Apr 12 09:26:48 XXXXXX named[25686]: starting BIND 9.4.3-P3 -u named -t /var/named/chroot
Apr 12 09:26:48 XXXXXX named[25686]: adjusted limit on open files from 1024 to 1048576
Apr 12 09:26:48 XXXXXX named[25686]: found 1 CPU, using 1 worker thread
Apr 12 09:26:48 XXXXXX named[25686]: using up to 1024 sockets
Apr 12 09:26:48 XXXXXX named[25688]: loading configuration from '/etc/named.conf'
Apr 12 09:26:48 XXXXXX named[25688]: using default UDP/IPv4 port range: [1024, 65535]
Apr 12 09:26:48 XXXXXX named[25688]: using default UDP/IPv6 port range: [1024, 65535]
Apr 12 09:26:48 XXXXXX named[25688]: no IPv6 interfaces found
Apr 12 09:26:48 XXXXXX named[25688]: listening on IPv4 interface lo, 127.0.0.1#53
Apr 12 09:26:48 XXXXXX named[25688]: listening on IPv4 interface eth0, 91.121.172.82#53
Apr 12 09:26:48 XXXXXX named[25688]: /etc/named.conf:13: using specific query-source port suppresses port randomization and can be insecure.
Apr 12 09:26:48 XXXXXX named[25688]: could not get query source dispatcher (0.0.0.0#53)
Apr 12 09:26:48 XXXXXX named[25688]: loading configuration: address in use
Apr 12 09:26:48 XXXXXX named[25688]: exiting (due to fatal error)
avr 12 09:26:48 XXXXXX named: named startup failed
avr 12 09:40:49 XXXXXX named: failed
Apr 12 09:40:51 XXXXXX named[26306]: starting BIND 9.4.3-P3 -u named
Apr 12 09:40:51 XXXXXX named[26306]: adjusted limit on open files from 1024 to 1048576
Apr 12 09:40:51 XXXXXX named[26306]: found 1 CPU, using 1 worker thread
Apr 12 09:40:51 XXXXXX named[26306]: using up to 1024 sockets
Apr 12 09:40:51 XXXXXX named[26308]: loading configuration from '/etc/named.conf'
Apr 12 09:40:51 XXXXXX named[26308]: using default UDP/IPv4 port range: [1024, 65535]
Apr 12 09:40:51 XXXXXX named[26308]: using default UDP/IPv6 port range: [1024, 65535]
Apr 12 09:40:51 XXXXXX named[26308]: no IPv6 interfaces found
Apr 12 09:40:51 XXXXXX named[26308]: listening on IPv4 interface lo, 127.0.0.1#53
Apr 12 09:40:51 XXXXXX named[26308]: listening on IPv4 interface eth0, 91.121.172.82#53
Apr 12 09:40:51 XXXXXX named[26308]: /etc/named.conf:13: using specific query-source port suppresses port randomization and can be insecure.
Apr 12 09:40:51 XXXXXX named[26308]: could not get query source dispatcher (0.0.0.0#53)
Apr 12 09:40:51 XXXXXX named[26308]: loading configuration: address in use
Apr 12 09:40:51 XXXXXX named[26308]: exiting (due to fatal error)
avr 12 09:40:51 XXXXXX named: named startup failed

Partager ce message


Lien à poster
Partager sur d’autres sites
jcaron    11

"address in use" ça veut dire qu'il y en a déjà un qui tourne, normalement (même si le message me paraît un peu bizarre). Que dit "ps axl | grep named"?

Jacques.

Partager ce message


Lien à poster
Partager sur d’autres sites
balooo    0

0     0  5074  5031  40   0  1852  692 pipe_w S+   ttyp0      0:00 grep named

A priori malgré mes maigres connaissances ça veut dire qu'il y a un processus named qui tourne...

Partager ce message


Lien à poster
Partager sur d’autres sites
jcaron    11

Non, ça veut dire qu'il n'y en a pas (tu as juste le "grep" que tu viens de taper...).

Un petit "netstat -an | grep 53"?

Le contenu de ton named.conf pourrait être utile aussi, il y a peut-être quelque chose de bizarre dedans (c'est en tous cas ce que suggèrent les logs).

Jacques.

Partager ce message


Lien à poster
Partager sur d’autres sites
balooo    0

Non, ça veut dire qu'il n'y en a pas (tu as juste le "grep" que tu viens de taper...).

Un petit "netstat -an | grep 53"?

Le contenu de ton named.conf pourrait être utile aussi, il y a peut-être quelque chose de bizarre dedans (c'est en tous cas ce que suggèrent les logs).

Jacques.

netstat ne retourne rien du tout

Je te mets mon .conf. Merci de ton aide


// generated by named-bootconf.pl

options {
pid-file "/var/run/named/named.pid";
directory "/var/named";
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
query-source address * port 53;
};

//
// a caching only nameserver config
//
controls {
inet 127.0.0.1 allow { localhost; } keys { rndckey; rndc-key; };
};
zone "." IN {
type hint;
file "named.ca";
};

zone "localhost" IN {
type master;
file "localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
type master;
file "named.local";
allow-update { none; };
};

include "/etc/rndc.key";


key rndc-key {
algorithm hmac-md5;
secret "W1/gH74GHHPO6Q4oXXXXXXXXXXXXXX==";
};

pour l'instant forcément pas de domaine puisqu'il ne redémarre même pas ;)

Modifié par balooo

Partager ce message


Lien à poster
Partager sur d’autres sites
jcaron    11

Une petite recherche montre qu'il y aurait un bug avec la directive "query-source". Commente-la, et vois si ça marche comme ça.

Jacques.

Partager ce message


Lien à poster
Partager sur d’autres sites
Dan    133

Je pense que c'est un problème connu lors de l'installation de bind sur les release 1.

Tu peux faire ceci, qui devrait résoudre ton problème, pour autant que tu sois bien en release 1.83 (regarde le fichier /etc/ovhrelease):

echo 1.82 > /etc/ovhrelease
cd /root
sh patch-all.sh

Cela réinstallera la release 1.83 et réinstallera bind.

Partager ce message


Lien à poster
Partager sur d’autres sites
balooo    0

Je pense que c'est un problème connu lors de l'installation de bind sur les release 1.

Tu peux faire ceci, qui devrait résoudre ton problème, pour autant que tu sois bien en release 1.83 (regarde le fichier /etc/ovhrelease):

echo 1.82 > /etc/ovhrelease
cd /root
sh patch-all.sh

Cela réinstallera la release 1.83 et réinstallera bind.

Non dans /etc/release j'ai 1.82. Le patch all ne marchera pas donc ?

Bonjour

Effectivement avec le query source commenté il a redémarré.

Bon maintenant il faut que je paramètre ce fichu reverse DNS... Je l'ai fait une fois sur la même release mais je ne me souviens plus du tout. Merci pour votre aide en tout cas.

Partager ce message


Lien à poster
Partager sur d’autres sites
Dan    133

Si, alors lance cela directement, sans la ligne "echo...."

La 1.83 met bind à jour !

cd /root
sh patch-all.sh

Si cela ne fonctionne pas après passage à la 1.83, tu referas une seconde fois la commande, avec le echo cette fois !

Il ne fallait pas que ton serveur soit dans une release plus ancienne, par exemple 1.80 ou 1.81 .... mais 1.82 c'est OK.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×