Jump to content
Sign in to follow this  
ivoyages

Bug d'affichage sous ie7

Recommended Posts

Bonjour,

Je suis entrain de refaire la maquette de mon site. Et je coince sur un point.

Je suis dans la phase d'essai et je constate un bug dans mon header sous ie 7 (ie 6 non testé ? Pas de bug constaté sous les autres navigateurs) entre mon logo et mon bandeau pub. Le bandeau vient se placer sous le logo au lieu d'être à sa droite.

Voici mes bouts de code

Template :


<!-- header -->
<div id="header" align="left">
<div id="header_col1">
<a href="http://www.i-trekkings.net" target="_blank"><img src="http://www.i-trekkings.net/templates/temp/img/logo.gif" border="0" /></a>
</div>
<div id="header_col2">
<!--/* OpenX Tag Javascript v2.6.5 */-->
<script type='text/javascript'><!--//<![CDATA[
var m3_u = (location.protocol=='https:'?'https://www.i-trekkings.net/Bando/www/delivery/ajs.php':'http://www.i-trekkings.net/Bando/www/delivery/ajs.php');
var m3_r = Math.floor(Math.random()*99999999999);
if (!document.MAX_used) document.MAX_used = ',';
document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
document.write ("?zoneid=1&target=_blank&blockcampaign=1");
document.write ('&cb=' + m3_r);
if (document.MAX_used != ',') document.write ("&exclude=" + document.MAX_used);
document.write (document.charset ? '&charset='+document.charset : (document.characterSet ? '&charset='+document.characterSet : ''));
document.write ("&loc=" + escape(window.location));
if (document.referrer) document.write ("&referer=" + escape(document.referrer));
if (document.context) document.write ("&context=" + escape(document.context));
if (document.mmm_fo) document.write ("&mmm_fo=1");
document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://www.i-trekkings.net/Bando/www/delivery/ck.php?n=ad81383f&cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://www.i-trekkings.net/Bando/www/delivery/avw.php?zoneid=1&n=ad81383f' border='0'/></a></noscript>
</div>
</div>

Css :


#header div {
width:995px;
background-color:#fff;
color:#ff9933;
display: table-cell;
vertical-align:middle;
text-align:center;
}

#header_col1 {
}

#header_col2 {
padding:0px 4px 0px 0px;
}

Si vous avez des idées pour corriger ce problème d'affichage, je suis preneur ;)

A voir ici *http://www.i-trekkings.net/index_new.php

Greg

Edited by Ernestine
Merci d'utiliser les balises [code] et [/code] pour écrire du code

Share this post


Link to post
Share on other sites

Bonjour,

A priori IE7 ne supporte pas display: table-cell;, il te reste éventuellement la possibilité d'utiliser un commentaire conditionnel pour s'occuper de son cas en plaçant tes blocs en float?

Edited by Ernestine
Inutile de recopier le précédent message dans son intégralité !

Share this post


Link to post
Share on other sites

Bonjour,

A priori IE7 ne supporte pas display: table-cell;, il te reste éventuellement la possibilité d'utiliser un commentaire conditionnel pour s'occuper de son cas en plaçant tes blocs en float?

Ah merde !

C'est quoi un commentaire conditionnel pour faire des blocs en nfloat ?

Share this post


Link to post
Share on other sites

j'ai encore 2 bugs sous ie7 sur la page d'accueil :

Image tronquée

Dans le bandeau translucide qui chevauche l'image d'accueil, il y a une flèche devant Devenez I-Trekkeur. Elle est tronquée.

Menu déroulant

Le 2e niveau déconne totalement. Il se décale sous la liste déroulante d'à côté (à droite) et ne se referme pas forcément si on survole d'autres liens du menu.

Page interne *http://www.i-trekkings.net/dossiers/index_new.php

Colonnes

J'ai commencé à travailler sur les pages internes. J'ai souhaité créer trois colonnes.

Gauche

Milieu

Droite

qui font partie d'un block central (Centre).

Mais, j'ai un souci avec le footer qui vient chevaucher les blocks. Je pense que c'est une erreur de div (un en trop ou en moins ou mal placé) mais je n'arrive pas à trouver laquelle

Si un webmasterhubien avait une idée sur l'un ou l'autre des points...

Greg

Share this post


Link to post
Share on other sites

Bonjour,

Pour le footer, un clear: both; devrait régler la chose, pourquoi? http://www.alsacreations.com/astuce/lire/7-depassement-flottants-css.html

En fait, j'avais déjà essayé le clear:both mais ça n'avait pas fonctionné car j'avais un problème de div en plus. En tenant compte des deux, ça roule :)

Merci pour ton retour.

Je connais Alsacecreations mais parfois, on est dans le code (le css) et on ne voit pas l'erreur qui saute aux yeux :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...