Jump to content

Problème importation table


ladinho58

Recommended Posts

Bonjour,

avant toute chose, je tiens à préciser que je travaille sur Seven.

j'ai récemment installé WAMP et je voulais importer un fichier sql (23Mo) dans ma base de données. Mais je rencontre de nombreux problèmes pour importer ma base.

* j'ai tenté d'importer mon fichier via l'onglet "importer" de phpmyadmin. Mais après 300 secondes, je reçois un message d'erreur : Fatal error : Maximum execution time of 300 seconds exceeded in C:\wamp\apps\blablabla..\mysqli.dbi.lib.php on line 199

Et sous le nom de cette erreur, je peux voir un petit tableau a 4 lignes et 4 colonnes (Time, Memory, Function, Location)

* j'ai alors décidé de modifier certains parametres dans le fichier php.ini

j'y ai modifié : post_max_size, upload_max_filesize, register_globals (ces 3modifications m'ont été dictées par mon prédécesseur stagiaire), max_execution_time et user_ini.cache_ttl.

malgré ces modifications, j'ai toujours obtenu le meme message d'erreur.

* Alors j'ai ensuite essayé de zipper le fichier sql pour qu'il prenne moins de place, mais toujours le même résultat.

Ensuite, j'ai essayé de scinder mon fichier sql en 2 parties moins lourdes, toujours pas concluant.

* Ensuite, des messages sur des forums m'ont fait pensé qu'il fallait que je fasse importer mon fichier directement par ligne de commande. J'ai donc tapé dans la "fenetre de requete" de phpMyAdmin la commande : "mysql -h localhost -uroot -p lenomdemabase < monfichier.sql"

Mais en tapant ca j'obtiens le résultat suivant : #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'mysql -h localhost -uroot -p nomdemabase < monfichier.sql' at line 1

"

Pour essayer, j'ai également tapé ca dans la console windows mais alors la ca me met que "mysql" n'est pas reconnu en tant que commande interne ou externe, un programme exécutable ou un fichier de commande.

Je ne sais plus du tout quoi faire.

J'ai essayé également en plaçant mon fichier sql dans le répertoire bin de mysql comme ca avait été dit dans un forum.

Quelqu'un peut-il m'aider a résoudre ce problème ?

Link to post
Share on other sites

Salut,

Tout d'abord, as-tu bien pensé à redémarrer Apache après avoir fait les changements dans php.ini ? en effet, il faut redémarrer pour que les changements soient pris en compte.

Pour faire l'import en ligne de commande, il faut le faire dans la console Windows (et évidemment pas dans la fenêtre de requêtes de phpmyadmin qui n'a aucun rapport). Une fois la console ouverte, tu navigues dans les dossiers avec la commande "cd" (voir cette doc pour XP mais c'est pareil pour Seven) jusqu'à ce que tu sois dans le dossier où se trouve l'exécutable mysql, et là tu peux l'utiliser. Ou mieux : tu ajoutes le dossier de l'exécutable dans la variable d'environnement PATH, ainsi elle sera disponible partout. (mais commence déjà par la première méthode, qui est plus simple, et te permettra déjà de réaliser ton import).

Link to post
Share on other sites

J'ai bien redémarré Apache, mais je garde toujours les mêmes problèmes...

Concernant ton autre méthode, c'est ce que quelqu'un d'un autre forum me disait de faire. Mais alors quand je vais dans la console Windows et que j'essaye de venir dans le dossier contenant mysql.exe, ca ne fonctionne pas.

En entrant dans la console, je suis déjà dans le chemin C:\Users\C71372

Mon objectif est d'aller dans C:\wamp\bin\mysql\mysql5.5.16\bin

Mais alors directement quand je tente de faire cd, la console me répond mon propre chemin. Je ne peux ni avancer, ni reculer avec cd. C'est ca que je ne comprend pas... (mon chemin C71372 est protégé par un cadenas, pour qu'il ne soit pas disponible des autres employés, serait-ce ca ?)

Sinon, peux-tu m'expliquer plus en détail la 2nde solution ? je ne comprend pas trop ce que tu veux dire par "variable d'environnement path" .. :S

Link to post
Share on other sites

Si tu es dans

C:\Users\C71372

et que tu veux aller dans

C:\wamp\bin\mysql\mysql5.5.16\bin

Tu commences par taper :

cd ..

Ce qui te fait remonter d'un cran, donc tu te retrouves dans

C:\Users\

Tu refais

cd ..

Et là tu te retrouves à la racine :

C:

Là, tu fais :

cd wamp

Et tu te retrouves dans

C:\wamp

Tu fais alors cd bin

Tu es dans

C:\wamp\bin

Et ainsi de suite jusqu'à

C:\wamp\bin\mysql\mysql5.5.16\bin

Sinon, peux-tu m'expliquer plus en détail la 2nde solution ? je ne comprend pas trop ce que tu veux dire par "variable d'environnement path" .. :S

Clique sur Démarrer, puis clic droit sur "Ordinateur", puis clic sur "Propriétés".

Là, cliquer sur "Paramètres systèmes avancés", puis sur "Variables d'environnement".

Dans la liste déroulante en bas, sélectionne celle qui commence par "Path", puis clique sur "Modifier".

Dans le champ "Valeur de la variable", à la fin tu ajoutes : C:\wamp\bin\mysql\mysql5.5.16\bin;

(à priori, il faut aussi rajouter un point virgule juste avant, car les chemins sont séparés par des points virgule, tu comprendras en regardant le truc).

En faisant ça, tu informes windows que ce répertoire contient des exécutables (en l'occurence mysql) disponibles.

PS : il me semble qu'il faut redémarrer le PC pour prendre en compte ce changement, enfin chuis pas sûre.

Link to post
Share on other sites

Justement, quand j'utilise cd, je n'arrive pas à descendre ou monter les chemins. Je reste automatiquement bloqué à C:\Users\C71372

Enfin je vais essayer ta seconde méthode.

Et une fois que je modifie le chemin d'accès via cette solution, je pourrais taper ma ligne "mysql -h localhost -uroot -p nomdelabase < nomfichier.sql" qui importera monfichier dans la base voulue ?

Link to post
Share on other sites

Tu tapes bien cd .. (avec les deux points) et non pas uniquement cd ?

Non parce que de mémoire, quand tu faisais cd sur les anciennes versions de windows, ça t'amenait à la racine, mais ce n'est plus le cas avec les nouvelles versions. Donc si tu as lu ça sur un forum, oublie, il faut utiliser cd .. pour remonter d'un cran.

En ajoutant le chemin du dossier de l'exécutable mysql à la variable PATH, en principe, la commande mysql devrait désormais être reconnue.

Link to post
Share on other sites

j'ai effectivement oublié les .. :)

Bon enfin, maintenant que j'ai modifié directement via le chemin Paramètres systemes avancés, je vais essayer comme ca ! C'est la premiere fois depuis 7heures que je me dis que je touche au but !

Evidemment, il fallait qu'il y ait une erreur.

quand je tapes ma ligne "mysql -h localhost -uroot -p vespa < vespa.sql", on me demande d'entrer mon mot de passe, dans ce cas, je ne met rien (mot de passe de phpmyadmin), j'appuie sur ENTRER et ..

ERROR 2003 <HY000>:Can't connect to MySQL server on 'localhost' <10061>

Link to post
Share on other sites

Any idea ?

Je viens de voir sur un forum ceci :

The error (2003) Can't connect to MySQL server on 'server' (10061) indicates that the network connection has been refused. You should check that there is a MySQL server running, that it has network connections enabled, and that the network port you specified is the one configured on the server.

Alors je me dit : serait-ce possible que je ne sois pas connecté au serveur local ?!

Et quand je glisse la souris sur l'onglet de Wamp (qui est vert), je vois écrit : WAMPSERVER - serveur hors ligne.

Comment faire ?

Link to post
Share on other sites

Heu, là je vois pas trop. Peut-être un problème de droits d'accès.

Tu peux essayer d'ouvrir la console en tant qu'administrateur : aller dans C:\Windows\System32, faire clic droit sur cmd.ex puis "Exécuter en tant qu'administrateur".

Et essayer de nouveau la commande...

En tout cas, après ça (si tu arrives à te connecter au serveur), il faudra sûrement aussi que tu mettes le bon chemin d'accès au fichier de sauvegarde et pas juste "vespa.sql" (ou tout au moins déplacer ce fichier dans le répertoire "C:\wamp\bin\mysql\mysql5.5.16\bin" le temps de faire l'import.

Edit : si ton serveur n'est pas démarré, c'est sûr que ça peut pas marcher.

Je n'utilise pas Wamp Server (je préfère installer Apache, Php et mysql manuellement), mais il doit y avoir moyen de le redémarrer.

Il faut demander aux utilisateurs de Wamp :)

Link to post
Share on other sites

Ernestine, j'ai un nouveau problème, mais cette fois-ci pas en rapport avec phpmyadmin.

Le stagiaire a qui j'ai pris la place m'a indiqué qu'une fois les tables importées dans la base de données et le dossier des fichiers php installé dans wamp/www, je dois installer openoffice et une fois installé, rentrer cette ligne de commande :

soffice -headless -nologo -noestore -accept=socket,host=localhost,port=8100;urp;StartOffice.ServiceManager

mais, idem que précédemment, quand je rentre ça dans la console, je reçois ce message d'erreur :

'soffice' n'est pas reconnu en tant que commande interne ou externe, un programme exécutable ou un fichier de commandes.

C'est le meme message que j'avais recu pour mysql -h localhost -uroot -p vespa < vespa.sql.

Est ce qu'il faut que je retourne dans le dossier Démarrer/clic droit sur ordinateur/propriétés/parametre systeme avancés/.... et complète le path vers le chemin qui mène vers soffice.exe ?

Link to post
Share on other sites
Est ce qu'il faut que je retourne dans le dossier Démarrer/clic droit sur ordinateur/propriétés/parametre systeme avancés/.... et complète le path vers le chemin qui mène vers soffice.exe ?

La meilleure façon de le savoir, c'est d'essayer ;) Si c'est juste pour une utilisation unique, le plus simple est quand même d'exécuter la commande après t'être placé dans le bon dossier avec "cd".

Ernestine, j'ai un nouveau problème, mais cette fois-ci pas en rapport avec phpmyadmin.

Merci, mais je ne suis pas seule, tu peux faire une demande générale et pas juste à moi ;)

Link to post
Share on other sites

Bonjour,

Pour redémarrer Wampserver:

- solution 1 : si l'icone est active dans la barre de menu de Windows, alors clic gauche dessus, puis 'redémarrer tous les services'.

- solution 2 : ouvrir 'démarrer' > tous les programmes > wampserveur > et clic dessus.

L'icone de Wampserveur va changer de couleur. Au final, au bout de quelques secondes, elle doit être toute blanche. Si elle est jaune, alors c'est qu'un service est arrêté. Si elle est rouge, c'est que tous les services sont arrêtés.

Dans ces 2 cas là, alors revoir le fichier modifié précédemment : php.ini il me semble. Il doit y avoir un problème dans le fichier, ce qui fait que Apache n'arrive pas à l'ouvrir.

OpenOffice n'a rien à voir avec ton problème de base de données et d'import. Essaie déjà d'importer ta base et ensuite essaie de régler le problème de OpenOffice.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...