Jump to content
Sign in to follow this  
lorem_ipsum

Serveur mail different du serveur web

Rate this topic

Recommended Posts

Bonjour tt le monde,

nous sommes à la recherche de la procédure à suivre pour l'envoi des mails à partir d'un serveur dédié (ubuntu), quand la gestion des mails se fait depuis un serveur mail (exchange).

Le nom de domaine est géré par gandi, le dédié (web) par ovh et le serveur mail (exchange) par un autre prestataire.

Les éléments sont déjà renseignés chez Gandi (mail: telle ip, et www telle ip...)

Le site se trouvant sur le dédié est configuré en vhost, toutes les traces du ndd se trouvant dans /var/qmail/control.... ont bien été supprimé.

Dans plesk, le MX à bien été modifié par celui du serveur mail (vérif du MX dans les conf ubuntu = ok).

Le problème actuel:

Le cms en place utilise un formulaire qui à pour adresse mail pour l'envoi, une adresse existante sur exchange.

Les mails envoyés vers une adresse mail en toto_AT_domain.eu retourne l'erreur alors que l'envoi vers une adresse differente du ndd fonctionne.

L'adresse mail d'envoi reçoit:

<toto_AT_domain.eu>:
9x.xxx.xx.xxx does not like recipient.
Remote host said: 550 5.7.1 <toto_AT_domain.eu>... Relaying denied. Proper authentication required.
Giving up on 9x.xxx.xx.xxx.

Solutions testées:

-recherche dans le forum (sans succes)

-recherche Google (sujets similaires mais sans interet...)

-rechjerche plesk (sans succes)

-recheche forum ovh (sans succes)

-prières (sans succès)

-une bonne nuit de sommeil = sans succès

Merci bcp pour l'aide.

Lorem

Share this post


Link to post
Share on other sites

C'est tout simplement parce que ton serveur considère encore l'adresse email comme locale, malgré les MX distincts.

Si tu utilises exim, le fichier à éditer sera /etc/virtual/domains, duquel il faudra supprimer le nom de domaine et relancer exim.

Share this post


Link to post
Share on other sites

En fait notre problème est résolu.

Au départ il s'agissait bien d'un problème avec l'adresse mail en local...

Avec le message :

Sorry. Although I'm listed as a best-preference MX or A for that host,
it isn't in my control/locals file, so I don't treat it as local. (#5.4.6)

Une fois le problème réglé, le message d'erreur change pour celui cité plus haut.

Et biensur, le temps de voir que le message à changé, des heures et des heures s'écoulent...

Bref, une fois le nouveau message lu! on fourni à notre script de quoi faire sa "Proper authentication required" -.- et le tour est joué.

Merci pour l'aide, bonne journée,

Lorem

Edited by lorem_ipsum

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...