Aller au contenu
TYBMHI

Problème d'affichage de flux RSS en php

Noter ce sujet :

Recommended Posts

Bonjour à tous !

J'ai installé un script PHP pour lire les flux RRS provenant d'autres sites sur mon site. En local (PHP 5) tout fonctionne très bien. En revanche, depuis que j'ai mis mon site en ligne (PHP 5 aussi), le lecteur ne fonctionne plus et m'indique l'erreur suivante :


Warning: simplexml_load_file() [function.simplexml-load-file]: URL file-access is disabled in the server configuration in/homepages/36/d312582560/htdocs/SDF/info.php on line 74

Warning: simplexml_load_file(http://www.marianne.net/blogsecretdefense/index.php?preaction=rss) [function.simplexml-load-file]: failed to open stream: no suitable wrapper could be found in /homepages/36/d312582560/htdocs/SDF/info.php on line 74

Warning: simplexml_load_file() [function.simplexml-load-file]: I/O warning : failed to load external entity "http://www.marianne.net/blogsecretdefense/index.php?preaction=rss" in /homepages/36/d312582560/htdocs/SDF/info.php on line 74

Voici le code (en gras la ligne 74) :

<?php
/* insérer ici l'adresse du flux RSS de votre choix */
$rss = simplexml_load_file('http://www.marianne.net/blogsecretdefense/index.php?preaction=rss');
$cpt=0;
echo '<div style=margin:40px 0px 0px 0px;>';
foreach ($rss->channel->item as $item){
$datetime = date_create($item->pubDate);
$date = date_format($datetime, 'd M Y, H\hi');
echo '<p style=margin:0px 0px 10px 0px;><a href="'.$item->link.'">'.$item->title.'</a>   ('.$date.')</p><p style=margin:0px 0px 0px 0px;>'.$item->description.'</p><hr><br/>';
$cpt++;
if($cpt==10) break; //on sort de la boucle
}
echo '</div>';
?>

Je précise que je suis chez 1and1. Je ne sais pas si cela peut avoir une incidence. Est ce quelqu'un pourrait m'orienter pour résoudre ce problème ? Merci d'avance pour vos réponses et toute votre aide.

Modifié par TYBMHI

Partager ce message


Lien à poster
Partager sur d’autres sites

Apparemment, ton hébergeur t'empêche d'appeler directement un flux externe (URL file-access is disabled in the server configuration).

Il faudra sans doute que tu passes par cURL pour récupérer le contenu du flux XML.

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci beaucoup capatain_torche ! Je vais donc voir du coté du cURL. Encore merci et j'espère donc que je vais y arriver. A bientôt !

Partager ce message


Lien à poster
Partager sur d’autres sites

Un nouveau message pour te dire un grand merci capatain_torche ! C'est exactement ce qu'il me fallait. Ca fonctionne maintenant, parfait ! A bientôt !

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×