Aller au contenu
Djames-Allen

Quick cache crée des pages blanches

Noter ce sujet :

Recommended Posts

Bonjour le Hub,



Parfois le plugin quick cache me créé des pages blanches complètement vide. Quand je vide le cache la page s'affiche à nouveau normalement.



Quelqu'un aurais t-il une idée sur l'origine de ce bug. J'ai cherché mais je n'arrive pas à trouver.



Merci beaucoup pour votre aide


Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,



saturation de l'espace disque de la partition en question ?


Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Koob,



Non loin de la. Il y largement de la marge au niveau espace disque. Il me fait ce bug rarement mais je ne comprends pas pourquoi, le problème est que je ne peux pas vérifier une à une les pages du site pour voir si elle ont bien été mise en cache.

Partager ce message


Lien à poster
Partager sur d’autres sites

Dans ce cas, si le système de cache n'est pas fiable, change-en. Non ?


Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai songé mais les plugins de cache pour wordpress m'ont pas totalement convaincu. J'aime bien celui-la, je commençais à m'y habituer.



J'ai vu que le couple WP Super Cache et DB Cache Reloaded.était conseillé et performant. Mais quand je le mets en test il ne me donne pas des temps d'affichage de pages aussi rapide que je peux voir sur certains sites.


Partager ce message


Lien à poster
Partager sur d’autres sites

Tu es sur dédié ou mutualisé ? Parce que ça peut faire une énorme différence avec les temps que tu vois sur d'autres sites !

Partager ce message


Lien à poster
Partager sur d’autres sites

Une erreur PHP à l'intérieur de tes fichiers de cache ? (avec display_errors à off, ça explique la page blanche)


Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,



Désolé pour le retard.



@Dan je suis sur dédié. Y'a t'il quelque chose à faire pour améliorer cela ?



@SStephane. Il n'y a pas d'erreur php d'affiché dans ces pages blanches. Faut-il modifier display_errors ?



Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,



si tu es sur dédié, tu peux probablement déplacer ce cache en mémoire (tmpfs), par exemple en changeant le chemin de stockage en /dev/shm, ou mieux en ajoutant une ligne spécifique dans ton fichier /etc/fstab :




quickcache /chemin/de/ton/cache tmpfs defaults,atime,nodev,nosuid,noexec 0 0


Restera à faire mount /chemin/de/ton/cache.



Vérifie toutefois que tu ais assez de place en mémoire pour te permettre ce genre d'optimisation.



Et si «QuickCache» est bien l'outil auquel je pense, il ne fait pas le nettoyage de lui même. Donc à placer en cron, toutes les nuits par exemple :




find /chemin/de/ton/cache -atime +2 -type f -delete

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×
×
  • Créer...