Aller au contenu
Bridou

Cloner un serveur dédié pour tenter mise à jour

Noter ce sujet :

Recommended Posts

Bonjour,

Je viens demander de l'aide aux experts smile.gif

Je viens de reprendre en main un serveur dédié que possède un ami, avec dessus plusieurs sites en PHP.

Celui ci n'a, a priori jamais été mis à jour au niveaux des packages et on souhterait étudier cette possibilité (afin d'eviter les failles de sécurité, etc...)

La config du dédié est la suivante :

Fournit par OVH (lancé en 2010 je crois)

Distribution : CentOS release 5.5 (Final)

Kernel : 3.8.13-xxxx-std-ipv6-32

Lorsque je fais un yum check-update, il y'a presque 300 packages prêts a être updaté et un yum update se termine en erreur:

atomic/filelists_db | 970 kB 00:00

updates/filelists_db | 3.7 MB 00:04

--> Finished Dependency Resolution

sb-publish-3.0.1-200705230939.noarch from installed has depsolving problems

--> Missing Dependency: any-php-sqlite2 is needed by package sb-publish-3.0.1-200705230939.noarch (installed)

Error: Missing Dependency: any-php-sqlite2 is needed by package sb-publish-3.0.1-200705230939.noarch (installed)

You could try using --skip-broken to work around the problem

You could try running: package-cleanup --problems

package-cleanup --dupes

rpm -Va --nofiles --nodigest

The program package-cleanup is found in the yum-utils package

Je souhaiterai tenter de mettre a jour ce serveur mais tout en sécurité smile.gif

Mon idée serait de:

-"cloner" entièrement ce serveur (j'ai les accès root), est-ce que l'outil partimage peut rendre ce service ?

- Demarrer une VM linux en pointant sur le clone avec VMWare (la je ne sais pas encore trop comment faire pour démarrer un linux sur une image d'un autre système, mais je pense que c'est jouable)

- Faire en toute sécurité mes updates et valider que les sites fonctionnent par la suite sur mon clone.

Pensez vous que c'est envisageable de faire ca?

J'ai trop peur de tenter une mise a jour du serveur qui est en production et si par chance ca marche, que des sites ne soient plus compatible suite à la mise a jour de packages comme php et mysql.

Merci pour vos avis et conseils

A bientôt !

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,



Il est toujours risqué de mettre à jour php "à l'aveugle" car, si je ne m'abuse, la version standard de Php installée avec avec CentOS 5.5 est la 5.1.6 (???) et une mise à jour va remplacer cette version par php 5.3 ou 5.4.



Et dans ce cas, nombre de tes sites risquent de poser des problèmes de compatibilité.



Il serait plus sage de vérifier d'abord tes sites et faire les mises à niveau du code


Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×