Jump to content
OnvouslogeV2

Problème de session PHP

Rate this topic

Recommended Posts

Bonsoir à tous, je suis nouveau sur ce forum...



Je voulais savoir si une lumière pouvais m'éclairer car suite à une mise à jour de mon serveur, mes clients n'ont plus accès à l'interface d'admin de mon site internet de petites annonces immobilières.



Je pense que cela viens de la mise à jour au passage de PHP, voir de SQL, et du coup impossible de trouver la soluce, car je suis un peu novice.




Cordialement


Share this post


Link to post
Share on other sites

Bonjour,



Tu ne donnes pas assez d'info pour qu'on soit certain d'une réponse... mais si tu as changé de version de Php, assure-toi que le répertoire contenant les fichiers de session n'a pas changé !



Sinon, il nous faudrait au moins un message d'erreur qui s'affiche pour aller plus avant !

Share this post


Link to post
Share on other sites

Le problème viens que meme un technicien de niveau 2 de chez OVH n'arrive pas à me donner l'information... :(



Je suis à bout de mes compétences, mais je suis sur que la mise à jour à un impact sur mes problèmes.



Le serveur POP / SMTP tourne mais la correspondance entre la sauvegarde des login pass et sql ne passe pas car il ne reconnait plus les utilisateurs, donc impossible de recup des email ou d'en envoyer.



Apres un backoffice permet l'ajout d'annonce via une interface, suite à un controle user / password et la encore une fois rien ne passe...



Hors mis les problemes d'auth, tous les sites fonctionnes, sauf ce qui concerne, il me semble au session php...



Par tel je pourrais en dire plus...



Enfin je pense ;)



Merci d'avance


Share this post


Link to post
Share on other sites

Je pense qu'il va falloir que tu étudies les logs d'erreur de ton serveur : si la mise à jour a causé un problème (Et c'est plus que probable), tu devrais en trouver une trace.


Share this post


Link to post
Share on other sites

Concernant le serveur POP / SMTP, utilises-tu SASLAUTH, DKIM, COURIER et/ou POSTFIX ?


Si oui, et dans le cas où tu aurais éffectué une upgrade de tes packets (apt-get upgrade), c'est sans doute lié aux nouveaux packets cités ci-dessus.



J'ai le même problème, les nouveaux packets ont écrasés les anciens fichiers de configurations par ceux "par défaut". Il te faudra donc tout revérifier.


Personnellement je n'y suis pas encore arrivé mais ce n'est qu'une question de manque de temps / fouille complète dans le serveur.


Cela peut causer donc une impossibilité de se connecter au serveur webmail / IMAP / SMTP / POP.



Concernant les Sessions, en effet il nous faudra des logs sinon nous ne saurons rien faire.


Share this post


Link to post
Share on other sites

Bonsoir à tous,



Pour les emails, il sont gérer par ISPConfig, donc PostFix il me semble... :(



L'Upgrade à été fait par OVH, et il me disent que cela serais du à la mise à jour et qu'il faut que je reinstall tout avec une distribution fournit dans le manager... :(



Pour le problème de session, j'ai aucun message d'erreur...Ou puis je trouver les logs pour vous les transmetres ?


Share this post


Link to post
Share on other sites

Les sessions fonctionnent ailleurs ? (sur d'autres sites installés sur ce serveur, ailleurs dans le site ?)


Si non, vérifie que ton disque n'est pas plein ou/et que php peut écrire dans le répertoire qui lui permet de stocker les sessions (généralement /tmp dans une install par défaut)car ton souci de session sans message d"erreur me fait penser à ça.





reinstall tout avec une distribution fournit dans le manager




Dasn bien des cas, ça peut prendre moins de temps wink.gif


Share this post


Link to post
Share on other sites

Bonsoir Stephane,



Le rep TMP est en 777.



Ovh dit " L'upgrade suite au Hack est bancale, il faut tous reinstaller car il pense à un problème de correspondance Mot de Passe / SQL qui pose problème ou de code PHP pas à jour pour PHP5 "


Share this post


Link to post
Share on other sites

Bonjour,



Bon effectivement tu ne donnes que peu d'information sur ton problème. D'information technique nous dirons. Si tu utilises ISPCONFIG pour la gestion de tes emails on supposera que tu l'utilises aussi pour la création de tes sites Internet.



Dans tes derniers posts tu nous dis que l'upgrade a été fait par OVH suite à un hack. Pas mal d'information, on imagine que pour l'upgrade il doit s'agir de l'OS (quel OS ? Quelle distribution/version ?).



Il est sur que résoudre un hack par un upgrade est une très mauvaise idée (OVH est parfois de bon conseil) mais surtout ce qui va nous intérésser c'est:


- version de PHP ?


- quelle méthode pour complier/exécuter tes scripts PHP ? (mod_php, suphp, php-fpm ...)


- comment ton site gère-t-il les sessions utilisateurs ? (memcache, apc, fichier, base de données ...)


...



Peut-être serait-il intéréssant de faire intervenir une personne compétente si ton activité commerciale dépend de ton site :)



Renaud


  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...