Jump to content
Sign in to follow this  
ventesmultimedia

Compression css pour référencement

Rate this topic

Recommended Posts

Bonjour,

Je rencontre une difficulté pour compresser un fichier all.css ( dans prestashop)

Pour le fichier en.js je n'ai aucun problème la compression fonctionnement parfaitement bien avec cette règle mise un fichier php.ini:

<?zlib.output_compression = true?>


Je place le fichier php.ini dans le dossier "cache" de mon thème à partir de la via l'outil de Google "PageSpeed Insights " me montre bien que le fichier a bien été compressé par contre pour le fichier qui est dans le même dossier en extension all.css aucune compression.

J'arrive toute fois à le compresser grâce a un fichier htaccess que je place toujours dans le même dossier avec la règle suivante:

AddType x-mapp-php5 .php .php3 .php4 .htm .html .jsRewriteEngine onRewriteBase /RewriteRule (.*)\.css /css/compressecss.php?file=$1.css [L]


super le fichier all.css est bien compressé l'outil de Google m'affiche un score de 85/100.

Par contre quand je me rends sur mon site tout mon site est en décaler plus rien est en place. Tout revient en ordre quand je supprime la règle sur le htaccess.

Avez-vous une indication sur la compression de cette extension qui me fait gagner 52,5 Ko ?

Cordialement.

Share this post


Link to post
Share on other sites

Ton fichier compressecss.php fait quoi ? OK, il compresse, mais de quelle manière ?



Tu l'as écrit toi même ou bien trouvé sur le net ?


Share this post


Link to post
Share on other sites

Bonjour,



Je suis peut etre HS mais pagespeed sur firebug te donne directement la version compressée non ? ( je sais je suis peut etre HS mais bon c'est le peu que j'arrive a faire pour ameliorer mon PS ).



Pagespeed sur firebug c'est bien plus pratique que insight car te donne toute les compression directement ( image ccs js .. ), je suis pas capable de dire si les compression son bonne mais pour Pagespeed elles le sont et il n'y a aucun bug d'affichage apres compression du Global, dans mon cas (et pourtant mon presta commence a etre sacrément trop bidouillé !! )



Désolé si je suis HS :P


Share this post


Link to post
Share on other sites

Vous pouvez aller au Back-office, sur le menu :

Paramètres avances-----performance : CCC (Concaténation, Compression et mise en Cache)
activé les options

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...