Jump to content
Sanjb

max_execution_time avec Apache en CGI donne une erreur 500

Rate this topic

Recommended Posts

Bonjour,

Nous avons un serveur dédié chez OVH (le ns417072 administré par Dan, mais je n'ai pas accès à la section du forum pour les serveurs administrés) qui exécute Apache en CGI.

Le souci est que dès que j'essaye d'augmenter le max_execution_time via htaccess en mettant la ligne "php_value max_execution_time 380" le site plante avec une erreur 500.

Dès que je commente la ligne, tout refonctionne. J'ai essayé avec plusieurs valeurs, mais rien, cela plante toujours.

Du coup je voulais savoir si quelqu'un sait comment augmenter le max_execution_time pour un site avec apache en CGI?

Je ne souhaite pas changer le paramètre global du serveur, mais juste pour un site.
Merci de votre aide.

JP

Share this post


Link to post
Share on other sites

Bonjour,



oui c'est normal, le mode (f)CGI permet justement d'isoler PHP et Apache, si bien qu'Apache ne connait plus aucune inscruction de type php[_admin]_(value|flag). Ce qui implique qu'on ne peut plus modifier la configuration de PHP via un fichier .htaccess



Toutefois il y a plusieurs alternatives, dont les deux principales :


- généralement en (f)CGI chaque si a son propre fichier php.ini, dans lequel on peut ajuster la conf que l'on veut


- depuis PHP 5.3 celui-ci gère les fichiers .user.ini (cf http://php.net/manual/fr/configuration.file.per-user.php), reproduisant le même mécanisme que les .htaccess, mais dédiés à PHP


Share this post


Link to post
Share on other sites

Trop rapide Kioob ! ;)

Share this post


Link to post
Share on other sites

Bonjour,


Je vous remercie pour vos réponse.


@Kioob : merci beaucoup, c'est exactement ça. J'ai créé mon fichier .user.ini à la racine avec la valeur max_execution_time="380" et maintenant c'est OK.


Bonne journée!


Share this post


Link to post
Share on other sites

@Dan : merci :) Pour une fois que je ne débarque pas après la tempête !


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...