Jump to content
Sign in to follow this  
WilliamWallace

compte d'envoi avec sendmail (resolu)

Recommended Posts

Bonjour tout le monde.

 

nous avons un serveur en infogérance par Dan et suite à la migration de notre serveur, nous cherchons à définir le compte d'envoi de mails automatiques pour les inscriptions, validation de commande etc.

En effet nos mails ont pour expéditeur: leUserDuServeur@nomDeLaMachine

Nous avons essayer de définir le parametre sendmail_path dans le php.ini mais ce la ne fonctionne pas. On a également essayer de redéfinir sur la page php d'envoi les paramètres en manuel mais nous n'avons pas réussi non plus. Voici le genre de chose que nous avons tenté:

<?php
// ini_set("SMTP", "mail.itcpiercing.com");
// ini_set("smtp_port", "587");
// ini_set("sendmail_from", "suivicommande@itcpiercing.com");
// ini_set("auth_username", "*****@itcpiercing.com");
// ini_set("auth_password", "****************");

$to       = 'john@itcpiercing.com';
$subject  = 'Test de l\'envoi d\'un message !';
$message  = 'Voici un simple message envoyé depuis un script PHP !';
$headers  = 'MIME-Version: 1.0' . "\n";
$headers .= 'X-Mailer: PHP/' . phpversion() . "\n";

echo "<h1>Envoi d'un message vers l'adresse E-MAIL : ".$to."</h1>";

$envoi = mail($to, $subject, $message, $headers);
if ($envoi == true)        echo "<br /><h1>L'email a été envoyé avec succès.</h1>";
else                    echo "<br /><h1>échec de l'envoi d'un email</h1>";
?> 

De plus, nos mails envoyés en auto n'ont pas les certifications (dkim etc. et elles sont bien actives sur des mails "standard")

 

Ceci fonctionnait avant mais je ne sais pas comment mettre la bonne config'. Et nous utilisons exim. Nous aimerions egalement personnalisé l'adresse d'envoi suivant le domaine ou la page est hébergée.

 

Donc si quelqu'un a des pistes pour nous aider svp, car nous on patauge ! :P

 

merci à vous ! :)

 

edit: sur une distrib' debian

 

Edited by WilliamWallace

Share this post


Link to post
Share on other sites

Hello,

 

Exim filtre par défaut les changements de champ from: .... saut si l'utilisateur est un "trusted user" (utilisateur de confiance)

(que ce serveur soit géré par moi n'y change rien :whistling: )

 

J'ai défini l'utilisateur linux du domaine itcpiercing.com dans la liste "utilisateur de confiance" du fichier de config exim, et relancé ce dernier.

Tu devrais pouvoir changer le from à ta convenance.


Dan

 

Share this post


Link to post
Share on other sites

parfait merci (encore) je vais voir ca.

 

Et ma démarche qui etait de dire que tu gérais le serveur en infogérance permettait de dire aux autres utilisateurs que nous avions la même config', rien de plus ;)

Et comme je te sollicite pour des problèmes de novice, j'essayais d'abord de résoudre le probleme par moi même... ;)

Je teste et reviens après...

Share this post


Link to post
Share on other sites

J'ajouterais ceci :  que ton serveur n'ajoute pas de champ DKIM pour un mail dont le destinataire est local (sur le même serveur) est tout à fait normal ;)

 

Share this post


Link to post
Share on other sites

En effet ca fonctionne nettement mieux ! :P

 

Et mes plus grands remerciements vont (encore et toujours) pour Dan !

Bonne journée

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...