Welcome to Webmaster Hub

Inscrivez-vous maintenant pour avoir accès à toutes les fonctionnalités.

Une fois inscrit et identifié, vous pourrez contribuer à ce site en soumettant votre propre contenu ou en répondant au contenu existant. Vous pourrez éditer votre profil et communiquer avec les autres membres par messagerie privée.

Ce message sera supprimé une fois que vous serez identifié !

Wolf18

Les mails envoyés depuis mon dédiés n'arrivent pas sur GMAIL

Noter ce sujet :

Bonjour à toutes et tous,

 

je suis très heureux de revenir parmi vous mais je ne vais pas épiloguer car là n'est pas le sujet.

J'ai constaté un problème, je pensais que c'était temporaire mais en fait non et cela devient plutôt problématique ! Les emails envoyés de façon automatique depuis mon (ou plutôt mes car j'en ai deux) serveur dédié n'arrivent pas jusqu'à leur destinataire lorsque ce dernier utilise une adresse Gmail. Je recevais quelques plaintes d'utilisateurs qui me disaient ne jamais avoir reçu le courriel de confirmation et je faisais donc le nécessaire mais ça devient problématique car je loupe des membres.

 

J'ai testé plusieurs sites, mes IPs ne semblent pas blacklistées. Du moins plus maintenant (je faisais parti de 3 blacklist dont BARRACUDA mais après avoir fait les demandes tout est clean à l'heure ou j'écris ces lignes) ! Bref, du coup fais le test avec mon adresse en m'inscrivant sur plusieurs de mes sites et je ne reçois rien, même pas dans le dossier "spam".

 

J'ai gratté un peu sur la toile et je n'ai pas trouvé grand chose.

Notons que sur certains de me sites les emails sont automatiquement envoyés par le script PHPBB, sur d'autres par un script fais maison.

 

J'ai regardé un peu du côté de php.ini, log de mail (euh pas sur d'avoir trouvé par contre et pourtant ça pourrait pas mal m'aider !)... Je vous avoue que je suis un peu perdu là et que je ne sais plus trop quoi faire.

Le pire dans tout ça c'est que c'est surement à cause des "bots" que c'est arrivé car j'avais constaté que pas mal de membres aux pseudos étranges avaient des adresses en GMAIL. Ça a peut être généré trop d'erreurs chez eux  car les adresses n'existaient pas, entrainant mon ban.

 

En tout cas si vous avez des pistes je suis preneur à 200%.

Je vous remercie déjà de vos réponses.

 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello et bon retour parmi nous !

 

Deux points importants à surveiller en priorité pour augmenter la délivrabilité des emails :

- assure-toi d'avoir un champ SPF qui correspond bien à l'adresse IP utilisée pour envoyer les mails

- installe DKIM sur tes domaines.

 

Dans les logs de ton serveur mail, tu dois avoir plus d'info sur les transactions avec gmail, ne fût-ce qu'un code retour du serveur SMTP

 

Dan

 

 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ta réponse Dan.

J'ai regardé au niveau du SPF j'ai ça :

v=spf1 include:mx.ovh.com ~all

Ça me semble correct, bien qu'effectivement il pourrait être un peu plus restrictif ?! Je ne sais pas si le fait de remplacer le include par l'ip4 de mon serveur serait plus judicieux. J'ai lu quelques articles sur le SPF mais on ne peut pas dire que cela soit hyper détaillé. Si je mets uniquement l'IP du serveur, est-ce que je peux toujours continuer à envoyer des mails via mon webmail ?

 

J'ai enfin trouvé les logs et des lignes avec du gmail, voila ce que ça donne.

 

Nov 30 06:36:15 **mon_serveur** postfix/smtp[7235]: 686CDF70DD: to=<*******@gmail.com>, orig_to=<root>, relay=gmail-smtp-in.l.google.com[2a00:1450:400c:c09::1b]:25, delay=0.54, delays=0.04/0.03/0.17/0.3, dsn=5.7.1, status=bounced (host gmail-smtp-in.l.google.com[2a00:1450:400c:c09::1b] said: 550-5.7.1 [2001:41d0:1:9bd6::] Our system has detected that this message does 550-5.7.1 not meet IPv6 sending guidelines regarding PTR records and 550-5.7.1 authentication. Please review 550-5.7.1  https://support.google.com/mail/?p=IPv6AuthError for more information 550 5.7.1 . ip3si62463679wjb.97 - gsmtp (in reply to end of DATA command))

 

J'ai donc consulté l'aide Google proposée et effectivement il est fortement suggéré de :

- publier un enregistrement SPF (c'est fait à priori mais je vais vérifier un à un tous mes domaines)

- signer mes messages à l'aide du protocole DKIM

- publier des règles DMARC

 

Bref, merci Dan je crois que tu m'as plutôt bien orienté ! Il ne me reste plus qu'à voir comment installer DKIM. N'étant pas un pro du dédié cela risque de me prendre un peu de temps mais je vais bien finir par trouver un petit tuto.

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu émets/reçois tes mails sur un MXPlan ? Parce que c'est ce que montre le SPF que tu donnes en exemple ...

 

Pourtant, ce n'est pas ce que je vois pour les deux domaines renseignés dans ta signature qui utilisant ton serveur dédié pour le MX !

Si c'est ton serveur qui gère les mails, il faut mettre

v=spf1 a mx ip4:94.23.23.49 ~all 

pour le SPF et pour info, le SPF de wolf18.com n'est pas bon !

 

Tu peux aussi forcer ton client mail (sur le serveur) à utiliser IPV4 ...

 

Comme tu utilises postfix, il faut mettre inet_protocols = ipv4  au lieu de inet_protocols = all

dans /etc/postfix/main.cf et relancer postfix.

 

Dan

 

 

 

 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de modifier le fichier de config de postfix et le SPF pour le domaine GTA6FR.

Après test j'ai maintenant le mail qui ne part plus du tout avec le message d'erreur suivant :

Dec  1 18:44:41 ns367063 postfix/smtpd[29404]: NOQUEUE: reject: RCPT from ns367063.ovh.net[94.23.23.49]: 554 5.7.1 <****@gmail.com>: Relay access denied; from=<****@gta6fr.com> to=<****@gmail.com> proto=ESMTP helo=<ns367063.ovh.net>

 

Je suis perdu...

J'ai bien redémarré les services du serveur, mais peut être faut-il attendre un peu que les DNS se propagent ?

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Es-tu bien authentifié sur ton serveur ?

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Euh très franchement c'est une très bonne question mais à priori non je ne pense pas.

 

Dec  4 14:29:07 ns367063 postfix/smtpd[27755]: connect from ns367063.ovh.net[94.23.23.49]
Dec  4 14:29:07 ns367063 postfix/smtpd[27755]: setting up TLS connection from ns367063.ovh.net[94.23.23.49]
Dec  4 14:29:07 ns367063 postfix/smtpd[27755]: Anonymous TLS connection established from ns367063.ovh.net[94.23.23.49]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Dec  4 14:29:07 ns367063 postfix/smtpd[27755]: NOQUEUE: reject: RCPT from ns367063.ovh.net[94.23.23.49]: 554 5.7.1 <***@gmail.com>: Relay access denied; from=<***@gta6fr.com> to=<**@gmail.com> proto=ESMTP helo=<ns367063.ovh.net>
Dec  4 14:29:07 ns367063 postfix/smtpd[27755]: lost connection after RCPT from ns367063.ovh.net[94.23.23.49]
Dec  4 14:29:07 ns367063 postfix/smtpd[27755]: disconnect from ns367063.ovh.net[94.23.23.49]

 

Je suis perdu, j'imagine que tout cela se fait dans le fichier de configuration de postfix mais franchement ça ressemble à du chinois pour moi.

Je vais voir ce que je peux trouver sur le net.

 

 

Test à l'instant sur le forum gta6fr.com :

Je me suis inscrit avec une adresse en gmail et une en hotmail pour faire le test. J'ai désactivé l'envoie de mail via smtp (qui visiblement ne fonctionne pas du tout).

 

sur GMAIL (ne fonctionne pas) :

Dec  4 16:29:50 ns367063 postfix/pickup[2294]: 2D55B40DDD: uid=510 from=<gta6fra>
Dec  4 16:29:50 ns367063 postfix/cleanup[14160]: 2D55B40DDD: message-id=<914d1218085a3cb076268f3e009ff5f5@www.gta6fr.com>
Dec  4 16:29:50 ns367063 opendkim[31250]: 2D55B40DDD: DKIM-Signature field added (s=default, d=gta6fr.com)
Dec  4 16:29:50 ns367063 postfix/qmgr[31996]: 2D55B40DDD: from=<gta6fra>, size=1712, nrcpt=1 (queue active)
Dec  4 16:29:50 ns367063 postfix/smtp[14170]: 2D55B40DDD: to=<******@gmail.com>, relay=gmail-smtp-in.l.google.com[108.177.15.27]:25, delay=0.2, delays=0.14/0.01/0.05/0.01, dsn=5.1.2, status=bounced (host gmail-smtp-in.l.google.com[108.177.15.27] said: 553 5.1.2 The sender address <gta6fra> is not a valid RFC-5321 address. w62si9726839wme.143 - gsmtp (in reply to MAIL FROM command))
Dec  4 16:29:50 ns367063 postfix/cleanup[14160]: 8DBC740DDE: message-id=<20161204152950.8DBC740DDE@ns367063.ovh.net>
Dec  4 16:29:50 ns367063 postfix/bounce[14171]: 2D55B40DDD: sender non-delivery notification: 8DBC740DDE
Dec  4 16:29:50 ns367063 postfix/qmgr[31996]: 8DBC740DDE: from=<>, size=4122, nrcpt=1 (queue active)
Dec  4 16:29:50 ns367063 postfix/trivial-rewrite[14161]: warning: do not list domain ns367063.ovh.net in BOTH mydestination and virtual_mailbox_domains
Dec  4 16:29:50 ns367063 postfix/qmgr[31996]: 2D55B40DDD: removed
Dec  4 16:29:50 ns367063 dovecot: lda(gta6fra): Error: user gta6fra: Initialization failed: mail_location not set and autodetection failed: Mail storage autodetection failed with home=/home/gta6fra
Dec  4 16:29:50 ns367063 dovecot: lda(gta6fra): Fatal: Invalid user settings. Refer to server log for more information.
Dec  4 16:29:50 ns367063 postfix/local[14172]: 8DBC740DDE: to=<gta6fra@ns367063.ovh.net>, orig_to=<gta6fra>, relay=local, delay=0.11, delays=0.03/0.01/0/0.07, dsn=4.3.0, status=deferred (temporary failure)

 

Et sur hotmail (fonctionne) :

 

Dec  4 16:32:48 ns367063 postfix/pickup[2294]: DA3DE40DDF: uid=510 from=<gta6fra>
Dec  4 16:32:48 ns367063 postfix/cleanup[14557]: DA3DE40DDF: message-id=<be01298d4961002b67c5a0716a63b343@www.gta6fr.com>
Dec  4 16:32:48 ns367063 opendkim[31250]: DA3DE40DDF: DKIM-Signature field added (s=default, d=gta6fr.com)
Dec  4 16:32:48 ns367063 postfix/qmgr[31996]: DA3DE40DDF: from=<gta6fra>, size=1706, nrcpt=1 (queue active)
Dec  4 16:32:49 ns367063 postfix/smtp[14567]: DA3DE40DDF: to=<****@hotmail.fr>, relay=mx2.hotmail.com[104.44.194.235]:25, delay=1, delays=0.1/0.01/0.34/0.55, dsn=2.0.0, status=sent (250  <be01298d4961002b67c5a0716a63b343@www.gta6fr.com> Queued mail for delivery)
Dec  4 16:32:49 ns367063 postfix/qmgr[31996]: DA3DE40DDF: removed

 

 

Le pire dans tout ça c'est que j'ai également testé avec une troisième adresse en nom@domaine.tld qui pointe sur mon adresse GMAIL et là je reçois le mail.

D'ailleurs, chose étrange dans l'entête de ce 3ème mail j'ai ça :

Envoyé par: mx1.ovh.net

 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous,

 

je vous annonce que j'ai enfin réussi à trouver un paramétrage pour que les emails passent, bon je vais rester prudent car pour l'instant je n'ai fait ça que sur un seul nom de domaine donc à voir si j'arrive en faire de même sur les autres.

Cela dit, mes mails se retrouvent pour le moment dans le dossier "spam" de GMAIL avec le message suivant :

 

Citation

Pourquoi ce message se trouve-t-il dans les spams ? L'adresse d'expéditeur indiquée est associée au domaine ****.com, mais les tests d'authentification de ****.com n'ont pas permis de la valider.

 

La seule solution que j'ai trouvé c'est de forcer le return path dans php.ini

Citation

mail.force_extra_parameters = -fwebmaster@local.domain

 

Mais du coup je pensais que ça fonctionnait comme le main.cf de postfix mais non...

Comment puis-je faire passer le domaine.tld dans php.ini pour que l'adresse corresponde au domaine qui envoie le mail ?

J'ai plusieurs domaines sur le serveur.

 

 

EDIT: j'ai finalement mis le nom de mon serveur dédié, avec création de compte email, SPIF, DKIM et DMARC.

Tout semble fonctionner, j'ai appliqué la config sur tous mes domaines et à priori ça fonctionne et je n'ai plus d'erreur dans les entêtes.

 

RE-EDIT: presque terminé car en fait sur un serveur je n'ai qu'un domaine qui possède une signature DKIM... Ne me reste plus qu'à voir comment leur affecter et le tour sera joué !

Un grand merci à toi Dan, tu m'as bien aiguillé et je t'en suis reconnaissant.

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !


Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.


Connectez-vous maintenant