Aller au contenu
balooo

debutant sur kimsufi - où est apache

Noter ce sujet :

Recommended Posts

Et bien, tu lances tout simplement :

host dns100.ovh.net

et tu auras l'IP (IPv4 et IPv6) qui s'affichera.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est ce que j'avais fini par faire. C'est bon, merci énormément pour ton aide Dan.

Modifié par balooo

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

Je n'ai rien modifié sur la conf du domaine dont on parlait et je me retrouve de nouveau avec la redirection vers la page de défaut.

Quand j'utilise l'outil d'ovh j'ai l'erreur suivante :

Merci d'avance.

DELEGATION ERROR

Les serveurs de noms de la zone parente retournent des serveurs faisant autorité (vps525880.ovh.net) qui ne le sont pas par les serveurs de noms de la zone.

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tu parles de chaussito.ovh, moi j'arrive bien sur ton site !

 

C'est manifestement ton vps qui est SOA pour ce domaine.


 

ns.le-hub.net:dan# dig chaussito.ovh SOA

; <<>> DiG 9.10.3-P4-Debian <<>> chaussito.ovh SOA
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58910
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 4

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;chaussito.ovh.                 IN      SOA

;; ANSWER SECTION:
chaussito.ovh.          14400   IN      SOA     vps525880.ovh.net. hostmaster.chaussito.ovh. 2018032102 43200 3600 1209600 86400

;; AUTHORITY SECTION:
chaussito.ovh.          14400   IN      NS      sdns2.ovh.net.
chaussito.ovh.          14400   IN      NS      vps525880.ovh.net.

;; ADDITIONAL SECTION:
sdns2.ovh.net.          891     IN      A       213.251.188.141
sdns2.ovh.net.          891     IN      AAAA    2001:41d0:1:4a8d::1
vps525880.ovh.net.      891     IN      A       164.132.196.88

;; Query time: 12 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Jul 04 18:38:56 CEST 2018
;; MSG SIZE  rcvd: 200

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Je vois que chaussito.com a une IP différente selon que l'on interroge ton serveur ou le serveur secondaire !

Manifestement, le serveur secondaire pointe vers un hébergement mutualisé !

ns.le-hub.net:root# dig chaussito.com @vps525880.ovh.net

; <<>> DiG 9.10.3-P4-Debian <<>> chaussito.com @vps525880.ovh.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19260
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;chaussito.com.                 IN      A

;; ANSWER SECTION:
chaussito.com.          14400   IN      A       164.132.196.88

;; AUTHORITY SECTION:
chaussito.com.          14400   IN      NS      dns100.ovh.net.
chaussito.com.          14400   IN      NS      vps525880.ovh.net.

;; Query time: 11 msec
;; SERVER: 164.132.196.88#53(164.132.196.88)
;; WHEN: Thu Jul 05 07:40:00 CEST 2018
;; MSG SIZE  rcvd: 110
ns.le-hub.net:root# dig chaussito.com @dns100.ovh.net   

; <<>> DiG 9.10.3-P4-Debian <<>> chaussito.com @dns100.ovh.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17479
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;chaussito.com.                 IN      A

;; ANSWER SECTION:
chaussito.com.          3600    IN      A       213.186.33.5

;; Query time: 0 msec
;; SERVER: 2001:41d0:1:4a90::1#53(2001:41d0:1:4a90::1)
;; WHEN: Thu Jul 05 07:40:13 CEST 2018
;; MSG SIZE  rcvd: 58

chaussito.ovh n'utilise pas dns100.ovh.net mais bien sdns2.ovh.net comme DNS secondaire !

 

Tu as donc du définir par erreur une zone DNS sur le manager OVH pour ce domaine vu que dns100.ovh.net apparaît comme SOA pour le domaine.
 

ns.le-hub.net:root# dig chaussito.com @dns100.ovh.net SOA

; <<>> DiG 9.10.3-P4-Debian <<>> chaussito.com @dns100.ovh.net SOA
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 48456
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;chaussito.com.                 IN      SOA

;; ANSWER SECTION:
chaussito.com.          3600    IN      SOA     dns100.ovh.net. tech.ovh.net. 2018043001 86400 3600 3600000 300

;; Query time: 0 msec
;; SERVER: 2001:41d0:1:4a90::1#53(2001:41d0:1:4a90::1)
;; WHEN: Thu Jul 05 07:43:14 CEST 2018
;; MSG SIZE  rcvd: 97

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Comme la page qui s'affiche est manifestement la page "standard" d'apache sur Ubuntu, tu as du oublier de créer un VirtualHost pour ton domaine chaussito.com.

Partager ce message


Lien à poster
Partager sur d’autres sites

Coucou

Oui les autres domaines format sur la page ubuntu. J'ai tout rajouté les vhosts y compris pour celui là. et maintenant c'est même plus la page de félicitations pour avoir créé un domaines c'est le webmail.

Tous les autres domaines que j'ai crées en appliquant à la lettre de ce que tu m'as expliqué fonctionnent très bien sauf chaussito.com

 

Partager ce message


Lien à poster
Partager sur d’autres sites

La page de webmail que tu affiches vient du fait que tu utilises dns100.ovh.net comme serveur DNS secondaire.

Or celui-ci donne 213.186.33.5 comme adresse IP pour ton domaine.
Donc tu as la page du webmail qui s'affiche si le serveur DNS qui répond est dns100.ovh.net !

 

Il faudrait peut-être apprendre à lire les messages que je t'ai donné -notamment ce matin- et effectuer les corrections de DNS, sinon tu n'y arriveras pas ! :whistling:

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Je l'avais déja fait mais j''ai recrée ce vhost mais rien ne change... Normal ?

(ps j'ai bien relancé apache après )

Modifié par balooo

Partager ce message


Lien à poster
Partager sur d’autres sites

Il n'y a pas que le vhost...

Tu as tout de même lu que tes DNS ne sont pas corrects ?

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui mais je les ai fait à l'identique des autres, je ne comprends pas comment le SOA est mal renseigné, j'ai fait comme les autres et meme encore hier pour un nouveau. tout marche très bien.

Donc la question qui me reste c'est comment je peux changer pour mettre le bon SOA primaire. et ça pour le coup je vois pas ou j'ai pêché.

Modifié par balooo

Partager ce message


Lien à poster
Partager sur d’autres sites

Il faut simplement changer le  DNS secondaire sur le manager du registrar du domaine (OVH ?) et mettre sdns2.ovh.net comme pour chaussito.ovh !

 

Assure-toi aussi de ne pas avoir de zone DNS définie sur le manager OVH pour ce domaine !

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Re. Ca marche. Je ne comprends pas pourquoi ils donne pas par défaut sdns2.ovh.net plutôt que ns du webmail. Merci encore Dan

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×