Aller au contenu
balooo

symfony, problème de config

Noter ce sujet :

Recommended Posts

Bonjour, Dan avait réussi gentillement à m'aider pour les  DNS maintenant mon site symfony apparait très bien dans mon documentroot, en revanche il ne fait que lister le repertoire web, et donc n'utilise pas app.php ou app_dev.

Une idée?

Partager ce message


Lien à poster
Partager sur d’autres sites

définissez l'index du vhost comme "add.php" ou renommez le fichier php que vous souhaitez voir être exécuté par défaut en "index.php".

A moins que vous souhaitez signaler que les scripts ne sont pas fonctionnels ? Si c'est le cas, il vous faudra installer le module PHP pour votre serveur web

Partager ce message


Lien à poster
Partager sur d’autres sites

Symfony ne fonctionne pas avec des index, il y a une regle de reecriture; j'ai bien mis cette regle fichier conf mais rien ni fait

Pour info c'est le site chaussito.ovh

Modifié par balooo

Partager ce message


Lien à poster
Partager sur d’autres sites

egalement pour info le vhost

<VirtualHost *:80>
    ServerName chaussito.ovh
    ServerAlias www.chaussito.ovh

    DocumentRoot /var/www/www-dev/frontorny/web
    <Directory /var/www/www-dev/frontorny/web>
        AllowOverride None
        Order Allow,Deny
        Allow from All

        <IfModule mod_rewrite.c>
            Options -MultiViews
            RewriteEngine On
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteRule ^(.*)$ app.php [QSA,L]
        </IfModule>
    </Directory>

    # uncomment the following lines if you install assets as symlinks
    # or run into problems when compiling LESS/Sass/CoffeeScript assets
    # <Directory /var/www/project>
    #     Options FollowSymlinks
    # </Directory>

    # optionally disable the RewriteEngine for the asset directories
    # which will allow apache to simply reply with a 404 when files are
    # not found instead of passing the request into the full symfony stack
    <Directory /var/www/www-dev/frontorny/web/bundles>
        <IfModule mod_rewrite.c>
            RewriteEngine Off
        </IfModule>
    </Directory>
    ErrorLog /var/log/apache2/project_error.log
    CustomLog /var/log/apache2/project_access.log combined
</VirtualHost>

Modifié par balooo

Partager ce message


Lien à poster
Partager sur d’autres sites

Avec le mod rewrite activé je n'ai plus le listing du repertoire web mais je mange une belle erreur 500

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×