Jump to content

Dossiers et index htaccess


Recommended Posts

Bonjour à tous

je voudrais quand je tape https;//monsite/dossier accéder à https;//monsite/dossier/index.php
or j'accède à https;//monsite/dossier/ avec un 404

en localhost ca fonctionne

pour la racine https;//monsite c'est ok

mon htaccess
 

RewriteEngine On
Options -Indexes
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^([^\.]+)$ $1.php [NC,L]
RewriteCond %{HTTPS} ^off$ [NC]
RewriteRule ^(.*)$  https://%{HTTP_HOST}/$1   [R=301,L]
AddDefaultCharset    UTF-8
ErrorDocument 404 /404.php

 
Link to comment
Share on other sites

Bonjour et bienvenue à bord du Hub !

 

As-tu bien index.php dans la liste DirectoryIndex ?

 

Par défaut, c'est :

DirectoryIndex index.html

Ajoute cette ligne dans ton fichier .htaccess :

DirectoryIndex index.html index.php
A ta place, je mettrais la règle suivante avant toutes les autres réécritures:
RewriteCond %{HTTPS} ^off$ [NC]
RewriteRule ^(.*)$  https://%{HTTP_HOST}/$1   [R=301,L]

 

 

Link to comment
Share on other sites

Merci pour la réponse mais le problème reste le même

https://monsite/dossier/fichier envoie bien vers https://monsite/dossier/fichier.php

mais https://monsite/dossier/ ne renvoie pas vers https://monsite/dossier/index.php

c'est bizarre car en localhost ça fonctionne

mon htaccess actuel

RewriteEngine On
RewriteCond %{HTTPS} ^off$ [NC]
RewriteRule ^(.*)$  https://%{HTTP_HOST}/$1   [R=301,L]
DirectoryIndex index.html index.php
Options -Indexes
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}.php -f
RewriteRule ^([^\.]+)$ $1.php [NC,L]
#RewriteEngine On
AddDefaultCharset	UTF-8
ErrorDocument 404 /404.php
DirectoryIndex index.php

le site en question

https:chezgopi.fr/2/index.php

je voudrais comme adresse

https:chezgopi.fr/2

Link to comment
Share on other sites

Commente ou supprime ces lignes  parce que la redirection de http://chezgopi.fr/2 renvoie vers https://chezgopi.fr/2/.php

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}.php -f
RewriteRule ^([^\.]+)$ $1.php [NC,L]

Tu as une ligne DirectoryIndex en trop dans ton .htaccess, même si cela ne gène pas vraiment !

Link to comment
Share on other sites

Toujours pareil

voir https://chezgopi.fr/2

mon htaccess

RewriteEngine On
RewriteCond %{HTTPS} ^off$ [NC]
RewriteRule ^(.*)$  https://%{HTTP_HOST}/$1   [R=301,L]
DirectoryIndex index.php
Options -Indexes
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME}.php -f
#RewriteRule ^([^\.]+)$ $1.php [NC,L]
#RewriteEngine On
AddDefaultCharset	UTF-8
ErrorDocument 404 /404.php

 

Link to comment
Share on other sites

Ton fichier, il est bien renommé .htaccess ? (avec un point au début)

Parce qu'il semble que les modifs que tu fais ne sont pas prises en compte !

 

Link to comment
Share on other sites

Si tu te connectes par ftp, supprime le fichier .htaccess de ton hébergement, fais un test pour t'assurer que les redirections ne se font plus et télécharge à nouveau ton fichier .htaccess

Link to comment
Share on other sites

Tu avais raison je ne mettais pas a jour mon htaccess car j'avais un filtre dans mon winsp mon programme ftp qui bloquait le htaccess que j'avais mis parce que en local il ne supporte pas la redirection en https

merci encore por le temps passé à me répondre

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...