Jump to content

hébergement désordonné chez OVH


Recommended Posts

Bonjour.
J'ai besoin d'une aide pour mon site http://www.argotheme.com
sur les fichiers et dossiers et fichier hébergés chez OVH.
Après une manoeuvre incontrôlé, il a disparu de la toile.
Je ne suis pas webmaster, je ne trouve pas le problème.
Je donne une capture d'écran, si ça peut éclairer le chemin de la correction.
Merci de m'apporter un coup de main. 

FTP client.png

Link to post
Share on other sites

Bonjour,

 

Seul quelqu'un avec un hébergement mutualisé pourra te dire si les dossiers sont à leur emplacement d’origine.

Tu n'as aucune idée quant-à la "manœuvre incontrôlée" que tu as effectuée ?

Link to post
Share on other sites
il y a 7 minutes, Dan a dit :

Bonjour,

 

Seul quelqu'un avec un hébergement mutualisé pourra te dire si les dossiers sont à leur emplacement d’origine.

Tu n'as aucune idée quant-à la "manœuvre incontrôlée" que tu as effectuée ?

Bonjour. 
J'ai touché le 1er novembre. Y'a 2 jours.
J'ai lancé une restauration des sauvegarde, infructueuse. Et aucune possibilité de faire d'autres.
Merci.

Link to post
Share on other sites

Cela ressemble bien à une redirection incorrecte (dans le fichier .htaccess)

Tu dois vouloir forcer le www et le ssl dans l'URL :

 

ns.le-hub.net:root# curl http://argotheme.com     
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>302 Found</title>
</head><body>
<h1>Found</h1>
<p>The document has moved <a href="https://www.argotheme.com/">here</a>.</p>
</body></html>

 

et lorsqu'on demande la bonne URL, il y a toujours une redirection 302 en place.

 

ns.le-hub.net:root# curl https://www.argotheme.com
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>302 Found</title>
</head><body>
<h1>Found</h1>
<p>The document has moved <a href="https://www.argotheme.com/">here</a>.</p>
</body></html>

 

Donne-nous la partie du contenu du .htaccess qui gère cette redirection.

 

Link to post
Share on other sites
il y a 1 minute, Dan a dit :

Cela ressemble bien à une redirection incorrecte (dans le fichier .htaccess)

Tu dois vouloir forcer le www et le ssl dans l'URL :

 


ns.le-hub.net:root# curl http://argotheme.com     
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>302 Found</title>
</head><body>
<h1>Found</h1>
<p>The document has moved <a href="https://www.argotheme.com/">here</a>.</p>
</body></html>

 

et lorsqu'on demande la bonne URL, il y a toujours une redirection 302 en place.

 


ns.le-hub.net:root# curl https://www.argotheme.com
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>302 Found</title>
</head><body>
<h1>Found</h1>
<p>The document has moved <a href="https://www.argotheme.com/">here</a>.</p>
</body></html>

 

Donne-nous la partie du contenu du .htaccess qui gère cette redirection.

 

Effectivement je voulais passer en HTTPS... de http.

Link to post
Share on other sites

Ton erreur est là !

Envoie-moi le fichier .htaccess par MP si tu ne veux pas l'afficher ici.

 

Link to post
Share on other sites

Effectivement je voulais passer en HTTPS... de http.
Mais, il n'y a que ça en
.htaccess 

SetEnv PHP_VER 4

Link to post
Share on other sites

Tu fais ta redirection vers https de quelle manière ?

Tu es toujours en php 4 ???

 

Link to post
Share on other sites

Je parlais du .htaccess à la racine du site, vraisemblablement dans le répertoire www (ou dans site ?)

 

Link to post
Share on other sites

Effectivement dans www.
que j'ai fait passer en https...

j'ai rajouté les 3 dernières lignes données par OVH


SetEnv PHP_VER 4
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.argotheme.com/$1 [R,L]
 

Edited by argotheme
Link to post
Share on other sites

Ce n'est pas ça ! Tu me transmets un fichier html ... pas un fichier de configuration .htaccess.

 

Le nom doit commencer par un point (c'est un fichier "caché" sous linux).

 

Link to post
Share on other sites

OK pour ces trois lignes. Assure-toi qu'elles soient AVANT toutes les autres lignes de réécriture du fichier .htaccess.

Le mieux est de transmettre le fichier, s'il contient d'autres lignes.

 

 

Link to post
Share on other sites

La ligne SetEnv n'est pas une ligne de réécriture donc c'est OK !

 

Ton site ne fonctionne toujours pas ! Tu dois avoir autre chose qui coince dans ce fichier.

Link to post
Share on other sites

il ne fonctionne toujours pas.
C'est la disposition des fichiers...
Le root devance tous les téléchargements.
Je ne l'avais pas remarqué auparavant.

 

Link to post
Share on other sites
il y a 23 minutes, argotheme a dit :

il ne fonctionne toujours pas.
C'est la disposition des fichiers...
Le root devance tous les téléchargements.
Je ne l'avais pas remarqué auparavant.

 

Tu as toujours une redirection 302 vers https://www.argotheme.com même si le site est déjà en SSL !

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...