Jump to content
Sign in to follow this  
xpatval

margin différent selon nav ?

Rate this topic

Recommended Posts

Décidemment, que de questions aujourd'hui.

Voili: Sous IE et opera, pas de prob.

Sous firefox et netscape, là je l'ai.

Quel problème ? celui d'un margin-top d'une dizaine de pixel qui subsiste, malgré une déclaration à 0 dans la feuille de style:

body {
background-color: #000066;
margin: 0;
padding:0;
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 12px;
}

#cont {
position: absolute;
width: 100%;
padding:0;
margin-left:-3px;
}

cont est le <div> conteneur principal.

Quelqu'un a-t-il eut ce problème ?

xpatval.

Share this post


Link to post
Share on other sites

Bonjour xpatval,

je ne sais pas ce que tu as d'autre dans ta page, mais il faudrait peut-être mettre à zéro les margin et padding par défaut de tes balises (elles en ont toutes, je crois, sauf le div).

tu peux le faire ainsi au début de ta CSS:

*{margin:0; padding:0;}

;)

Share this post


Link to post
Share on other sites

Ils le sont. (rectifiés).

Néanmoins, le problème persiste.

Visible là: index.php

(à ouvrir avec netscape ou firefox, et voir que l'image en haut à droite ne "colle pas" au haut de page, contrairement à opera et IE)

xpatval

Edited by xpatval

Share this post


Link to post
Share on other sites

Bonjour,

<div id="head">
<p align="center">
<img class="coin" src="commun/coin_h_left.gif" align="left">
</p>
</div>

Dans un premier temps tu pourrais supprimer le <p></p>.

Ensuite pourquoi ne pas supprimer l'image (qui n'a pas de alt="" !!!) et modifier #head en y ajoutant :

background: url("valpastel.free.fr_fichiers/coin_h_left.gif") no-repeat left top;

Share this post


Link to post
Share on other sites

Je confirme, le code n'est pas joli joli.

Ce qui plante sous firefox c'est que tu n'as pas défini de margin et de padding pour <p> dans ta feuille de style, et que tu encadre ton image (inutilement) de balises <p>.

Share this post


Link to post
Share on other sites

Bien vu pour les padding margin du <p> de #head. Le problème venait de là.

Pour les autres remarques, la page qui était visible était dépouillée de tt le reste, ce pourquoi la question a été posée par Jeroen Et Tchesko de l'utilité de la balise <p>.

Elle m'est bien entendu utile, car il y a du texte.

Le alt est défini aussi, malgré le code indiqué ici (dépouillé lui aussi).

En tt cas, un grand merci. :up::up:

A plus,

xpatval

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...