Jump to content
Sign in to follow this  
Marie

CSS différente selon navigateur

Rate this topic

Recommended Posts

Bonjour

J'ai déménagé un de mes sites et depuis, mon annuaire est en "vrac"... on dirait que la CSS est introuvable (les fichiers ont pourtant tous été copiés correctement)

Si quelqu'un à une idée je prends

http://www.enfant-precoce.com/annuaire

merci!

Share this post


Link to post
Share on other sites

Edit : ca viendrait de ton javascript sous firefox il ne semble pas s'exécuter, sous IE ca fonctionne.

Ca peut aider : http://www.metalusions.com/backstage/articles/8/

http://simon.incutio.com/archive/2003/08/11/documentAll

document.all est déprécié on dirait ;)

Share this post


Link to post
Share on other sites

Merci pour les pistes que je vais explorer rapidement

Je reste toutefois assez surprise que tout fonctionnait auparavant sur l'autre serveur... :wacko:

j'édite pour donner l'url de l'ancien hébergement :

http://240plan.ovh.net/~enfantpr/annuaire/

Chez moi c'est ok.. et chez vous?

Share this post


Link to post
Share on other sites

Etrange en effet. De chez moi avec firefox ça marche sur ton ancien serveur, et pas sur le nouveau (avec ie ça marche sur les 2). Pourtant avec javascript tout est sensé se passer coté client :blink:

Share this post


Link to post
Share on other sites

Ah tu me décomplexes Jan!

Je reste perplexe...

Je vais explorer les liens de Monique et Gilles et vais tenter de m'en sortir comme ça ;)

Share this post


Link to post
Share on other sites

et si au lieu de <LINK HREF=\"n.php\" REL=stylesheet>

tu changes l'extension et mets <LINK HREF=\"n.css\" REL=stylesheet>

car cela peut venir de la configuration du serveur de l'hébergeur sur sa façon de traiter le type mime d'un fichier suivant son extension.

Share this post


Link to post
Share on other sites

Merci Sylvain

je pense que tu m'as mise sur la bonne piste, ça donne déjà du mieux en modifiant juste quelques extensions

je peaufine ce soir :) et merci encore :)

Share this post


Link to post
Share on other sites

Attention avec cet annuaire la feuille de style est dynamique notamment les couleurs (d'ou le php)...si tu change l'extension en css il faudra je pense coder les variables "en dur"

Share this post


Link to post
Share on other sites

Sebastien, je savais bien que tu viendrais m'aider sur ce topic, tu connais bien ce type d'annuaire ;)

:wacko: la feuille de style est dynamique??

à quoi ça sert?

Bon, je remet ça à plus tard mais je n'abandonne pas!

Share this post


Link to post
Share on other sites

Il y a 2 feuilles de style (en tt cas avec ma version, ca a pu changer depuis) qui sont ie.php et n.php. Le script detecte le navigateur et choisit la plus adaptée.

Ces feuilles de style sont très ordinaires sauf que les couleur, la taille des polices et le logo sont des variables php definie dans style.php

Si tu change ie.php en ie.css et n.php en n.css le code php ne sera plus interpreté et ta feuille sera invalide. Il faudra donc remplacer dedans les variables par leur valeurs.

Edited by Sebastien

Share this post


Link to post
Share on other sites

Est-ce vraiment indispensable de passer par JavaScript pour inclure du CSS ?

Les trois couches : contenu, style et dynamique, ce n'est pas pour rien qu'on dit qu'elles doivent être séparées non ? Faire dépendre l'une de l'autre, c'est prendre des risques !

Par exemple tu as essayé avec Opera ? Opera connait le document.all, donc applique la feuille pour IE. Je te laisse imaginer le résultat :whistling:

À ta place je suivrais le lien de Monique qui dit "pas de détection de navigateur" :hypocrite:

Share this post


Link to post
Share on other sites

Ok Xavier

j'avoue avoir installé l'annuaire "par défaut" et ne m'être pas posé plus de questions que ça!

Les vacances arrivent, j'espère pouvoir y bosser un peu ;)

Share this post


Link to post
Share on other sites

De mon côté j'ai la même présentation sous Firefox et I.E. mais pas comme sur l'ancien hébergement...

Share this post


Link to post
Share on other sites

Je ne sais plus quoi penser... j'ai vraiment l'impression que le problème vient du serveur (un dédié chez Amen contre un mutalisé OVH avant) et non pas du script de détection de navigateur

:blink:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...