Jump to content

Problème menu et cadre du contenu


Recommended Posts

Bonsoir à tous.

Sur mon site www.technyrem.fr , je rencontre un problème de menu.

En effet celui-ci passe au-dessus du header si on réduit la taille du texte.

C'est également comme ça qu'il apparait dans le cache de google ou dans certains moteurs qui mettent des miniatures :wacko:

Mon menu est positionné en <include> et en bas de page dans le code et ainsi dans ma feuille de style (pour lui faire reprendre sa position):

.menu {
position: absolute;
top: 6.8em;
left: 1ex;
padding: 3px 0 0.5ex 0;
width: 10.8em;
background-color: #D5D7E1;
border-width: 1px;
border-style: solid;
border-color: #4B81AF;
   }

Pour solutionner ce problème de "passage sur le header", j'ai revu tout ceci sur -http://technyweb.free.fr/ (pour les essais).

Mon menu est maintenant en <include> en haut de page (le tout dans un conteneur) et mon texte principal est dans un "main".

Dans ma feuille cela donne ceci

 /*Menu*/     
#menuconteneur {
float: left;
clear: both;
margin-left: 1.5px;
}

#menu {
padding: 3px 0 0.5ex 0;
width: 10.8em;
background-color: #D5D7E1;
border-width: 1px;
border-style: solid;
border-color: #4B81AF;
   }

Cela fonctionne , mon menu ne passe plus sur mon header si je réduit la taille du texte. Mais cela engendre un autre problème :unsure:

Sous Internet Explorer, la "bordure" de mon "main" en haut à gauche s'affiche après un certain délai

et semble attendre la fin du chargement du menu.

Sous FF, je n'ai pas ce problème, car FF est rapide à charger les pages :rolleyes:

Mais sous IE, c'est du plus mauvais effet et je trouve ça très moche :wacko:

Quelqu'un a-t-il des idées ou suggestions me permettant de résoudre ce problème de délai d'affichage de la bordure du "main" sous IE

et/ou le passage du menu sur le header ????

Merci d'avance

(je sais qu'il y a beaucoup de travail sur le reste du code, j'essaie déjà de résoudre ça ;) )

Edited by technyweb
Link to post
Share on other sites

Bonsoir :)

Je ne trouve rien de moche sous IE ... ou alors, je n'ai pas compris ce que tu souhaitais :blush:

La page sous IE et FF s'affiche de la même façon, même en réduisant les caractères.

Link to post
Share on other sites

Merci Azon de ton commentaire.

Tu parles de mon site-celui dans ma signature (problème de menu qui passe sur le header) ou du site technyweb (chez free) où je fais mes essais (problème de délai d'affichage de la bordure en haut à gauche) ?

Moi j'ai ce délai :wacko:

Link to post
Share on other sites

J'ai testé le site chez Free et c'est celui où tout marche bien.

En revanche, je viens de tester le site -http://www.technyrem.fr/ et effectivement, je vois le menu qui passe sur le header.

Il y a un autre souci je crois : sur FF, la page ne prend pas la totalité du body en largeur. Contrairement à IE qui affiche bien la page.

Je crois que le mieux est que tu récupères le code chez Free, et pour le problème du délai d'affichage, attendons d'autres avis mais je ne vois rien de louche ;)

Link to post
Share on other sites
Il y a un autre souci je crois : sur FF, la page ne prend pas la totalité du body en largeur. Contrairement à IE qui affiche bien la page.

Tu es en quelle résolution ? Moi, en 1024 x 768, je vois tout !!! :blink:

Je crois que le mieux est que tu récupères le code chez Free, et pour le problème du délai d'affichage, attendons d'autres avis mais je ne vois rien de louche ;)

Oui c'est mon intention de prendre le code chez FREE (c'est celui que je travaille).

Mais effectivement, j'aimerais d'autres avis pour voir si ce délai n'existe que chez moi car ça m'embête vraiment.

(bizarre tout de même, ça doit être une question de vitesse de connexion peut-être).

NB: avant de continuer à travailler sur mon code et à l'améliorer, je dois absolument choisir une des deux versions.

Link to post
Share on other sites

Je suis en 1600x1200 avec la barre des favoris affichée à gauche.

Sous IE, la largeur de la page varie en fonction de la largeur du navigateur, pas sur FF. Sur FF, on dirait que tu as une largeur fixe.

Pour la vitesse de connexion, je ne sais pas .. mais je suis en numeris alors à moins que tu sois en 56K, je ne comprends pas ;)

Link to post
Share on other sites

Je suis étonné pour le problème de largeur du contenu.

Normalement, il s'adapte à la résolution.

Je viens pour un problème, je vais repartir avec un autre :wacko:

Quand à mon problème initial de délai d'affichage de la bordure du "main", on me l'a confirmé donc si quelqu'un à une idée ou des suggestions pour le résoudre, merci d'avance ?

Je suis bloqué là-dessus, c'est embêtant.

Link to post
Share on other sites

Mon message ne semble pas inspirer grand monde (je sais, c'est dimanche ;) )

Mais j'ai vraiment besoin de vos avis pour choisir une des deux versions et continuer à travailler et revoir mon code (sémantique, conformité ......).

Aussi, à défaut d'avoir LA solution, pouvez me dire comment cela s'affiche chez vous,

selon votre navigateur, vitesse de connexion et résolution d'écran ?

Je parle du site hébergé en essai chez free ----> ICI

Bien-sur, si vous avez également des conseils ou une solution, je suis preneur :rolleyes:

(Et merci encore à Azon d'avoir pris la peine de me répondre ^_^ )

Edited by technyweb
Link to post
Share on other sites

Pour vous montrer de quoi il s'agit précisement, voici une image.

tech5eu.gif

J'ai un délai sous Internet Explorer dans l'affichage du cadre du contenu (au niveau des flèches rouges), ce n'est pas terrible et je ne sais pas comment le résoudre. :wacko:

La page de test est ------> ICI

Merci de me donner vos conseils ou à défaut de me dire comment cela s'affiche chez vous selon votre navigateur, vitesse de connexion et résolution d'écran.

Je suis bloqué là-dessus, c'est pénible et j'ai vraiment besoin d'un peu d'aide pour pouvoir continuer. :huh:

Link to post
Share on other sites

Bonjour,

J'ai testé avec Win XP, 1024x768, ADSL

Je n'ai pas constaté ton problème ni avec Firefox, ni avec IE, ni avec Opera :huh:

Link to post
Share on other sites

Idem chez moi, sous Windows XP Pro en 1280x1024 avec I.E. et Firefox. Pas de problème d'affichage :)

Link to post
Share on other sites

Merci Monique et Dan pour vos réponses ;)

Pas mal de personnes par ailleurs me signale tout de même ce "décalage" d'affichage de cette bordure du contenu. (comme sur l'image ci-dessus)

Je penche pour la piste du <include> utilisé pour mon header, mon pied de page mais surtout mon menu.

Dans ma version initiale (celle de ma signature), le menu est aussi en include mais il est en bas de page et je le fais remonté en le mettant en position absolu comme dit plus haut.

Ce n'est qu'en le mettant en float et avec le clear:both que je mets l'include en haut de page pour le menu.

Est-ce que cela pourrait être la cause du délai d'affichage ?

Et si oui, comme garder le float et le clear:both tout en positionnant le <include du menu> après le contenu (donc en bas de page dans le code) ?

Edited by technyweb
Link to post
Share on other sites

J'ai essayé en supprimant 2 includes et en ne gardant que celui du menu mais cela ne change rien.

Je désespère un peu. :gueule:

Il faudrait sans doute que je revois ma mise en page complète mais là, je câle et ça m'embête un peu. Je l'aime bien celle-là :wub:

Sauf idée lumineuse d'un membre, je ne sais plus trop quoi faire :rolleyes:

Link to post
Share on other sites

quel est ta version de IE , car il faut que tu sache que IE et FF n'interprete pas du tout les codes pareils , ont peut dire qu'un code sous IE ne passe pas du tout sous FF , et inverse aussi ... donc vérifie ta version de IE ... c'est ce qu'il faudrait faire selon moi ... mais j'ai aussi plutot l'impresion que c'est une image du design qu'il te manque pour arrondir les cadres non ? si c'est ca c'est ton navigateur qui bug et vide le cache puis recharge ta page ...

++

Link to post
Share on other sites

Non mon problème ne vient pas de la version de IE ni même des cadres arrondis.

Les cadres arrondis, je ne les ai que sous FF mais je le sais et ce n'est pas un problème.

Merci quand même de ta réponse ;)

Link to post
Share on other sites
Dans ma version initiale (celle de ma signature), le menu est aussi en include mais il est en bas de page et je le fais remonté en le mettant en position absolu comme dit plus haut.

Ce n'est qu'en le mettant en float et avec le clear:both que je mets l'include en haut de page pour le menu.

Est-ce que cela pourrait être la cause du délai d'affichage ?

Et si oui, comme garder le float et le clear:both tout en positionnant le <include du menu> après le contenu (donc en bas de page dans le code) ?

<{POST_SNAPBACK}>

Il est en effet probable que, sur une machine un peu lente, le traitement de la page soit suffisamment long pour qu'un affichage progressif de ce genre se produise.

Si tu souhaites inverser l'ordre de ton contenu pour obtenir <contenu> puis <menu>, tu peux conserver ton positionnement en float:

- float:right sur le <contenu> avec une largeur en %

- menu en flux de largeur donc variable selon les résolutions.

Mais en fait:

- si je ne me trompe pas, ton pied de page n'occupe pas toute la largeur d'affichage ? Auquel cas, la solution du menu en positionnement absolu est bien plus évidente.

- et finalement, ce petit problème de rendu progressif est-il vraiment essentiel au point de revoir ta mise en page ?

Link to post
Share on other sites

Bonsoir Laurent et merci beaucoup pour ta réponse.

J'ai compris ce que tu voulais dire en mettant

Si tu souhaites inverser l'ordre de ton contenu pour obtenir <contenu> puis <menu>, tu peux conserver ton positionnement en float:

- float:right sur le <contenu> avec une largeur en %

Mais je ne comprends pas quel code saisir exactement dans mon css pour ça

menu en flux de largeur donc variable selon les résolutions

et faire remonter mon menu.

J'ai essayé plusieurs solutions mais aucune ne fait remonter le menu.

Sauf à revenir à la configuration précédente, celle de ma signature, configuration que je cherche précisement à changer.

Donc, j'imagine que quelque chose à dû m'échapper dans ton explication et que je l'applique mal :unsure:

NB: Pour le pied de page, je verrais après si necessaire, c'est un peu secondaire.

NB2: le rendu progressif n'est certes pas essentiel mais est vraiment très dommageable sur certaines configurations.

J'ai beaucoup de choses à revoir et/ou améliorer (sémantiques, codes, "bonnes pratiques"...) et j'aimerai repartir sur une base "propre" visuellement pour m'attaquer ensuite au contenu page par page ;)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...