Jump to content

dj_aroy

Actif
  • Content Count

    15
  • Joined

  • Last visited

Community Reputation

0 Neutre
  1. Effectivement en regardant de plus pres j'ai mal lu, il n'existe pas de forme avec un echo. J'ai mélange avec un des codes ici : http://php.net/manual/en/function.ini-set.php Erreur sans doute du à la fatigue de toujours regarder le meme script et lignes de code. En tout cas encore merci de vos eclairages, qui m'ont été de bons conseils tout de meme et qui m'ont fait perdurer dans ma cherche. Quant à la fonction que tu donne Dan, j'avais essayé malheureusement sans que rien ne se passe à l'ecran, c'est pour cela que j'avais abandonné. Ce qui est dommage c'est de ne pas avoir trouvé o
  2. Désolé de faire les réponses à mes propres posts. Malheureusement ayant vraiment eu l'impression d'etre dans une impasse j'ai repensé le script, et finalement cela marche. Voici le code complet si jamais ca peut aider. La grosse différence réside en la séparation du code en deux requete principale pour eviter d'avoir des if else if imbriqué. Maintenant le code marche parfaitement. Je n'arrive néamoins pas à comprendre d'ou venait l'erreur. Ce qui est sur c'est qu'il y avait aucun rapport avec Recaptcha, c'etait une pure coincidence. Encore a tous merci de votre aide. <?php m
  3. En cherchant un peu notamment ici, http://php.net/manual/en/errorfunc.configuration.php la ligne exacte a ecrire était apparemment : <?php echo ini_set('display_errors', 1); ?> avec le echo en plus. J'ai donc un 1 qui s'affiche. Quel est son sens? Je ne comprend pas ce qu'il se passe quant à cette page. Depuis le départ on parle d'erreur du code source, mais n'est-il pas possible que ca vienne de mon inscription à ReCaptcha?
  4. Hello Dudu Quand j'integre <?php ini_set('display_errors', 1); ?> ce petit bout de code dans ma page, rien de special ne s'affiche. Est ce bien comme cela qu'il faut proceder? J'ai placé ce code a différent endroit dans la page et cela ne change rien. Ou faut-il exactement l'inclure? Lorsque je regarde dans le code source, la ligne n'est pas visible. Sinon la page s'affiche toujours sans sortir les elements relatifs à la requete, ni message d'erreur. Pour le code complet, il y a d'autre elements en php avec des includes. Veux tu que je poste le code complet ici?
  5. Quelques idées complémentaires sur ce probleme?
  6. Dan, une fois de plus merci de ton implication. Malheureusement et c'est un peu de ma faute je n'avais pas mis tout le script de ma page. En entier il est le suivant, sauf quelques parties de texte : <? if(isset($_POST['requete']) && $_POST['requete'] != NULL) // on vérifie d'abord l'existence du POST et aussi si la requete n'est pas vide. { mysql_connect("","",""); mysql_select_db('ac90_article'); $requete = htmlspecialchars($_POST['requete']); // on crée une variable $requete pour faciliter l'écriture de la requête SQL, mais aussi pour empêcher les éventuels malins q
  7. Je ne comprend pas vraiment ou tu veux placer tes elements. Si j'interprete ton post, voici le code que j'ai: <?php ini_set('display_errors', 1); if(isset($_POST['requete']) && $_POST['requete'] != NULL) // on vérifie d'abord l'existence du POST et aussi si la requete n'est pas vide. {... Malheureusement, lorsque j'ecris ce code j'ai alors le message : "Parse error: syntax error, unexpected $end in /home/ac90/public_html/Recherche.php on line 203" La ligne 203 est la fermeture de la balise html...
  8. Je suis chez Hosteur, et il me permet d'acceder au htaccess, puisque j'ai pu parfaitement mettre en place un URL rewriting. Ce que je trouve toujours étonnant est que le fichier en l'etat marchait parfaitement avant l'installation-desinstallation de ReCaptcha. Cela n'est-il pas la cause, avec l'entrée dans un champs de formulaire?
  9. Dan, Je viens d'effectuer cette manip en incluant la ligne dans le fichier htaccess ou j'avais aussi mis mes réecritures. Il se trouve normalement à la racine du site de mon hebergeur : /public_html/.htaccess Malheureusement si je fais cela des ma page d'accueil j'ai une erreur 500 interne au serveur. Pourquoi?
  10. Petite précision, Si comme tu l'indique, Tizel, j'ajoute <?php avant le if ce qui me donnerai cela: <?php if(isset($_POST['requete']) && $_POST['requete'] != NULL) J'obtiens alors un Parse error au niveau de ma balise </body> Comme tu me l'a effectivement indiqué j'ai ajouté avant les echo le <?php pour affichier les mots, ce qui les affiche, mais la requete n'est toujours pas executé. Tout cela est d'autant plus bizarre que dans mon fichier précédent je n'avais pas ajouter ce php et tout fonctionnait parfaitement. Pour alimenter le tout voici la re
  11. Merci de cette réponse aussi rapide Tizel. Malheureusement, l'erreur n'est pas celle-ci, car mon code était déjà ainsi et marchait parfaitement. En effet, en updatant mon ancienne page de recherche j'ai le meme probleme. L'erreur vient-elle vraiment du code source, ou alors de mon entrée dans la base de données de Recaptcha? Peut etre que je me trompe totalement....
  12. Bonsoir à tous. Je fais actuellement face à un probleme que je n'arrive pas à résoudre sur mon site http://www.actualites-electroniques.com En effet, j'ai voulu il y a quelques jours installer Recaptcha pour filtrer les commentaires sur mon site. J'ai finalement abandonné cette idée, mais je fais maintenant face à un probleme quant à mon moteur de recherche interne. Ainsi lorsque je rentre une requete sur la colonne de droite pour faire une recherche classique dans le contenu de mon site, ma page générée ne fonctionne pas du tout et le code de ma requete apparait dans le fichier source
  13. Complètement bluffé. En effet, suite à une conversion avec Dan, que je remercie beaucoup d'ailleurs le probleme a été résolu. Pour mieux identifier le problème, il fallait s'aider de cela />http://www.webmaster-hub.com/pages/outils/headers Ensuite la correction du code correspond au suivant: RewriteRule ^EN-(.*)-Dj-(.*)$ /EN-Dj-Archive.php?artiste=$1&titre=$2&rewrite [L] RewriteCond %{QUERY_STRING} ^artiste=(.*)&titre=([^&]*)$ RewriteRule EN-Dj-Archive\.php /EN-%1-Dj-%2? [L,R=301] La modification se situe sur la deuxieme ligne pour la variable titre dont la pa
  14. Re Voila apres quelques tests et changements dans le fichier je n'ai toujours rien qui marche. Pour info complémentaire j'ai bien depuis le départ ces lignes introductrices: Options +FollowSymlinks RewriteEngine on Je compte vraiment sur vos conseils et votre aide pour résoudre ce probleme, car je ne vois pas vraiment ou est l'erreur. Merci d'avance
  15. Bonjour à tous, Je suis un petit nouveau et j'ai un probleme sur mon fichier htaccess. En effet depuis quelques jours j'ai mis en place un url rewriting qui fonctionne sur le site : http://www.actualites-electroniques.com Apres epluchage de plusieur posts sur le forum et ailleurs, je suis arrivé à la déduction que pour eviter un bouclage suite à un rewriting, il fallait créer un faux parametre supplémentaire. J'en ai donc déduit avec quelques posts du forum que cela marcherait avec le code suivant: RewriteRule ^EN-(.*)-Dj-(.*)$ /EN-Dj-Archive.php?artiste=$1&titre=$2&rewri
×
×
  • Create New...