Jump to content
Sign in to follow this  
xpatval

php.ini et erreurs non-apparentes

Rate this topic

Recommended Posts

'Jour,

Tout est (presque) dit dans le titre. Les erreurs et warning, en local (easyphp 1.8), n'apparaissent pas lorsqu'il y en a. Juste une page blanche.

Dans mon php.ini, j'ai pourtant:

register_globals = Off
error_reporting = E_ALL

Qu'ai-je oublié ?

xpatval

Share this post


Link to post
Share on other sites

Salut xpatval;

essaye : display_errors = 1

;)

(tu peut aussi voir du coté (pour plus d'infos) de :

track_errors = 1

mysql.trace_mode = 1

)

++

Edited by InTech

Share this post


Link to post
Share on other sites
Salut xpatval;

essaye : display_errors = 1

;)

(tu peut aussi voir du coté (pour plus d'infos) de :

track_errors = 1

mysql.trace_mode = 1

)

++

Nein pour le display_errors (qui était à ON).

Share this post


Link to post
Share on other sites

Re ;)

Si tu tourne sous une architecture NT (NT,Server,XP), vérifie que les erreurs ne sont pas enregistré sur le journal système (dans la config php -> syslog)

Share this post


Link to post
Share on other sites

Non plus, "error_log" étant décommentarisé ...

C'est embêtant, car même en comparant avec mon "vieux" php.ini de la version 1.7, je ne vois aucune différence... :evil:

Share this post


Link to post
Share on other sites

reste toujours un éventuel probleme lié à la bufférisation

output_buffer = off

(le temps de voir les erreurs si tu en as réellement besoin)

error_reporting			 = E_ALL||E_STRICT
display_errors = On
display_startup_errors = On
log_errors = Off
log_errors_max_len = 1024
ignore_repeated_errors = Off
ignore_repeated_source = Off
report_memleaks = On
html_errors = Off
;docref_root = "/phpmanual/"
;docref_ext = .html
error_prepend_string = "<font color=ff0000>"
error_append_string = "</font>"
;error_log = filename
error_log = syslog

track_errors = On
mysql.trace_mode = On

Tu es sur de la présence d'erreurs dans le scripts ? (utile pour tester ;) )

Le script testé, il est de toi, ou c'est une récup;

Share this post


Link to post
Share on other sites

Quelques pistes au cas où :blush:

Tu relances Apache après chaque modification de ton php.ini ?

Tu n'as pas quelque part dans ton code (fichier de conf ?) un ini_set("display_errors", FALSE) ?

Pas de fichier .htaccess ou des directives PHP seraient modifiées à l'aide de php_flag ?

Share this post


Link to post
Share on other sites

Non seulement les scripts sont de moi, mais j'ai bien évidemment besoin de savoir s'il existe des erreurs, en local, plutôt que de les voir apparaître lors de la mise en ligne du/des site/s.

error_reporting  =  E_ALL
display_errors = On
display_startup_errors = Off
log_errors = On
track_errors = Off

Je relance bien apache après chaque modif du php.ini.

Je n'ai pas de fichier conf tel que Dièse le cite.

Pas de directive via un PHP_FLAG.

:evil::evil:

Share this post


Link to post
Share on other sites

peut-être dans ton css :

body {
background: #fff;
color: #fff;
}

:blush: Je dis juste ça pour te détendre un peu, je sens que ça commence à t'énnerver un peu ;)

Share this post


Link to post
Share on other sites
:blush: Je dis juste ça pour te détendre un peu, je sens que ça commence à t'énnerver un peu ;)

Un peu n'est pas tout à fait correct...je dirais plutôt énormément, car c'est franchement gênant !!

Merci, malgré tout, à vs deux

Share this post


Link to post
Share on other sites

Salut,

Voilà ce que j'active pour le debug de mes pages :

ini_set('display_errors', TRUE);

ini_set('max_execution_time', 60);

error_reporting(E_ALL | E_STRICT);

J'ai un temps aussi galéré avec ce pb.

Share this post


Link to post
Share on other sites

Et je continue de galérer..

Bon, j'ai posé directement la question sur le site d'Easyphp. En attente d'une éventuelle réponse.

Malgré tout, j'ai aussi testé à la manière de ADN, sans résultat, puisque les erreurs volontaires (variables non-définies, fichiers inexistants...) n'apparaissent toujours pas !!

Share this post


Link to post
Share on other sites

Bonjour,

Tes erreurs PHP doivent se trouver dans ton fichier log apache ;-)

Share this post


Link to post
Share on other sites

Je pense à une chose qui m'est déjà arrivé, es-tu sûr de t'intéresser au bon serveur Apache ? Beaucoup d'IDE (zend studio, phped...) ont leur propre serveur apache pour le débuggage.

Les modifications que tu fais dans ton php.ini sont-elles visibles avec un phpinfo() ?

Edited by dièse

Share this post


Link to post
Share on other sites
Bonjour,

Tes erreurs PHP doivent se trouver dans ton fichier log apache ;-)

Oui, absolument, c'est d'ailleurs comme ça que je peux les voir, mais c'est franchement balourd. Et, à moins que la gestion d'erreur soit devenu différente de la précédente version (ce dont je doute), je ne pige pas le problème.

Share this post


Link to post
Share on other sites
Les modifications que tu fais dans ton php.ini sont-elles visibles avec un phpinfo() ?

Oui, elles sont visibles. Par contre, concernant par exemple le display_errors, il est à off dans la colonne "local value", et à on dans "master value". Cela aurait-il une incidence ?

xpatval

Share this post


Link to post
Share on other sites

oui ;)

Donc je vois plus qu'une chose c'est l'utilisation de php-flag directement dans ton virtualhost. Vérifie ton fichier httpd.conf.

Je voulais te conseiller comme cogotte de mettre "php_flag display_errors on" dans un fichier .htaccess, mais je viens de tester sur mon post sous Windows et mon fichier .htaccess n'est pas interpreté alors que normalement je n'ai aucun problème... et ce matin je n'ai pas trop le temps de pousser plus loin les investigations :/

Autre chose si dans ton fichier php tu écris ini_set("display_errors", TRUE), et que dans ton phpinfo() tu vois que l'affichage des erreurs en local est à On, ce n'est pas pour autant que tu verras s'afficher les erreurs de syntaxes (du style oubli d'un point virgule), l'analyse de la syntaxe étant effectué avant la compilation de ton code et donc avant l'inclusion de ton ini_set(). C'est d'ailleurs pour cela qu'il est intéressant d'utiliser un fichier .htaccess pour modifier localement ta conf PHP :).

Edited by dièse

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...