Jump to content

Animations flash (slideshow)


Recommended Posts

Bonjour,

j'essaye d'intégrer différents slideshows sur un site. J'ai créé le slideshow dans dreamweaver, je l'ai testé et il fonctionne. J'essaye de l'intégrer dans le site. J'ai placé un dossier à la racine /slideshow/ dedans je mets mes images, le fichier .xml et le fichier .swf. Je copie-colle la partie de code html générée par dreamweaver dans mon CMS et je le lance... La page est ultra-longue à charger et mon pc freeze. J'ai tout de suite penser à un problème d'urls, j'ai fait différents tests, ça n'a rien changé...

Comment pourrais-je le faire fonctionner?

Code HTML:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="440" id="accueil" align="middle">
<param name="FlashVars" value="xmlFile=accueil.xml&preloaderBackColor=0x0099FF&preloaderBorderColor=0xCCCCCC" />
<param name="movie" value="slideshowpro.swf" />
<param name="quality" value="best" />
<param name="scale" value="noscale" />
<param name="wmode" value="window" />
<param name="bgcolor" value="#FFFFFF" />
<embed src="slideshowpro.swf" id="accueil" wmode="window" quality="best" flashvars="xmlFile=accueil.xml&preloaderBackColor=0x0099FF&preloaderBorderColor=0xCCCCCC" scale="noscale" bgcolor="#FFFFFF" type="application/x-shockwave-flash" width="440" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>

Code XML:

<slideshow loop="true" stream="true" random="true" bgColor="0xFFFFFF" flash8="false" showMute="false" margin="5" mutecolor="0xFFFFFF">
<slide url="DSC00102.jpg" duration="3" fill="squeeze" background="0x000000">
<transition effect="fade" position="0" easing="Linear" duration="2" />
<kenburns panstart="9" panend="9" zoomstart="1.3" zoomend="1.3" />
</slide>
<slide url="DSC00101.jpg" duration="3" fill="squeeze" background="0x000000">
<transition effect="fade" position="0" easing="Linear" duration="2" />
<kenburns panstart="9" panend="9" zoomstart="1.3" zoomend="1.3" />
</slide>
</slideshow>

Désolé si le code parait bordélique, il est généré par dreamweaver et j'ai essayé de mettre les urls en gras.

Merci d'avance

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...