Jump to content

Drupal, multilinguisme et wamp


Recommended Posts

Bonjour,



Mon problème: avec Drupal 7 et tous les modules qui vont avec, notamment ceux permettant le multilinguisme, j'ai une extension .fr pour le français, et .com pour l'anglais (en prod comme en local,sur mon serveur, wamp), dont le contenu est enregistré dans une seule base de données.



Avec wamp, j'utilise les virtualhost.



Pour ce faire, en LOCAL, et "rediriger" vers la langue voulue, le httpd.conf est paramétré ainsi:



<VirtualHost *:80>
ServerName geodev.com
DirectoryIndex index.php index.php3 index.php4 index.html index.shtml
Options Indexes FollowSymLinks Includes
DocumentRoot "C:/blabla/geo"
<Directory "C:/blabla/geo">
Options Indexes FollowSymLinks Includes
AllowOverride All
Order deny,allow
deny from all
allow from 127.0.0.1 192.168.
</Directory>
</VirtualHost>
<VirtualHost *:80>
ServerName geodev.fr
DirectoryIndex index.php index.php3 index.php4 index.html index.shtml
Options Indexes FollowSymLinks Includes
DocumentRoot "C:/blabla/geo"
<Directory "C:/blabla/geo">
Options Indexes FollowSymLinks Includes
AllowOverride All
Order deny,allow
deny from all
allow from 127.0.0.1 192.168.
</Directory>
</VirtualHost>

Maintenant, je dois rajouter une troisième langue (l'espagnol). Je paramètre Drupal, puis ajoute un bloc similaire à ci-dessus pour le pseudo nom de domaine .es, avec "serverName geodev.es".



Impossible d'acceder à ce site virtuel, j'ai eu beau vérifier mille fois les différents paramétrages dans Drupal comme dans le httpd.conf, l'adresse "n'est pas accessible"...



Sauriez-vous ce que j'ai loupé, oublié....?



Merci de vos réponses,



xpatval



Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...