Jump to content

skale

Hubmaster
  • Content Count

    132
  • Joined

  • Last visited

Community Reputation

0 Neutre

Contact Methods

  • Website URL
    http://www.level141.net

Profile Information

  • Localisation
    $_GLOBAL['aix en provence']
  • Société
    me, myself and i
  1. Les caractères du genre é, Ã... sont ceux que l'on rencontre lorsqu'un texte codé utf-8 est décodé en iso-8859-1 La ligne à insérer dans le header est $headers = "Content-type: text/plain; charset=utf-8\r\n"; @+ Emeric
  2. Merci, toutes les pages et seulement la langue en cours, c'était ma première idée. @+ Emeric
  3. De retour de week-end Je suis étonné que tu n'ais pas eu d'autres réponses. Le nom des images est peut-être la cause effectivement, j'en doute un peu. Dans ce cas, essaye un stripslashes, ou url_encode (si espaces, accents...) et selon le codage de ton fichier PHP pourquoi de ne pas essayer utf8_decode() ou beaucoup plus simple, pour savoir si c'est bien là le problème renomme 1 ou 2 images pour voir si elles apparaissent. @+ Emeric
  4. Bonjour, j'ai copié collé ton code, j'ai enregistré un fichier photo.php dans un répertoire x/ avec un répertoire images dans x/ et des sous-répertoires dans images Tout fonctionne très bien. Pas facile de t'aider donc Vérifie les droits d'utilisation des fichiers (sur un Système Linux), le PHP n'est peut-être pas autorisé à lire certaines images. @+ Emeric
  5. Bonjour, Petite question : Où déclarer un fichier RSS quand il existe. M'enfin je sais que je dois le déclarer dans une balise link mais dois-je le déclarer sur toutes les pages du site ou bien uniquement sur la page d'actualités qui reprend le fichier RSS (par exemple). Pour un site multilingue, est-il utile de déclarer tous les fichiers ou seulement le fichier correspondant à la langue choisie par l'internaute ? Merci d'avance. @+ Emeric
  6. Bonjour, je n'ai pas trouvé si le sujet avait déjà été abordé, merci d'avance si vous avez un lien. Sinon, j'aimerais connaître votre avis, le salon me semble le forum le plus approrié. Depuis un moment, de plus en plus d'annuaires donnent la valeur url pour l'attribut type de la balise input (on est entre webmasters non ?) pour le champ du formulaire d'inscription qui demande l'adresse du site à inscrire. De plus, cette valeur n'est pas valide (extrait xhtml1-strict.dtd) <!ENTITY % InputType "(text | password | checkbox | radio | submit | reset | file | hidden | image | button)" > Quel intérêt ? Le champ fonctionne alors de la même manière que la barre d'adresse du navigateur, du moins sur Opera qui ne garde pas en mémoire les entrées précédentes des champs qui ont l'attribut name de même valeur, avec IE ou Firefox de préciser type=url ne sert à rien. D'où vient cet engouement pour la valeur url ? J'hésite à en faire autant sur mon annuaire (en même temps c'est pas valide donc je ne pense pas le faire) mais si ça plaît... @+ Emeric
  7. J'en connais qui ont peut-être plus de chance ou bien c'est un changement de politique chez Google : Ce message m'a été transféré ce matin. Avant de fermer un compte, le webmaster sera désormais alerté ? Cette pratique, nettement moins radicale, est-elle nouvelle ? ou bien il s'agit d'une exception (première fraude ou toute petite petite petite fraude détectée ?) skale
  8. quelques précisions pour les nouveaux venus qui ne maitrisent pas l'affichage d'un flux rss avec magpie ou ceux qui ne connaissent pas RSS Voici un extrait d'un fichier RSS très simple : <channel> <title>Easy RSS</title> <link>http://www.lesiteduflux.com</link> <description>Mon premier flux rss</description> <language>fr</language> <items> <item> <title>Infos 2</title> <link>http://www.lesiteduflux.com/article.php?id=2</link> <description>Infos 1</description> <author>skale</author> </item> <item> <title>Infos 1</title> <link>http://www.lesiteduflux.com/article.php?id=1</link> <description>Infos 1</description> <author>skale</author> </item> </items> </channel> Les balises à retenir sont <channel> et <items>. Maintenant du côté de magpie, on trouve la fonction fetch_rss($rss_xml) qui va créer un objet qui contiendra les données du flux RSS. L'accès aux donnés se fait simplement avec l'objet MagpieRSS. require_once("magpierss/rss_fetch.inc"); $rss = fetch_rss($url_feed); // si la lecture s'est bien passee, on lit les elements // on retrouve <channel> avec $rss->channel et // <items> avec $rss->items if (is_array($rss->items)) { // on affiche le titre du flux echo $rss->channel['title'] . '<br />'; // on ne recupere que les 10 derniers elements $items = array_slice($rss->items, 0, 10); foreach ($items as $item) { // on affiche le titre des articles en faisant un lien echo '<a href="'.$item['link'].'">'.$item['title'].'</a><br />'; } } Pour Stef, c'est tout simple, les balises <itms:balise> (qui sont des éléments de <item> ?) se retrouvent dans le code précédent avec echo $item['itms']['balise'] . '<br />'; Itunes Music Store est une extension de définition pour RSS (Namespaces) qui ajoutent différentes balises déclaration namespaces W3C Ici réside la puissance du XML [edit]Ce post a plutôt sa place dans XML et ses dialectes[/edit]
  9. skale

    Probleme d'update mysql

    Effectivement c'est bizarre. Est-ce que quand tu valides le formulaire, il s'affiche : L'article titre de l'article a été modifié. Il y a des chances pour que $_POST['update'] soit vide donc la mise à jour ne se fera pas, tu dois cliquer sur le bouton Editer. Pour tester ce qu'envoie le formulaire, tu devrais ajouter la ligne suivante à la suite de l'include qui va afficher tous les éléments du tableau : print_r($_POST); Sinon, si tu nous a bien mis tout le code, alors il manque la balise de fermeture du formulaire. C'est juste une idée, mais c'est possible que cela pose problème @+ Emeric
  10. skale

    Probleme AJAX

    Personnellement, selon le traitement à faire derrière, je préfère créer des variables. Je voulais faire remarquer que le code PHP tel qu'il nous a été donné ne pouvait pas afficher le résultat souhaité, en supposant que register_globals est désactivé, mais c'est désormais la configuration par défaut et la plus courante et surtout celle recommandée.
  11. skale

    Probleme AJAX

    Salut, peut-être une nouvelle piste, dans le code HTML essaye de remplacer this.value par this.form.elements['doc030034941SX'].value et si tu connais le nom du champ de formulaire autant le passer en brut : <input type="checkbox" name="doc030034941SX" value="1" checked onclick="sndReq('index.php5?ac=sav&name=doc030034941SX&value='+this.form.elements['doc030034941SX'].value);" /> D'ailleurs je ferais tout passer en brut, si le formulaire est construit dynamiquement, construit aussi l'URL (sans rajouter le dynamisme du javascript pour la création de l'URL) : <input type="checkbox" name="doc030034941SX" value="1" checked onclick="sndReq('index.php5?ac=sav&name=doc030034941SX&value=1);" /> Peut-être que tu as abrégé ton code pour le présenter, mais dans le cas contraire je ne suis pas étonné que le fichier PHP ne réponde que " vaut " et il a pourtant tout bien reçu. if (isset($_GET['ac']) && $_GET['ac'] == 'sav' && isset($_GET['name'] && isset($_GET['value'])) { // 2 lignes à ajouter pour afficher $name = $_GET["name"]; $value = $_GET["value"]; echo "$name vaut $value \n"; } @+ Skale
  12. Bonjour, je vais répondre par rapport au référencement d'un site qui a commencé il y a un peu plus d'un mois (un site très jeune) Seul Yahoo a indexé le site : 90 pages à ce jour. MSN : 0, mais la commande link: donne des résultats. Google : 0 Les 3 robots sont passés sur le site, c'est le bot de Yahoo qui arrive en tête, suivi de celui de MSN et enfin de Google. En suivant ce référencement et d'autres, je me suis fait une remarque : skale
  13. salut, le nombre de résultats pour la commande link: n'a peut-être pas beaucoup bougé. Mais sur ces 2 datacenters (et autres de même sous-réseau, je fais des tests sur 64.233.171.99 et 64.233.179.99) pour une requête que je surveille de près, de 3 millions de résultats sur les autres, il y a maintenant 14 millions de résultats sur les 2 concernés, et le nombre de pages indéxées a lui doublé pour un site (euh en fait, pour moi, ça dépend des sites ou c'est 2 fois plus ou c'est 2 fois moins). ça peut expliquer le cache ancien, l'index est 5 fois plus gros, les robots ont passé peut-être plus de temps à ajouter des pages que mettre à jour des anciennes. skale
  14. mince alors. Pourtant je ne doute pas que tu avais le plugin activé. Apparemment, sauf toi Monique qui fait exception, c'est avec Opera qu'il y a un problème. Est-ce qu'un utilisateur de ce navigateur peut tester, parce que ça peut venir de ma configuration. merci
  15. Bonjour, voici un site http://www.advitam-interactive.com/ en Full Flash (ce n'est pas mon choix mais je vais devoir le référencer), j'ai rencontré des problèmes de navigation avec Opera 8.5 et précédents + le plugin Flash 8,0,22,0 et aussi avec FireFox + le plugin 7,0,19,0. Pourtant en phase de test il semblait fonctionner. Est-ce que vous pouvez tester ce site, simplement visiter 2 pages et me dire si tout est ok ou si comme moi, le menu ne fonctionne plus après un clic (vraiment dommage) et répondre par un oui ou par non avec votre OS,navigateur et version du plugin. J'espère que j'en demande pas trop, mais je ne peux pas me permettre de proposer ce site dans un annuaire si son administrateur n'arrive pas à le visiter. Merci d'avance pour votre contribution. skale
×
×
  • Create New...